locked
SNOM OCS Beta and dial out RRS feed

  • Question

  • Hi,

    has anyone tried the SNOM OCS beta version to integrate Snom phones into the OCS?
    We tried and it worked except dialing out when typing a number on the phone,regardless if internal or external, it is always forbidden. But when "dialing" the sipadress in the gui of the phone it works.
    Anyone an idea or faced the same problem?

    Best regards,
    Rene
    Wednesday, July 16, 2008 11:53 AM

All replies

  • Hi,

     

    I can call from the SNOM to other OCS users via SIP address and external like from any OCS client or regular phone by typing the external number. Calling from OCS clients and external to SNOM doesn't works because of a SRTP issue mention in the release notes.

     

    Regards,

    Peter

     

    Wednesday, August 20, 2008 6:59 PM
  • Hi,

     

    please ask Tim Köhler for the newest beta version ( tk@snom.com ) if you didnt get an email-update for it.

    His short statement: "..we fixed the SRTP issue and included a preliminary support for location profiles..."

     

    Best regards,

     

    Jan

     

     

     

     

    Monday, September 8, 2008 11:06 PM
  •  

    Hi there,

     

    Tim has provided me with the newest firmware but I'm having trouble registering my phone with my OCS lab. I've followed the instructions but keep getting a "registration failed" message.

     

    Did you have to do anything particular in OCS to have these phones work??

     

    Thanks,

     

    Jason

    Friday, September 19, 2008 3:52 AM
  • Hello Jason,

     

    I configured the SNOM 320 phone as documented (URL) in the release notes and did not change any settings on the OCS. I tested the SNOM phone in our company and on the OCS from one of our customers and it worked.

     

    http://www.snom.com/en/products/software/how-to-configure-the-snom-ocs-edition/

     

    I would be happy if you could get the SNOM working, because I need to know whether the issue I have with calls coming from the Mediation Server (PSTN) can be reproduced by someone else.

     

    I have the following build and error if I do an inbound call coming from the mediation server.

    Build: cronbuild_branch_7_3_2008_08_19_22_00_01_snom_OCS 14671

    Error on PSTN inbound calls: [0]20/9/2008 13:33:01: SRTP auth tag failure: seq-nr=983, roc=0

     

    Thanks,

    Peter

    Saturday, September 20, 2008 12:09 PM
  • Hi Peter,

     

    I'm glad you responded to my message about this. We are few and far between out there! I've tried searching just about everywhere (even within Microsoft) for help with these issues so its good to see someone else is working on this product.

     

    I ended up getting my issue resolved by simply tracing the SIP messages and making a few modifications to both the phone and OCS.

     

    1. For some reason the phone is trying to use MTLS to connect with OCS. I observed an error on my OCS server stating there were many failed attempts using an untrusted certificate from the device "SNOM".....etc. etc. Further investigation of this resulted in me creating a secondary listener on my front-end server which is set up using the same IP, but I changed the protocol to TLS and the port to 5066. This solved my "registration failed" and presented me with another issue where the phone was saying "invalid contact information".

     

    2. After close inspection of the instructions provided by SNOM (and several calls to Tim in Germany), I noticed in Step4 they show the setting "Register HTTP Contact" is turned off. Both of my phones (320/370) it was on. After turning it off I FINALLY was able to connect!!

     

    So, onto your issue......

     

    We have the same build version and I'm not sure what issues you have with your environment but here are mine:

     

    1. When I call in from the PSTN my DID goes to my Exchange UM server where the Auto Attendant picks up the call. I type in the extension of my now-signed-in SNOM phone (+8021) and it rings! I pick up the phone and NO AUDIO comes through.

     

    I can call from OCS to OCS (SNOM) and it works great.

    I can call from OCS (SNOM) to OCS and it works great.

    I can call from OCS to my Exchange UM AA and transfer to the OCS (SNOM) and it works great.

    I can call from OCS (SNOM) to PSTN and it works great.

     

    2. When I place a call on hold using the OCS (SNOM) unit, the other party shows the call being held. When I pick up the call again it HANGS UP! I've tried this many different ways and think this is a genuine bug.

     

    3. When I try to call my Exchange UM AA from my OCS (SNOM) unit, I get an error "unsupported media type" on the phone and Exchange produces an error:

     

    'The SDP media description received from the remote SIP peer could not be parsed.'.

     

    4. I'm not 100% sure how to bring up the directory but I've found that hitting the "0" key once or twice usually works. I've programmed the Directory button to do this for me so I suppose its working Tongue Tied

     

    Feel free to add my SIP URI if you wish (shavej@initechsolutions.ca).

     

    Thanks,

     

    Jason

     

     

    Saturday, September 20, 2008 4:59 PM
  •  

    !!UPDATE!!

     

    I've resolved all the issues with the following changes:

     

    1. When I created my UM dial plan I had set it to "SIP Secured" but quickly had issues with the Tanjay phones being able to dial into voice mail. I changed this to "Secured" and went on my way....

      Now that I've been working with the SNOM phones I've come across these issues and found that if I change the security setting back to "SIP Secured", it works!! I can dial voice mail, the auto attendant, and finally recieve PSTN calls with audio.
    2. The instructions on the SNOM web site show the user registration, RTP settings with the "RTP Encryption" value to "ON". Turning this to "OFF" resolved my "unsupported media type" error.

    I recently also updated my Tanjay phone to firmware version 1.0.522.101 which may have resolved the "SIP Secured" voice mail issue.

     

    Oh, and I can now place calls on hold and retrieve them!!

     

    Cheers!

    Sunday, September 21, 2008 6:17 PM