locked
[WHS 2011] Problem with Windows Update (stuck at 'Preparing to install...') RRS feed

  • Question

  • Up until 2 months ago, Windows Update on my Windows Home Server 2011 machine was working fine. However, at some point, it got stuck at downloading updates (0%). After several hours (and then days) of sitting at 0%, I eventually restarted the system. When it came back up, it appeared as if the files had been downloaded (at least Windows Update says they are when you click on the individual updates) and was now stuck at 'Preparing to install...'. I let it sit at that screen for several days again and it did not finish. After giving up on it, I did notice that when you clicked the start menu, the power menu button did have the yellow triangle icon that indicates the system needs to be restarted for updates to be installed. I rebooted the system but it never tried to install anything, either during the shutdown or when coming back up. Windows Update is still showing the sames updates need to be installed (and still shows they have already been downloaded) but it doesn't proceed past the 'Preparing to install...' screen.

    I'm not sure whether it is relevant but I've also noticed that the internet connection on the WHS box is ridiculously slow compared to the other machines in the network. I have 4 computers (including the WHS box) wired to a router. Pulling up google.com is a second or less on the other machines. On the WHS box, it can take up to 30 seconds at times (with no other devices on the network accessing anything). I haven't really looked into it since I don't normally use that box for browsing but I noticed it when searching for solutions to resolve my Windows Update issue.

    Any ideas? Thanks!

    Thursday, April 12, 2012 4:01 AM