locked
Expand Dsitribution List RRS feed

  • Question

  • Hi,
    I cannot expand AD/Exchange distribution lists. Office Communicator says:
    "Cannot perform this action, and the cause is unknown. Contact your....."

    Upon investigation from our standard edition server I browse to:
    https://hostname/GroupExpansion/service.asmx

    I invoke the ExpandDistributionList with a valid group email. I then get an http 500 error.
    If i type in an incorrect email i get xml with "notfound"

    How to i fix this HTTP 500 - internal server error?

    thanks
    Leighton

    Thursday, May 31, 2007 1:00 PM

Answers

  • Try the following:

    Click Start, click Run, type inetmgr, and then click OK.

    1. Expand ServerName, expand Web Sites, expand Default Web sites, and then expand Abs.
    2. Right-click Ext, and then click Properties.
    3. In the Ext Properties dialog box, on the Virtual Directory tab, click to select the A directory located on this computer option, click Browse to select the Address Book Files folder, and then click OK.
    4. Repeat steps 3 to 4 for Int.

    Also, verify that the directory you designate has NTFS permissions on it to allow the RTC Server Local Group Full Control over the folder.

    Thursday, June 14, 2007 1:34 PM

All replies

  • What happens if you browse to https://hostname ?

     

    Nóri

    Saturday, June 2, 2007 12:21 AM
  • browsing to it is fine.
    https://hostname      brings up the IIS under construction site
    https://hostname/groupexpansion/service.asmx    brings up the live server distribution list expander

    Nothing wrong with the IIS server. Something to do with the expanddistriubtionlist code.
    Monday, June 4, 2007 9:48 AM
  • Try the following:

    Click Start, click Run, type inetmgr, and then click OK.

    1. Expand ServerName, expand Web Sites, expand Default Web sites, and then expand Abs.
    2. Right-click Ext, and then click Properties.
    3. In the Ext Properties dialog box, on the Virtual Directory tab, click to select the A directory located on this computer option, click Browse to select the Address Book Files folder, and then click OK.
    4. Repeat steps 3 to 4 for Int.

    Also, verify that the directory you designate has NTFS permissions on it to allow the RTC Server Local Group Full Control over the folder.

    Thursday, June 14, 2007 1:34 PM
  • Cheers Chad. The IIS directories were already set correctly, and the NTFS permissions for the RTC Server Local Group  were  also there. I think by re-applying the NTFS permissions it fixed the issue.  I can now expand the email groups.

    Thanks for your help.
    Leighton
    Monday, June 18, 2007 10:20 AM
  • We had the same problem.  I verified all the settings were correct.  However, when I added the RTC Server Local Group with full control to the Program Files\Microsoft Office Communications Server 2007\Web Components\Group Expansion and reset IIS, expansion worked.  After that, I reset permissions back to the default (read/execute) and reset IIS.  We can still expand DL's.  I assume "refreshing" NTFS permission fixed our issue.

    Tuesday, November 13, 2007 5:27 PM
  •  

    I am having the same issues.  I have added the rtc local server group to both the group expansion folder and the address book files folders with full control - reset iis - reopened communicator and I am still unable to expand distribution lists.  I have also rebrowsed for the addrbook files in IIS like suggested.  When i go to the services.asmx page and put in a valid distribution list email I get the 500 internal server error.  When I put in an email that does not exist I get an XML page that says invalid list (which looks correct).

     

    Any other ideas?

    Sunday, September 28, 2008 2:46 PM
  •  

    Don't ask me how, but for my issue all I did was go to windows update on the server and rebooted and now group expansion works.  It must have been one of the .net service packs.  Now my external users are not getting galcontacts.db which is another thread : )
    Monday, September 29, 2008 1:07 PM
  •  

    I am seeing the same 500 internal error. Have looked at the permissions and virtuals and they are all correct. I ran test plans previously and all the group expansion, address book checked out fine. The only change I have made recently is to re-issue the cert as the previous PKI was rebuilt. Still working on it.
    Tuesday, October 7, 2008 12:10 AM