locked
Why no Response Group Login in Communicator? RRS feed

  • Question

  • I created a response agent group with "formal" login set.  Added myself to it.

    I know I have Communicator R2 installed as well as the attendant.  Neither one offers any kind of link, tab, or anything for me to login to the response agent group.

    I signed out, exited, slept overnight to see if some kind of update from the server was needed, but no luck.

    i"ll haveto wait until later today to see if others in the group have the same problem.
    Friday, May 8, 2009 1:11 PM

Answers

  • Try moving https://your_front_end_server.domain.com from Trusted Sites to Local Intranet zone. This should work for domain account.

    Also, be carefull how you will puch it via Domain Policy. If a user is not an Agent, a big rex X and the text "You are not subscribed to any groups. Contact your administrator to get more information." appears on the tab. You don't want few hundred people to "contact you" about this... I would create new policy and add the Agents only.

    On this issue the log you should look is the IIS log. "401 Invalid credentials" unless the https://FE server is not in the Local Intranet zone.

    Drago

    • Marked as answer by Barry Adkins Sunday, May 17, 2009 9:11 PM
    Sunday, May 17, 2009 3:09 PM

All replies

  • Hi Barry,

    The login portion of the response group actually comes from using a custom tab that you will need to configure on your client through registry settings and an xml file to get the tab to display. The attendant console has no way of dsiplaying custom tabs. The RGS tab information actually resides on the front end so its not to hard to setup. Below is an example of the xml file and the registry setting you will need. Also the link to the technet articla on settign up custom tabs is below as well.

    http://technet.microsoft.com/en-us/library/dd425110(office.13).aspx

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator]
    "TabURL"="https://<Location of xml file>/ocs_tab.xml"

    XML file example.

    <?xml version="1.0"?>
    <tabdata>
    <tab>
    <image>https://<front end FQDN>/rgs/Clients/RgsOcTab.png</image>
    <name>Response Group Tab</name>
    <tooltip>Response Group Tab</tooltip>
    <contenturl>https://<front end FQDN>/rgs/clients/Tab.aspx</contenturl>
    <userid>true</userid>
    <contactid>false</contactid>
    <siteid>1</siteid>
    </tab>
    </tabdata>

    Hope this helps.

    Cheers
    Chris


    http://voipnorm.blogspot.com/
    • Edited by VoIPnorm Friday, May 8, 2009 7:03 PM
    Friday, May 8, 2009 7:01 PM
  • Thanks for the help!!!

    Another further set of steps I found were:

    1.    Switch to Internet Explorer.

    2.    Select the Tools | Internet Options menu command.

    3.    In the Internet Options dialog click the Security tab.

    4.    Click Trusted Sites, and then click Sites.

    5.    In the Add this website to the zone field type http://OCS-STD.litwareinc.com.

    6.    If checked, uncheck Require server verification (https:) for all sites in this zone.

    7.    Click Add, and then click Close.

    8.    Click OK, and then close all applications.

    9.    Right-click the Communicator icon in the system tray and select Exit.

    I used https:// in setp 5 since our site is set to require SSL.  Also substitute your appropriate site url.

    Without these steps, it would not display in Communicator.

    -Barry
    Friday, May 8, 2009 9:56 PM
  • Now we still have a problem.

    I can see the added Tab only if I do not login to my client using my domain account.

    If I just login to the computer and then I have to supply Communicator with my Domain Credentials, the Tab shows up.  If another user or I login to the client using our domain account when communicator comes up the new Tab at the bottom does not show up.

    The website address is set to allow Authenticated users read/execute from that location.  Also I myself have Administrator rights, and I explicitly assigned the Administrator group to have "Full" permission to that site.  Still if I login to the client using my domain account, I cannot browse that site using IE nor will communicator show the tabs.

    If I do login to my computer client with a local computer account, it will allow me to browse that site with IE after I supply my domain account/password, AND Communicator will show the Tab at the bottom.

    Now I got home and logged in from home and it does not work --- even though I also at home do not login to the domain, just like on the computer at the office.  I have a vpn connection at home, so I could login to the domain which I will later and see how that works.

    I know it sounds like it has something to do with rights to that folder, but I can't find the particular problem.  Yet, at home I can browse the XML file on the server and it will list the contents of the xml file, yet it will not show the tab on Communicator.

    The server is a 2008 Standard 64 bit machine, meaning IIS 7.0.

    More treasure to search for.
    Friday, May 8, 2009 11:53 PM
  • I am getting nowhere with this problem.  It makes no sense.

    This has become our top priority because it is our last issue in our deployement.

    I need some optional Response Group agents and right now the "tab" at the bottom of the Communicator window only shows up on my desktop client where I first implemented the process.  I can't get it to work on any other computer for anyone.

    -Barry
    Thursday, May 14, 2009 4:50 PM
  • I have now verified that so long as one does not login to a client with a domain account, meaning logging into a local computer account on the client, then the tab will appear in Communicator.

    If anyone logs in to a client using the domain account, then the tab will NOT appear at the bottom of the Communicator window.

    I now do not think it has anything to do with permissions on the web server, BECAUSE when I remove ALL permissions from the folder still the Communicator tab section will appear at the bottom of the Communicator window with a message that the web page is unavailable.

    When logged into the domain account Communicator shows no evidence of offering to present the tab section at the bottom of the Communicator window.

    It is NOT a IIS permissions problem.  I think that somehow Communicator is not accessing the configuation info from the Registry.

    I'm still working on this.

    -Barry
    Friday, May 15, 2009 5:44 AM
  • I am convinced this has nothing to do with IIS.

    Some things I have found for those who might care... The registry entry for this to work [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator] kesy TebURL must be a single string key.  A multi string key will not work.

    The behavior when there is no key or an incorrect key is the same as when I setup everything correct and login to the client using the domain account.  This leads me to believe that the problem has something to do with Communicator getting the information from the registry.

    I also enabled logging and event logging in Communicator.  NO events get logged to the Event log, AND I cannot find the location of the Communicator log files.

    ANYBODY KNOW WHAT THAT SELECTION IN THE GENERAL TAB MEANS WHEN IT SAYS "TURN ON LOGGING IN COMMUNICATOR"?  I mean what in the %^&*(*& does it mean if it does not mean what it says?  I have been less than impressed with the documentation for any of this OCS software.  It seems to be great software but not well documented OR the documentation is not well indexed.

    In general we had mostly a smooth deployement, with just a few nagging issues to figure out.  I really need someone to lend a hand on this one!!!!

    -Barry

    Friday, May 15, 2009 7:36 PM
  • Barry,

    Here you go:

    Create CustomTabs.xml file in the root of your Front End server (wwwroot) with the following content:



    <?xml version="1.0"?>

    <tabdata>

      <tab>

        <image>https://your_front_end_server.domain.com/Rgs/clients/RgsOcTab.png</image>

        <name>Response Group Tab</name>

        <tooltip>Response Group Tab</tooltip>

        <contenturl>https:// your_front_end_server.domain.com/Rgs/clients/Tab.aspx</contenturl>

        <siteid>1</siteid>

      </tab>

    </tabdata>



    The TabURL string should be:  https://your_front_end_server.domain.com/CustomTabs.xml

    On the client's computer add https://your_front_end_server.domain.com to the trusted sites.

    This will do. Took me four hours last night to figure out.


    Drago

    Saturday, May 16, 2009 11:21 PM
  • Drago,

    Thanks for lending a hand again!

    I have done everything you've suggested, let me tell you what is happening...

    If I put the xml file in the root of the website it does not work.  If I put it in the Clients folder, it does work (actually I have it in both places and I just change the Registry to point to 1 or the other for testing), but only if I login to the computer using a local computer account.  If I login using a domain account the tab window will not show.

    This thing is driving me crazy more than the other problem I was having.  At least that other problem I could get some log information to be able to diagnose the problem.  This thing is like working in the dark!!!

    The odd thing, I can use IE and browse the URL and it opens the XML file no matter where I put the file, so it does not make sense that it will not work in the root, AND it does not make sense that it does not work when I login using a domain account.

    Do you know where the MOC log file is located?  I turned on logging, but I can't find a log file for it.

    -Barry
    Sunday, May 17, 2009 6:16 AM
  • Try moving https://your_front_end_server.domain.com from Trusted Sites to Local Intranet zone. This should work for domain account.

    Also, be carefull how you will puch it via Domain Policy. If a user is not an Agent, a big rex X and the text "You are not subscribed to any groups. Contact your administrator to get more information." appears on the tab. You don't want few hundred people to "contact you" about this... I would create new policy and add the Agents only.

    On this issue the log you should look is the IIS log. "401 Invalid credentials" unless the https://FE server is not in the Local Intranet zone.

    Drago

    • Marked as answer by Barry Adkins Sunday, May 17, 2009 9:11 PM
    Sunday, May 17, 2009 3:09 PM
  • The specific solution to my problem was to add the site to the "Local Intranet Zone" when the user logs in to the client using a domain account instead of a local user account.

    I am not sure why it would not work when loaded in the root folder, but I prefer not putting it there anyway.

    Your help has been very valuable!!

    -Barry
    Sunday, May 17, 2009 9:13 PM
  • This is frustrating. first of all, the [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator] key does not even exist on my machine. I added the Communicator key and the TabUrl value and no luck. I can get to the tab from a browser but not from communicator. Any ideas? Thanks.
    Thursday, October 1, 2009 9:02 PM