Problem importing managed solution RRS feed

  • Question

  • Attempting to import managed solution.  It's a very simple one with an entity and the icons, simply to bring the entity into a managed state.  However, I get hit with the following error

    Found 17 dependency records where unmanaged component is the parent of a managed component. First record (dependentcomponentobjectid = bfbf6314-fc2a-e111-b2e7-005056902aad, type = AttributeMap, requiredcomponentobjectid = a57aa80a-fc2a-e111-b2e7-005056902aad, type= EntityMap, solution = 75750d54-d52a-4662-9426-d2c36cde2a59).

    I get hit with the same error with another, larger managed solution.  Same error, same ids in the error.

    Due to integration reasons, I don't want to leave any entities in an unmanaged state so need to troubleshoot this.  Can anyone advise me on what I need to look for?  Searching around the forums, led me to investigate the custmizations.xml and all AttributeMap tags are empty.


    Friday, May 25, 2012 2:20 PM

All replies

  • in your solution, if you click on an entity and then click the button Add required components it will add the other required components to your solution.  you may want to try this on all the entities to make sure all the required components are added.

    you solution probably has dependencies on other parts of CRM which you have not included in your solution, so when it tries to create the solution on the import it is missing.

    Ben Hosking
    Check out my CRM Blog
    Linked-In Profile
    Follow Me on Twitter!

    Monday, May 28, 2012 11:02 AM
  • Hi

    Try to create a new managed solution with all the necessary components.  When adding components to the solution, make sure that you add all the necessary dependencies to the solution.

    Export and import.

    Please vote if you find my post useful. Add me on Skype @ christo.skype1

    Wednesday, May 30, 2012 1:30 PM