none
Promise RAID Controller RRS feed

  • Question

  • I Have  Promise 20265R controller onboard my MSI K7T Turbo Limited Edition Mainboard in my Windows Home Server.
     
    Unfortunately I can not get any drives to be seen by the machine. There are no drivers for Server 2003, so in the past I have used the Windows XP drivers and all was well (in both raid and non raid configurations).
     
    I have tried WinXP and Win2K drivers, which work (according to device manager) and the drives are seen in the bios. also, I have tried using cable select (CS) on the drives, and also jumpering them into place with Master and Slave setups (I have seen issues with CS on this controller before).
     
    Anyone got anything to say about this? IE do you have the same chipset? Different chipset, same problem? anything at all of use?
     
    I don't know if theres a hardware list avaialable, if there is can someone please point me in the right direction?
     
    if my on board chipset doesnt work, I need to go buy a PCI IDE controller that is definately SVR2003 compatible.
     
    cheers
     
    Russ
    Wednesday, February 14, 2007 2:49 PM

Answers

  • We have found that most Windows Server 2003 drivers will work correctly on Windows Home Server.  There are no hardware compatibility lists specifically for Windows Home Server yet.

    I would need more detailed information about your setup then already shown to give a more solid answer, but based off of what I have read here, you will need to purchase a Windows Server 2003 supported controller card.

     

     

    Wednesday, February 14, 2007 7:15 PM
    Moderator

All replies

  • We have found that most Windows Server 2003 drivers will work correctly on Windows Home Server.  There are no hardware compatibility lists specifically for Windows Home Server yet.

    I would need more detailed information about your setup then already shown to give a more solid answer, but based off of what I have read here, you will need to purchase a Windows Server 2003 supported controller card.

     

     

    Wednesday, February 14, 2007 7:15 PM
    Moderator
  • Is there an option in the BIOS to set the controller mode to 'Native IDE' or 'Legacy IDE' or something like that (and not RAID or AHCI)? That should dumb it down enough that built-in Windows drivers work.

    If you're hunting for custom drivers, you may need Vista-friendly ones for setup since it's the new WinPE. I've noticed that things like my network card are happily recognised in setup but then not supported natively in WHS itself.

    Thursday, February 15, 2007 12:25 AM
  • Is there anything like a hardware compatability list for Windows 2003?  Looking through IDE cards on newegg I'm not seeing any that call out Windows 2003 support.
    Thursday, February 15, 2007 6:04 PM
  • Don’t know if this helps – but I did have a similar problem.  I decided to pull an old computer out of my closet that met the minimum requirements.  The system had a Promise 100 IDE RAID.  After starting the installation, it of course complained that no drives were detected.  I loaded the device drivers from Promise’s website on a floppy and directed it to the Windows 2000 drivers.  It asked me if I wanted to have the drivers available in the text phase of the installation, and I chose “Yes”. 

     

    It then completed the 1st stage of the installation (formatting the drives, coping data, etc) and rebooted into the old NT style blue install screen.  When it got to the “Starting Windows” section, it blue-screened.  I went back and re-started the installation using the XP drivers, with the same luck. 

     

    I then decided to hit the F6 option when the text setup started to specify the drivers again.  This time the installation finished with no problems.

    Thursday, February 22, 2007 6:32 PM
  • I also had a similar problem, on an ASUS A7V333 motherboard. To resolve the problem I had to move the HDD's onto the motherboards non-raid IDE ports and disable the Promise BIOS. WHS then installed no problem. I don't intend to try and re-enable the Promise controller at all.

    This setup works great..

    Friday, March 16, 2007 9:28 AM
  • I also have the problem that I cannot get WHS to recognise my Raid controler, a Promise Fasttrak S150 TX2plus. I get an an error message saying that no harddrive was found to install WHS on. I am then asked to select a driver. I have downloaded the Windows 2003 driver from the Promise website, but when I select that I get the same error message again. Apparantly it is not the correct driver? I have also tried the Windows XP/2000/NT4 drivers but with the same result.

     

    PS I have read something about pressing F6 at some stage, but when I try thyat nothing happens(?)

     

    Any help or hints would be much appreciated.

    Sunday, April 22, 2007 2:24 PM
  • Nico,

    You should get two opportunities to load drivers. With the CTP version, you need the same drivers both times: Windows Server 2003. The driver you probably need to download is here, and you'll need to put the contents of that .zip file in the root of a floppy or flash drive.

    The first time you're asked for additional drivers is at the beginning of setup, during the WinPE portion. Once the driver has loaded, you may have to click the Back and then Next buttons to see any drive(s) attached to your add-on card. (If your system isn't set to be able to boot from that card, and there are no drives except the ones connected to it, you may not see any drives at all. If you can't boot from the add-on HBA, you'll have to connect a drive directly to the motherboard to install to.) Continue through the WinPE setup until you're prompted to reboot.

    The second time is after the first reboot, near the beginning of text mode setup. There's a prompt at the bottom of the screen that says

    Press F6 if you need to install a third party SCSI or RAID driver...

    The moment you see that prompt, press F6. (You only have a few seconds.) Insert the disk with the drivers again and load the driver. You should be able to complete the installation at that point. If you miss the F6 prompt, reboot your PC and restart. (I usually have to do that about every third Windows install on systems with add-on storage controllers...)

    Please let us know if you continue to have installation problems.
    Sunday, April 22, 2007 4:53 PM
    Moderator
  • Hi Ken,

     

    First of all, thanks for your quick response, really appreciate it.

     

    I have gone to work with your instructions. The driver you mentioned was one of the ones I tried so I have used that again. But I do not seem to get passed the intial phase. One of the things I have changed is to put the driver into the root directory of my USB stick (the system is a Shuttle with no floppy drive).

     

    Now first I get the error message "Unable to load V:\fasttx2k.INF (Error 0x80070002)"

     

    Then when I try again I get the error "The provided driver cannot be used to complete setup: txtsetup.oem was not found".

     

    Retrying to load the driver does not help and finally I have to abort the installation.

     

    You mention in your answer the use of Next and Back buttons, but I do not see any of these ;-(

     

    Any clues?

     

    Cheers,

    Nico

    Sunday, April 22, 2007 6:02 PM
  • Nico


    I have that same Promise SATA card.  I haven’t tried that specific one, but I have used a S150 TX4 with WHS, so 4 SATA ports and no IDE port on my card. 

     

    Make sure that you are specifying the TXTsetup.OEM in the root directory, and the file folder paths left the same for the files that Ken asked you to download.  That should select the correct driver for you.  Also make sure that you are using the latest BIOS level for the card.  Promise added Server 2003 support to some of their cards after the initial release.  It appears that the last BIOS for that card is 1.00.0.37.  The download is available from Promise.com here.

    Wednesday, April 25, 2007 2:06 PM
  • Well it looks like I'm going to have to eat my words from yesterday.

    I attempted to install on a promise Fasttrack S150 TX2+ last night, and it was unsuccessful.  I received the same error message with three different drivers that I downloaded from Promise. 
    "\$WIN_NT$~BT\$OEM$\WINXP\FASTTX2K.SYS" could not be loaded.  Error code 14. 


    Thursday, April 26, 2007 3:31 PM
  • I did not get that far myself yet. The first step I took yesterday evening was to try to install the new driver on the RAID controller (thought that was a good suggestion) but I am still stuck in that process because my server for now is using Linux (very curious to see if the change to WHS will make me more happy :-) and I had to install the driver from Windows or DOS. Since my server has no floppy drive I first had to create a bootable USB-stick. It took me a couple of hours to find out how to do that (having only Windows XP computers and the Linux server at home that turns out to be a non-trivial task). Then when I finally managed and booted the system from the stick it turned out that the new BIOS can *only* be installed from a floppy, not even from a USB-stick ;-(

     

    So my next step will be to install a floppy drive (I did not take one when I bought the system because there was no room when you are having two hard disks) and then proceed to follow your suggestions. Your message is a bit worrying me regarding my changes for success but I will try anyway. I will let you know how it goes....

    Thursday, April 26, 2007 3:56 PM
  • I got quite a bit further, thanks to the replies from Ken en Kerros11.

     

    I installed a floppy drive which enabled me to update the BIOS of the FastTrak S150 TX2plus.

     

    Then I got to the point where Kerros11 had a problem still not being able to install the driver. It worked for me though, the essential point perhaps is that the driver is on a floppy (and not on e.g. a USB-stick?).

     

    So WHS went on installing until I got at the F6-point (the second installation point for the driver). I pressed F6 and tried to install the driver (again). However, this failed because WHS could not find the driver any more on the floppy. So I am a bit puzzled here, I am pretty sure that all the files are in the right place.....

     

    Any clues would (again) be appreciated :-)

     

    Nico

    Saturday, April 28, 2007 4:58 PM
  • I ran into the same problem with the Promise FasTrrak SATA300 TX4.  I am using an old Dell Dimension 8100 (P4 1.4 GHz, 768 MB of RDRAM) with 2 new 500 GB SATA drives, but no matter what I do, WHS refuses to install on these drives with this controller.  WHS will accept the drivers I downloaded, and can even see the drives (I can see this in the error report).

    So, hooked up an IDE drive in addition to the 2 SATA drives.  When I set the HD sequence to BIOS boot items first, WHS starts to install.  It can see all 3 drives, and it appears to be willing to install with the IDE drive as the primary OS partition.  However I get a blue screen on the first reboot.  It prompts to press F6 to load additional drivers, but for some reason it doesn't respond when I press F6 (no matter how fast, or how often I press F6).

    I guess I'll have to pull the SATA controller in order to install WHS, then add it later.

    Tom V
    Thursday, May 10, 2007 3:37 AM
  • Well... that didn't work either.  Now I can't even boot from the DVD any more.  This is very strange.  The keyboard works when I boot up (to enter the BIOS setup, or to enter a password), but doesn't appear to recognize F6 when WHS tries to continue the install from the HD.  After disconnecting the Promise controller and SATA drives I can't boot from DVD any more (to re-start the WHS installation process).  If I set the boot sequence to the DVD drive first, and disable the HD from the boot sequence, booting up just fails.

    How could WHS possibly force my PC to not boot from the DVD?  Why does pressing F6 not work?  Inquiring minds want to know...

    Tom
    Thursday, May 10, 2007 5:05 AM
  • Tom, I'm afraid I cannot help you with this one, although I must say that I have had the problem with not wanting to boot from DVD any more either. For my rebooting a couple of times worked even though I did not change the BIOS in the mean time. Very odd.

     

    Well anyway I decided to give up on the Fasttrak controler and installed WHS on a single disc. In fact I had to use an old IDE disc I had laying around somewhere for that because the two SATA discs originally connected to the RAID controller cannot be used anymore because the mother board of the Shuttle server I have only supports IDE ;-(

     

    And I realised that I probably don't really need the RAID controller after all because the purpose I used it for (data safety) can probably also be realised with the WHS "Folder duplication" facility. So now I am going to experiment with that a bit.

     

    Cheers and good luck,

    Nico

    Thursday, May 10, 2007 1:58 PM
  • Thanks Nico.  My old IDE disc was 76 GB... supposedly adequate according to the Getting Started Guide (which says at least 70 GB), but not adequate according to older specs (which say 80 GB). 

    I found this post helpful... http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1549633&SiteID=50
    I abandoned my old IDE drive.  By unplugging 1 of the 2 SATA drives, I was able to get the install to work.  I also had to switch to version 1.00.0.31 of the Promise Driver (instead of the newer version 1.00.0.33).  With the newer driver I couldn't get past the first reboot.

    Tom




    Saturday, May 12, 2007 12:46 AM
  • My old school Promise FastTrak100 TX2 has drivers, not included with WHS, that I had to download from the Promise site and use during install. Everything seemed to work fine, tho the install had an issue when I tried using the XP drivers while installing WHS Beta 2. This was resolved by using the Windows Server 2003 compatible version of the drivers.

     

    When WHS comes out, is it going to be advertised that Windows Server 2003 drivers are the ones to look for when checking hardware compatibility for older hardware? I feel like that could cause some confusion.

    Monday, June 18, 2007 4:52 AM
  • I'm having similar problems with my Promise FastTrak Tx4310 card (4x SATA) and all sorts of weird *** is happening.  At first after I defined an array (4x320gb in RAID5), it wouldn't boot into Windows.  I removed everything but the primary hard drive from the boot order and it worked, for a day or so.  Then WHS reported the RAID drive was failing, even though the raid reported that all the drives were fine.  It gave me the option to repair the drive, so I said ok.  Then it didn't work.  It stopped and I couldn't remote in or open the console.  When I rebooted, I couldn't boot into windows anymore.  A bunch of other stuff broke in WHS after that - the backup service stopped and wouldn't start again, all sorts of errors.

     

    That's the way it stayed.  Even after a reinstall.  If there's a RAID array defined, it just stays on a black screen and never goes into the bar loading screen.  I tried to reinstall the first time, loaded the RAID driver during the install and that was working fine, but before it went through, we cancelled it to try something else.  Now I can't get it to do anything.

     

    If there's a RAID array defined when I try to install Windows or boot into the OS, it does nothing.  I can boot into debian or any other OS and have it be fine, but yeah. 

     

    Irritating!  I've tried new drivers, new BIOS, everything.  Any suggestions?

    Monday, August 20, 2007 2:20 PM
  • I also have a Promise SATA 300 TX2plus card in my machine. My mother board only has 2 SATA ports so I used the Promise card to add 2 extra SATA ports to my machine. This card has an IDE port and two SATA ports.

     

    Durning the build of my WHS I only had two SATA drives hooked up to the motherboard and installed the WHS on those, patched up and all and it was up and running. I did have the Promise card installed but no drives hooked up to it at first.

     

    Shut down the machine and connected the other two drives to the SATA ports on the Promise card and started up. No drives for the Promise card show up at first in the drive pool. Went to device manager and updated drivers from a floppy and the two drives showed up in the drive pool right after that. I only used drivers that came on the CD with the Promise card and made a floppy from that. Good thing I had an old floppy drive laying around to do this with.

     

    I did not put those drives in a Raid, even though it says atsome point they are raid drives. I simply added each drive one at a time to the drive pool, which formated them and off they went.

     

    Tuesday, August 21, 2007 1:40 PM
  • I apologize for being a bother but I am having a heck of a time downloading the promise fasttrak 100 driver for window 2003 server would you please send it to me at j_criscuolo@hotmail.com.

    thank you very much

    respectfully

    joe c

    Saturday, September 29, 2007 2:46 AM
  • The only safe place to get a driver for a Promise Technology product is the Promise Technology web site. While it appears to be down now, you should be able to get a driver there once the problem has been resolved.
    Saturday, September 29, 2007 4:48 AM
    Moderator
  • Did anyone manage to find a solution for the problems above?  I am having a heck of a time trying to install Windows Server 2003 on a FastTrak TX4310.  I followed the correct procedure:

    1. Inserted the Windows Server 2003 CD and booted from it.
    2. When it asked to press F6, I did so.
    3. Loaded the correct drivers via floppy.
    4. It let me format my drives.
    5. It copied all installation files onto the HDD.
    6. Reboots after all files are copied.

    After step 6, when it reboots to continue with install, it just stalls on a black screen with an "EB" at the bottom right hand corner.  I've checked my bios and can't figure it out.  When I reboot again, I can press Space Bar to skip the test it's stalling on and it goes back into the Setup Mode, as if I hadn't installed anything onto the drives.  I've even changed the bios to boot from the HDD and not the Disc.  Even removed the disc to verify.  No such luck.  Is Promise Technology Inc, just a cheap company that I shouldn't be dealing with?  Please advise.

    Saturday, November 10, 2007 10:59 PM