locked
User Mapping Error in Microsoft Dynamics CRM 2011 RRS feed

  • Question

  • Hi, 

    I have restored Production CRM 2011 Database without any data in tables in test environment and inserted records in BuildVersion, BusinessUnitBase, SystemBaseUser , RoleBaseIds and SystemUserRoles. And then tried to import the organization using this database in CRM 2011, but still getting below error in User Mapping. I tried with XML also, but getting same error. Could anyone help on this.

    And also May I know what are the tables should have record to import organization. 

    Error: "You must map your Active Directory user account to at least one enabled Microsoft Dynamics CRM user who has the System Administrator role before the organization can be imported."

    Please help.


    Wednesday, May 24, 2017 5:15 AM

All replies

  • Hi Krituka.

    It's pretty simple, the domain user your using(logged on as) to perform the "re-deploy/import" as needs to be mapped to an existing user that has the System Administrator role in that org db you are importing.
    You can basically map the account to any of the available CRM user that has the System Administrator role.
    Use the  Manual mapping option, search for an CRM user that has the System admin role, check the column on the right of that user, and then click browse AD and add the user ur currently running the import as.

    That should solve the problem.

    BR. /Philip
    Thursday, June 1, 2017 8:33 PM
  • Hi Kirutika

    Did you get this sorted out?

    BR. /Philip
    Thursday, July 13, 2017 8:36 PM