locked
Workflows not triggering in "same Domain" Test Environment RRS feed

  • Question

  • My issue appears to be that I can't get workflows to fire once I have created a test environment for CRM 4.0.  The test environment is in the same Domain as the Production servers.

    I have been trying to create a test environment by restoring the production server DB to another server in the same domain. I have tried a lot of stuff to get the workflows to trigger, but something is still missing.  Below I have listed my steps to restoring the DB and installing the CRM 4.0 application.  Please let me know if I may have missed something or if I need to change my procedure.

    1. Restore DB to CRMDB Server
    2. (From a clean server and OS) - Add Roles to Server Manager to CRMApp Server
    3. Install CRM 4.0 Server to CRMApp server
    4. Install CRM 4.0 SSRS Connector to CRMDB server
    5. Install Exchange MAPI Client and CDO to the CRMApp server
    6. Install CRM 4.0 Exchange Router Setup
    7. Because this is a restore in the same Domain - Edit the Registry - http://support.microsoft.com/kb/952934 - For the database and metabase subkey I make the Initial Catalog = <organizationName>_MSCRM
    8. Run the Email Router Configuration Manager
    9. Install Rollups - UR 17 (Server, SRS, Router)
    10. Update the MSCRM_CONFIG.dbo.DeploymentProperties table so that the 'AsyncSdkRootDomain', 'ADSdkRootDomain', and 'ADWebApplicationRootDomain' = CRMApp test server (and not the Production server)
    11. Run Deployment Manager Update and redirect the Organization to the CRMDB test Server - http://support.microsoft.com/kb/952934

    If you need some details about any of these steps let me know.  Thanks for any feed back.


    -Ben M
    Tuesday, July 5, 2011 2:04 PM

Answers

  • IF you follow the steps in this article, you should be successfull.  It should be fairly uncomplicated.  At a high level, Install the CRM Server on the test server with a Test Org, restore the production db to the test server db, disable the original organization on the Test server using Deployment Manager, Import the restored production db using the Deployment Manager and give it a different name from Production.

    Try installing just the test server and do the import then see if workflows fire.  Once you confirm everything is working, then begin installing the other items.  Ensure the Update Rollup on the Test server and Production server match before restoring or importing the db.

     


    Regards, Donna

    • Proposed as answer by Donna EdwardsMVP Wednesday, July 13, 2011 1:39 PM
    • Marked as answer by bjmorch Monday, July 18, 2011 7:14 PM
    Tuesday, July 12, 2011 6:16 PM

All replies

  • Hello.

     

    Try the following

    http://support.microsoft.com/kb/968793

     

    make sure the async service has been started and is not crashing

    Tuesday, July 5, 2011 2:17 PM
  • Thank you TD for the reply.  This does not appear to be the cuase of the issue.  I have restarted the async service and it has been running ever since without any crashes.  Let me know if you have any other suggestions.

     

    Thanks,


    -Ben M
    Tuesday, July 5, 2011 8:46 PM
  • IF you follow the steps in this article, you should be successfull.  It should be fairly uncomplicated.  At a high level, Install the CRM Server on the test server with a Test Org, restore the production db to the test server db, disable the original organization on the Test server using Deployment Manager, Import the restored production db using the Deployment Manager and give it a different name from Production.

    Try installing just the test server and do the import then see if workflows fire.  Once you confirm everything is working, then begin installing the other items.  Ensure the Update Rollup on the Test server and Production server match before restoring or importing the db.

     


    Regards, Donna

    • Proposed as answer by Donna EdwardsMVP Wednesday, July 13, 2011 1:39 PM
    • Marked as answer by bjmorch Monday, July 18, 2011 7:14 PM
    Tuesday, July 12, 2011 6:16 PM