locked
CRM upgrade to 2011: Key not found RRS feed

  • Question

  • Hello,

    I tried to upgrade CRM 4.0 Professional to CRM 2011 with these steps:

    - Installed fresh win 2008 r2 server with CRM 2011 prof and SQL 2008r2

    - Configured a test crm 2011 environment, this works

    - backupped the crm 4.0 databases from the production server and restored them on the new server, rebuilded indexes

    - import wizard from crm 2011 mmc, a couple of warnings but no errors

    After some time the upgrades fails with:

    >Crm Exception: Message: Het importeren van de organisatie (id=5fd09a8b-0385-df11-9a83-005056a31bca) is mislukt. Uitzonderingsfout:
    Microsoft.Crm.CrmException: Het bijwerken van de organisatie met de id 5fd09a8b-0385-df11-9a83-005056a31bca is mislukt met de uitzondering:
    System.Exception: Actie Microsoft.Crm.Tools.Admin.UpgradeDatabaseAction is mislukt. ---> System.Reflection.TargetInvocationException: Het doel van een aanroep heeft een uitzondering veroorzaakt. ---> System.Collections.Generic.KeyNotFoundException: De gegeven sleutel is niet aanwezig in het woordenboek.
    bij Microsoft.Crm.Metadata.PreloadedMetadataInitializationContext.GetEntityProvider(Guid entityId)
    bij Microsoft.Crm.Metadata.PreloadedMetadataCacheDataProvider.AddRelationshipsToCollections(IPreloadedMetadataInitializationContext context)
    bij Microsoft.Crm.Metadata.PreloadedMetadataCacheDataProvider.Initialize(IOrganizationContext organizationContext, MetadataContainer container, LoadMasks masks)
    bij Microsoft.Crm.Metadata.DynamicMetadataCacheLoader.CreateMetadataCacheDataProvider(MetadataContainer container, IOrganizationContext context, LoadMasks masks, CounterList counter)

    ==> free translation:

    System.Exception: Actie Microsoft.Crm.Tools.Admin.UpgradeDatabaseAction has failed. ---> System.Reflection.TargetInvocationException: The target of a call has triggered an exception. ---> System.Collections.Generic.KeyNotFoundException: The defined key is not present in the dictionary.

    I've done a second attempt, (deleted databases, restored again, built indexes again) and started a trace with the crm 2011 diagnostics tool. However, the same error pops up.

    Anyone have an idea?

    Thanks


    it's all very nice when it works
    Wednesday, June 29, 2011 9:17 AM

Answers

All replies