none
Nuget: 'Google.Apis' already has a dependency defined for 'Google.Apis.Core' RRS feed

  • Question

  • I'm facing the following error in NuGet while trying to install package Install-Package Google.Apis.Drive.v3 -Version 1.37.0.1470. Showing following Error:

    Install-Package : 'Google.Apis' already has a dependency defined for 'Google.Apis.Core'.
    At line:1 char:17
    + Install-Package <<<< Google.Apis.Drive.v3 -Version 1.37.0.1470
       + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
       + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    if i install previous version Install-Package Google.Apis.Drive.v2. Also showing same Error:

    Install-Package : 'Google.Apis' already has a dependency defined for 'Google.Apis.Core'.
        At line:1 char:17
        + Install-Package <<<< Google.Apis.Drive.v2
           + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
           + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

    I'm using Visual Studio 2012, .net framework 4.5 and NuGet package manager 2.8.6031.8.667. Please help me how to solve it.

    • Moved by CoolDadTx Thursday, January 24, 2019 8:37 PM Third party product
    Thursday, January 24, 2019 4:28 PM

All replies

  • This forum is for C# specific questions. Please post your question in the GitHub repo for this package.

    Michael Taylor http://www.michaeltaylorp3.net

    Thursday, January 24, 2019 8:37 PM