locked
Remote Access not working anymore RRS feed

  • Question

  •  

    Hello,

     

    I've seen a lot of issues with Remote Access on several forums but all related to problems with port forwarding on routers. My router is setup fine and Remote Access also worked for a while. But since a few days I cannot connect to the remote access website anymore. This is also the case when I try to connect to it from within my local network, even from my server itself. My Home Server URL is: http://mcoffereins.homeserver.com. The WHS redirects to: http://mcoffereins.homeserver.com/home/default.aspx?gotodefault=true but then is stops.

    Looking in the EventViewer I cannot find any related messages. All services needed seems to be up and running. To be sure I rebooted the WHS.

    Actually it was the WHS itself that noticed this problem and warned me by a Network Health Notification. When I go to the Remote Access tab on the WHS settings page in the WHS Console, then the Router status is not OK. All the tests (upnp, port forwarding, domainname, websites running) passes but the last test (Remote Access) fails.

    I'm afraid the clue to this issue is the fact that I renamed my WHS from it's standard name SERVER to MCSERVER (all my infrastructure equipment hostnames starts with my initials MC, thats why...). Can anyone confirm? Better, does anyone knows a solultion other than completely reinstall the server? Is there a way to turn on logging/debugging for Remote Access?

     

    Thanks in advance!

     

    Marco Offereins

    Apeldoorn, the Netherlands.

     

    Friday, March 14, 2008 12:38 PM

All replies

  • Can you use a site like Shields Up! to test your ports? Port 443 must show as Open, and 4125 as Closed, for remote access to work at all. Port 80 should be Open as well, but you can do without if need be.
    Friday, March 14, 2008 1:06 PM
    Moderator
  • Hello Ken,

     

    Thanks for your quick response! I'm not at home, so I cannot test it right now. But since I'm a network engineer for a living, I already did some testing. Netstat -na in a cmd-box on the WHS shows the WHS is listening on ports 80 and 443 TCP. Port 4125 TCP is NO.

    I can connect remotely to my router. It is configured to log any packet that is dropped by hitting a firewall-rule. There is no logging of any dropped packets directed to port 80 TCP or 443 TCP.

     

    - Marco

    Friday, March 14, 2008 1:17 PM
  • I have seen threads with local machine connectors being unable to reach the server after a server name change but not the website.   Can you still browse to the server website via the server name on your internal network, http:\\mcserver?  Or via the server IP or local loopback on the server? 

    Also maybe check IIS?  I've never actually looked at the WHS IIS website but perhaps there's a server name somewhere in the default website config.
    Friday, March 14, 2008 5:11 PM
  • I noticed that you can receive the homepage of the WHS by entering the URL followed by home/ thus: http://mcoffereins.homeserver.com/home/ . But when you hit the Login button you see the same result as described earlier.

     

    I checked all the aspx files down in the inetpub dir for clues (I'm not familiar with aspx of C# so it took a while  )

    I also checked all the logfiles of IIS in c:\windows\system32\logfiles - same result (like in 'no result')

     

    Furthermore I made a visit to Shields Up! The results confirmed that (only) port 80 and 443 (TCP) are open.

     

    Unless someone comes up with a new hint soon I will reinstall the WHS shortly. That is because my WHS is configured with two hard disks  so I'm vulnerable for the 'demigration' bug (which isn't actually a bug, I know).

    Monday, March 17, 2008 12:20 PM
  • Any chance that you fixed this issue? I'm currently experiencing the same thing.

    Thanks.
    Thursday, December 3, 2009 2:54 AM