locked
Router help needed. RRS feed

  • Question

  • For the life of me I cannot get my remote web access turned on any more. I'm pretty sure it's a router issue but I'm not 100% sure of that at the moment because my SQL server for My Movies is also screwed up at the moment. During setup of web access it hangs on setting up the router. 

    I've tried 3 linksys routers EA4500, E4200 and WRT54GL with DD-WRT on it. Tried setting up with upnp and manual port forwarding.  At this point I don't know whether to try a server reinstall or a different router.

    If a different router what options are known to play nice? I need something that has dualband, gigabit LAN and USB printer port. 

    Monday, February 4, 2013 6:25 AM

All replies

  • Hi Mouseskowitz,


    Firstly, please verify that your Home Server connects to the router directly. Also, please check if port forwarding are correctly configured via UPnP or manual.


    Details: How do I troubleshoot Remote Web Access connectivity?


    More information:

    Windows Home Server Router Setup


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Wednesday, February 6, 2013 9:24 AM
  • I have the same problem no matter how I try to set it up. If I have have UPnP on it hangs on the "setting route up" and it does that even if I check the box that I will manually set the router up. It still does it with the ports manually forwarded. And when I say hangs I mean that I have left it overnight and it is still stuck. Using nmap the I can see that the ports are open and that on 80 and 443 it shows my .homeserver.com address. However I cannot get past the above mentioned portion of the setup wizard to turn remote web access back on. I have previously had it working with WHS 2011 and v1 on this machine. Oh, and it is directly wired to the router. At one point I was able to get UPnP to setup on the E4200 by doing a 30-30-30 reset but that would only last a few days before the server would come up with a remote web access error. I'm suspecting that it might be an OS issue but I need to find a way to confirm that before going through the effort of a reinstall, and a fix that would prevent that would be even better.
    Wednesday, February 6, 2013 9:28 PM
  • Hi Mouseskowitz,


    Based on my research, please also manually make the following ports forwarded in you router configuration and open in the firewall. Then, please test the issue again.


    65500: Certificate web service

    65510 and 65515: Client computer deployment website.

    65532: Provider framework for server loopback communications.

    6602: Provider framework for communication between the server and client computers.


    Also, please check if the following similar threads could help you:


    Home Server 2011, Can't complete remote acces wizard

    Windows Home Server 2011

    Are you having trouble setting up WHS2011? Remote Web Access, Router setup

    Setting up Router Hangs

    Remote Web Access Wizard: Skip router setup checkbox not working


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Monday, February 11, 2013 7:17 AM
  • Jeremy, none of those ports are needed for remote access. The only truly required port is 443, and 80 is nice to have but often blocked by ISPs.

    To cmpletely eliminate the router, the OP should:

    1. turn off UPnP in his router.
    2. assign his server a static IP address in his router's internal IP address range but outside it's DHCP range (preferred), or make a DHCP reservation for his server.
    3. manually forward ports 80 and 443 from his router to his server.
    4. verify that his broadband modem is not also acting as a router; if it is, manually forward the same ports from it to his router.
    5. go through the configuration wizard on his server, telling it that he will manually configure his router.

    If it hangs at that point, there's a problem on the server.


    I'm not on the WHS team, I just post a lot. :)

    • Proposed as answer by Ken Warren Monday, February 11, 2013 9:45 PM
    • Unproposed as answer by Mouseskowitz Tuesday, February 12, 2013 5:14 AM
    Monday, February 11, 2013 12:10 PM
  • I'm not sure how to assign a static IP outside of DHCP range but I do have a DHCP reservation for the server. UPnP is off, ports are forwarded and to my knowledge my Motorola SB6120 is not capable of router functionality. Checking the manual configure box in the wizard still results in being stuck on the "setting up the router" portion. 

    This is a portion of the results of running a Nmap port test, which from my understanding pings my server from outside my home network. 

    Discovered open port 135/tcp on 192.168.*

    Discovered open port 445/tcp on 192.168.*

    Discovered open port 139/tcp on 192.168.*

    Discovered open port 443/tcp on 192.168.*

    Discovered open port 80/tcp on 192.168.*

    Discovered open port 554/tcp on 192.168.*

    Discovered open port 3389/tcp on 192.168.*

    Discovered open port 10243/tcp on 192.168.*

    Discovered open port 2869/tcp on 192.168.*

    Discovered open port 49154/tcp on 192.168.*

    Discovered open port 5357/tcp on 192.168.*

    Discovered open port 49156/tcp on 192.168.*

    443/tcp   open  ssl/http      Microsoft IIS httpd 7.5

    | http-methods: OPTIONS TRACE GET HEAD POST

    | Potentially risky methods: TRACE

    |_See http://nmap.org/nsedoc/scripts/http-methods.html

    | http-robots.txt: 1 disallowed entry 

    |_/ 

    | http-title: 

    |   title: 







    |_  redirect_url: nil

    | ssl-cert: Subject: commonName=****.homeserver.com/organizationName=****.homeserver.com

    | Issuer: commonName=Go Daddy Secure Certification Authority/organizationName=GoDaddy.com, Inc./stateOrProvinceName=Arizona/countryName=US

    | Public Key type: rsa

    | Public Key bits: 2048

    | Not valid before: 2012-12-13T02:11:01+00:00

    | Not valid after:  2017-12-13T02:11:01+00:00

    This would seem to indicate that packets are able to get through to my server, but since the setup wizard hangs I cannot use the remote web access. So, it seems like the problem is on the server. The question is what is it and how to fix it.

    Monday, February 11, 2013 11:26 PM
  • 192.168.* is your internal (private) network. You are not checking the ports on your external IP...

    You should try ShieldsUP at www.grc.com. Do this on any PC on your LAN. It will show you your external (public) IP. On that site you can now check the common ports. They all should be stealth except for ports 80 and 443. Remember that it is your router that is probed and ports that are shown as open can be any device on your internal LAN.

    You can further verify by stopping IIS on your server. Now all ports should be stealth. Restart IIS and again ports 80 and 443 should be open.

    Hope this helps.

    Luc.

    Tuesday, February 12, 2013 1:05 PM
  • I haven't figured out how to use ShieldsUP yet but I reran Nmap using 24.14.*.* which is my external IP address. Of 1000 tested it showed ports 80 and 443 open with the info as above on 443 and lists 4125 as filtered rww. Typing my external IP into a browser from inside an outside my network results in the same WHS 2011 message that remote web access is turned off. When I have time later today I will rerun the test from outside my network to verify that these results are accurate and I think they will be.
    Tuesday, February 12, 2013 1:44 PM
  • Did you run nmap on a PC on your internal network? If so the results are unreliable with respect to the ports on your external IP. You should run nmap on a PC on an external network. That's why I recommend using ShieldsUP or another web-based tool so that you check from the outside.

    Luc.

    Tuesday, February 12, 2013 3:35 PM
  • Nmap from outside my network shows ports 80 and 443 open and reports 443 as listed above. ShieldsUP also shows those two ports open.
    Tuesday, February 12, 2013 5:21 PM