locked
Could not find a web resource with name Images/refresh.png RRS feed

  • Question

  • The following exception continues to be logged in the Event Viewer for servers in all my environments:

    Could not find a web resource with name Images/refresh.png

    I've looked at this thread but haven't found anything to solve the issue. When I click on the link (http://xxxxx/xxxxx/Handlers/WebResource.ashx?name=Images/refresh.png) from the event log detail, I'm prompted to authenticate. After authenticating, I receive the error "Record is Unavailable", even though I'm the SysAdmin.

    Any ideas??

     

    Thanks,

    Dave

    Tuesday, December 13, 2011 4:12 PM

Answers

  • The problem arises from using an alias for the URL. If the FQDN is used, the issue disappears.
    • Marked as answer by DavidCRM Tuesday, February 21, 2012 5:41 PM
    Tuesday, February 21, 2012 5:41 PM

All replies

  • Hi!

    This is Robin.

    I have same issue just like your case.

     

    In my case, after resolve case within a case form, the explorer is stop working and there is some error page.

    did you solve the issue?

     

    If you did, would you share your information?

     

    Thanks.

     

     

     

    This is my error log.

     

    Application information:
        Application domain: /LM/W3SVC/2/ROOT-1-129683196081153180
        Trust level: Full
        Application Virtual Path: /
        Application Path: C:\Program Files\Microsoft Dynamics CRM\CRMWeb\
        Machine name: TRUECOM
     
    Process information:
        Process ID: 4316
        Process name: w3wp.exe
        Account name: NT AUTHORITY\NETWORK SERVICE
     
    Exception information:
        Exception type: CrmException
        Exception message: Could not find a web resource with name Images/refresh.png.
       위치: Microsoft.Crm.Application.Components.Handlers.WebResource.RetrieveWebResource(String webResourceName, String preview)
       위치: Microsoft.Crm.Application.Components.Handlers.WebResource.ProcessRequestInternal(HttpContext context)
       위치: System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       위치: System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     
     
    Request information:
        Request URL: https://ooo.ooo.co.kr:444/Handlers/WebResource.ashx?name=Images/refresh.png
        Request path: /Handlers/WebResource.ashx
        User host address: 000.000.000.000 
        User: 
        Is authenticated: True
        Authentication Type: Federation
        Thread account name: NT AUTHORITY\NETWORK SERVICE
     
    Thread information:
        Thread ID: 45
        Thread account name: NT AUTHORITY\NETWORK SERVICE
        Is impersonating: True
        Stack trace:    위치: Microsoft.Crm.Application.Components.Handlers.WebResource.RetrieveWebResource(String webResourceName, String preview)
       위치: Microsoft.Crm.Application.Components.Handlers.WebResource.ProcessRequestInternal(HttpContext context)
       위치: System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       위치: System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    • Edited by Robin ShinMVP Friday, December 16, 2011 4:33 AM modify
    Friday, December 16, 2011 4:31 AM
  • The problem arises from using an alias for the URL. If the FQDN is used, the issue disappears.
    • Marked as answer by DavidCRM Tuesday, February 21, 2012 5:41 PM
    Tuesday, February 21, 2012 5:41 PM
  • This is not true for us.  The FQDN is used and the result is an error.  In the log it is trying to access:

    https://fqdn.domain.com/Handlers/WebResource.ashx?name=Images/refresh.png

    That fails.

    https://fqdn.domain.com/Handlers/WebResource.ashx?name=msdyn_/Images/refresh.png

    Works.

    Thursday, February 23, 2012 3:40 PM
  • Same for us.  This should be unmarked as the answer.  I think there's a bug in the ActivityFeeds solution from MS.  It's referencing an incorrect URL.

    Ray Riopel

    Friday, March 9, 2012 1:15 PM
  • We also are having the exact same problem, and it is also not an issue of fqdn.

    I'm also leaning to a bug in ActivityFeeds.


    Thanks, Robert

    Wednesday, November 14, 2012 3:03 PM
  • as far as I know, this is a bug in ActivityFeeds and MS knows it... IT will be resolved in the next release of Activity Feeds accelerator... what they said so...

    regards.


    Mehmet Özgür Genç TradeSoft Business Services Vice President ozgurg@tradesoft.com.tr

    Wednesday, November 14, 2012 4:40 PM
  • It seems that problem is wrong URL in Activity Feeds CRM solution from Microsoft, I do have currently latest 1.0.1.20302 version, and I have exact problem.

    Any news from Microsoft regarding to an update and fix of solution ?


    -- Hrvoje Kusulja

    Tuesday, June 4, 2013 3:16 PM