locked
Term Services RRS feed

  • Question

  • Hii Everyone,

    I have had WHS since the early betas and have been and still am very happy with the product.  Id does everything that i want it to do without question, i have recently installed an addon called system event monitor.

    I have installed a printer on the server and can now print from any client from within the house and network...great...

    I am however getting an error constantly coming through, (it has no effect on the use of the server or health but is just annoying).
    the error reads:

    Source: TermServDevices

    TimeGenerated: 11/11/2008 12:59:47

    InstanceId: 1111

    Catagory: (0)

    CatagoryNumber: 0

    EntryType: Error

    Message: Driver Microsoft XPS Document Writer required for printer Microsoft XPS Document Writer is unknown. Contact the administrator to install the driver before you log in again.

    ----

     

    Source: TermServDevices

    TimeGenerated: 11/11/2008 12:59:48

    InstanceId: 1111

    Catagory: (0)

    CatagoryNumber: 0

    EntryType: Error

    Message: Driver Microsoft Office Document Image Writer Driver required for printer Microsoft Office Document Image Writer is unknown. Contact the administrator to install the driver before you log in again.

    ----


    has anyone any idea what this means and more importantly how i can stop it or correct the issue that the server is having.


    Incase needed, the machine i am runnin WHS on is a Dell Dimension 3100 with 3 clients all of which are using Vista.  All are up to date with MS updates also.
    I have also checked in the device manager and everything in there is fine.

    Any help would be gratefully appreciated.

    Thanks in advance

    TobsterUK
    Tuesday, November 11, 2008 3:45 PM

Answers

  • Hi,
    that message says, that your client has installed a printer, for which no driver exists in Windows Home Server.
    Default setting of the RDP client is to redirect the client printers to the Remotedesktop session.
    If you go into the options of your RDP client (before connecting), you can uncheck Printers in the Local devices and resources area to change this behavior.
    Another option would be, to login to the Windows Home Server desktop and perform following steps:
    • In Start menu click Control Panel/Administrative Tools.
    • Open Terminal Services Configuration.
    • Right click RDP-TCP and select Properties.
    • On Client Settings tab click the checkbox to disable Windows Printer Mapping amd LPT Port Mapping.
    • Click OK and confirm the message.
    This will stop the propagation of client printers from server side.
    Best greetings from Germany
    Olaf
    Tuesday, November 11, 2008 3:52 PM
    Moderator

All replies

  • Hi,
    that message says, that your client has installed a printer, for which no driver exists in Windows Home Server.
    Default setting of the RDP client is to redirect the client printers to the Remotedesktop session.
    If you go into the options of your RDP client (before connecting), you can uncheck Printers in the Local devices and resources area to change this behavior.
    Another option would be, to login to the Windows Home Server desktop and perform following steps:
    • In Start menu click Control Panel/Administrative Tools.
    • Open Terminal Services Configuration.
    • Right click RDP-TCP and select Properties.
    • On Client Settings tab click the checkbox to disable Windows Printer Mapping amd LPT Port Mapping.
    • Click OK and confirm the message.
    This will stop the propagation of client printers from server side.
    Best greetings from Germany
    Olaf
    Tuesday, November 11, 2008 3:52 PM
    Moderator
  • Many thanks for the quick reply.  I have tried that so i will see what happens from here.....many thanks again.
    Tuesday, November 11, 2008 5:44 PM
  • Thank you!  This solved our problem!
    Wednesday, May 26, 2010 1:35 PM
  • Thank you Olaf ,

    This solution has resolve my issue.


    regards Irshad
    Monday, September 12, 2011 5:00 AM
  • Many thanks Olaf,

    This solution has resolve my issue.

    Thanks and Regards,
    7hills
    Thursday, November 3, 2011 6:55 AM