locked
Rule deployment wizard : Failed to access the default store for the user RRS feed

  • Question

  • Good morning,

    I am using a foward mailbox as an incoming rule for my crm queues. It used to work good and suddently start failing. Now the email make it to the foward mailbox, are then redirected to the email address of the queue in outlook but they won't appear in the CRM queue. When I log the error on the email router server I get: An error occurred while checking for e-mail messages to process in mailbox fwdbox@domain.com. System.Net.WebException: The remote server returned an error: (404) Not Found.

    When I am trying to deploy/delete/verify the rules for any user I received the following error message in the rule deployment wizard Failed to access the default store for the user

    It is now a day I am working on this without any success, any help would be greatly appreciated !

    Clo
    Clo
    Thursday, January 7, 2010 5:28 PM

Answers

  • Hi Clo,
    It's looks that it's problem with Exchange security then CRM. Try to install Exchange Email Router on the Exchange server and try to configure rule.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    • Proposed as answer by Jimmy Morales Friday, January 8, 2010 3:05 PM
    • Marked as answer by Jim Glass Jr Wednesday, January 27, 2010 5:06 PM
    Thursday, January 7, 2010 10:17 PM
  • The following seems to have fixed the issue.

    <div title="In order to resolve this issue please follow these steps :

    On the CRM E-Mail Router machine, go to the following folder: %ProgramFiles%\Microsoft CRM Email\Server

    1°) Right click on this file : Microsoft.Crm.Tools.Email.Management.config and open it in notepad.

    Under the <Configuration> tag, add the following:

    <system.net>
    <connectionManagement>
    <add address="*" maxconnection = "24" />
    </connectionManagement>
    </system.net>
    Save the file.

    2°) Still within the same folder, create a file called: Microsoft.Crm.Tools.EmailAgent.exe.config

    Edit the file in Notepad and add this content:

    <configuration>
    <system.net>
    <connectionManagement>
    <add address="*" maxconnection = "24" />
    </connectionManagement>
    </system.net>
    </configuration>
    Save the file and restart the E-Mail Router service (“NET STOP MSCRMEMAIL”, then “NET START MSCRMEMAIL” from a command line)

    This should resolve this issue." id="'748' + '_more'" style="display: block;">


    Clo
    Wednesday, January 27, 2010 4:29 PM

All replies

  • Check your e-mail router service, log in account and use a domain admin account.  Also, ensure the e-mail address for the queue in CRM did not change.

    If the above doesn't help, have a look at this article and see if there are any changes needed to your configuration. 

    http://edwardsdnadynamicscrm.spaces.live.com/blog/cns!D5F22FDCDD6519D5!744.entry


    Best Regards, Donna
    Thursday, January 7, 2010 5:42 PM
  • Hi Clo, Please check if you have conectivity with the e-mail server from your crm server, and if the fwdbox accuount is working. take a look to the aplications events.

    regards

    Thursday, January 7, 2010 6:44 PM
  • Hi Dona,

    Thanks a lot for your answer. Yes the log in account for the router service is a domain admin (I have even tried to change it for another one but still get the errors). The email addresses are the same. I went through the article and my settings are exactly the one recommended. I am really confused


    Clo
    Thursday, January 7, 2010 7:56 PM
  • Hi Clo,
    It's looks that it's problem with Exchange security then CRM. Try to install Exchange Email Router on the Exchange server and try to configure rule.
    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    • Proposed as answer by Jimmy Morales Friday, January 8, 2010 3:05 PM
    • Marked as answer by Jim Glass Jr Wednesday, January 27, 2010 5:06 PM
    Thursday, January 7, 2010 10:17 PM
  • Hello,

    Thanks for the idea ! I don't have the rights to do this installation myself so I will update the post once we give it a shot


    Clo
    Friday, January 8, 2010 2:03 PM
  • The following seems to have fixed the issue.

    <div title="In order to resolve this issue please follow these steps :

    On the CRM E-Mail Router machine, go to the following folder: %ProgramFiles%\Microsoft CRM Email\Server

    1°) Right click on this file : Microsoft.Crm.Tools.Email.Management.config and open it in notepad.

    Under the <Configuration> tag, add the following:

    <system.net>
    <connectionManagement>
    <add address="*" maxconnection = "24" />
    </connectionManagement>
    </system.net>
    Save the file.

    2°) Still within the same folder, create a file called: Microsoft.Crm.Tools.EmailAgent.exe.config

    Edit the file in Notepad and add this content:

    <configuration>
    <system.net>
    <connectionManagement>
    <add address="*" maxconnection = "24" />
    </connectionManagement>
    </system.net>
    </configuration>
    Save the file and restart the E-Mail Router service (“NET STOP MSCRMEMAIL”, then “NET START MSCRMEMAIL” from a command line)

    This should resolve this issue." id="'748' + '_more'" style="display: block;">


    Clo
    Wednesday, January 27, 2010 4:29 PM