locked
Installing update KB923980 over and over and over ... RRS feed

  • Question

  • I use automatic updates and I was prompted to install KB923980 which I did. Ten minutes later it asked me to do it again. Then again, then again... I've restarted my system a half dozen times and allowed KB923980 to install on shutdown. I've downloaded the update and installed it twice manually. Since I started this message I've installed it twice. Please god someone make it stop!

    P.S. I am using Windows XP Home.

    Sunday, November 19, 2006 11:09 PM

Answers

  • I had to search around for awhile but found a solution that worked for me, maybe it will work for you too.

    First, I uninstall KB923980 from my Add/Remove programs and was prompted to restart but before I restarted I renamed a hidden file in my systems32 folder from nwprovau.dll to nwprovau.old then I restarted the computer. Once the computer started back up I reinstalled KB923980 and it seems to be working fine now.

    Hope that helps.

    Wednesday, November 22, 2006 10:46 AM
  • Cliff N was right on - I followed his instructions exactly, and everything works fine.  Thank you Cliff.
    • Marked as answer by Carl-S Wednesday, July 23, 2008 10:10 PM
    Sunday, November 26, 2006 4:25 PM

All replies

  •  Larry E Bear wrote:

    I use automatic updates and I was prompted to install KB923980 which I did. Ten minutes later it asked me to do it again. Then again, then again... I've restarted my system a half dozen times and allowed KB923980 to install on shutdown. I've downloaded the update and installed it twice manually. Since I started this message I've installed it twice. Please god someone make it stop!

    P.S. I am using Windows XP Home.

    Download and install the update directly: http://www.microsoft.com/downloads/details.aspx?FamilyID=2f54258f-1071-467b-80a2-e4dbfc050667&DisplayLang=en

    Monday, November 20, 2006 5:02 AM
    Moderator
  • I am having the same problem as Larry. 

    I have done the following to resolve the problem with no positive results:

    • installed many time in automatic mode
    • installed manally using the direct link above
    • uninstalled the security patch using add/remove programes (clicking the show updates option)
    • installed manualy using (again)!
    • deleted the temporary files in the C:\WINDOWS\SoftwareDistribution\Download  directory.
    • reinstalled yet again in automatic and manual modes

    I am running XP home and recently installed Visual Studio 2005.

     

    Monday, November 20, 2006 3:51 PM
  •  David Fish wrote:

    I am having the same problem as Larry. 

    I have done the following to resolve the problem with no positive results:

    • installed many time in automatic mode
    • installed manally using the direct link above
    • uninstalled the security patch using add/remove programes (clicking the show updates option)
    • installed manualy using (again)!
    • deleted the temporary files in the C:\WINDOWS\SoftwareDistribution\Download  directory.
    • reinstalled yet again in automatic and manual modes

    I am running XP home and recently installed Visual Studio 2005.

     

    Monday, November 20, 2006 4:22 PM
  •  Brakar wrote:
     David Fish wrote:

    I am having the same problem as Larry. 

    I have done the following to resolve the problem with no positive results:

    • installed many time in automatic mode
    • installed manally using the direct link above
    • uninstalled the security patch using add/remove programes (clicking the show updates option)
    • installed manualy using (again)!
    • deleted the temporary files in the C:\WINDOWS\SoftwareDistribution\Download  directory.
    • reinstalled yet again in automatic and manual modes

    I am running XP home and recently installed Visual Studio 2005.

     

    It's annoying isn't it? According to the Microsoft Update/Update History  page I have successfully installed this update over twenty-three times. Yet even now the little yellow shield beckons me to try it again. I've searched the Knowlegde Base but without knowing an exact search phrase finding something on the KB is next to impossible. -sigh-. Thanks for the help, if I find an answer I'll post it.

     

     

    Tuesday, November 21, 2006 2:42 AM
  • Hey David;

    It has taken me a while to try and find the right place to post the above question. It looks like I may have chosen the wrong site. In which case I am sorry. I haven't tried it yet but apparently there is a forum for update issues: http://www.microsoft.com/windowsxp/expertzone/newsgroups/reader.mspx?dg=microsoft.public.windowsupdate&lang=en&cr=US

    In this forum is a collection of people having the same problem with KB923980 - Who knows maybe there is strength in numbers?

    Tuesday, November 21, 2006 2:56 AM
  • I had to search around for awhile but found a solution that worked for me, maybe it will work for you too.

    First, I uninstall KB923980 from my Add/Remove programs and was prompted to restart but before I restarted I renamed a hidden file in my systems32 folder from nwprovau.dll to nwprovau.old then I restarted the computer. Once the computer started back up I reinstalled KB923980 and it seems to be working fine now.

    Hope that helps.

    Wednesday, November 22, 2006 10:46 AM
  • The one solution that I read somewhere else and worked for me was to:
    1. first install it once using the automatic (express) update option.
    2. Then when the yellow shield come back double click it again, but this time select the manual installation.
    3.  Then deselect the KB923980
    4.  You then get the option not to be alerted anymore about this particular update - so select that.
    And that's it.
    You now have the update installed and will not be notified again about it.
    (Please note however that if for whatever reason you deinstall this update you will not be notified of its absence until you change the above parameters)
    Wednesday, November 22, 2006 6:20 PM
  • Here is what worked for me.. May or may not help

    In windows/sys32 folder    rename the following

    nwapi32.dll to  nwapi32.old
    nwprovau.dll to nwprovau.old
    nwwks.dll  to nwwks.old  (mine was all caps NWWKS.DLL for some reason)
     
    Then I did the uninstall from add remove programs and rebooted.
    Once rebooted I let the "Install Shield"  version run.
    Again with another reboot and all was well.
     
    Hope that helps.
    Friday, November 24, 2006 4:49 PM
  • Cliff N was right on - I followed his instructions exactly, and everything works fine.  Thank you Cliff.
    • Marked as answer by Carl-S Wednesday, July 23, 2008 10:10 PM
    Sunday, November 26, 2006 4:25 PM
  • tligon
    I have tried what you suggest and it seems to work.
    Yesterday I tried the procedures suggested by Cliff, it worked while the pc was on. Today when I restarted it there it was the yellow icon again.
    Hope it works this time.
    Thanks to all

    Tuesday, November 28, 2006 3:04 AM
  • I also got this problem. I already tried everything including some of the recommendations from this forum. However, none of it works. It does not even show at my Add & Remove Prgms dialogue window in the Control Panel. It is very quite annoying indeed and I have enquired already from Microsoft. I am very sure that they are very much aware of what is happening with this kind of update. The first time the engineer replied to me as if he is not aware about this problem and ask me a lot of details. He also ask me again to explain further because he has the impression that I cannot install this update. I am very sure Microsoft should have all the answers for this technical problem and they should put the solution or the update on their website so we can put a stop to this issue.

    C'mon people don't waste MR. BILL GATES' money. We want a solution fast.

    Wednesday, November 29, 2006 7:30 PM
  • I,m having the same problem. Funny thing this security update is stated as beiing for windows 2000 but i am running xp. I did a google search and security update KB923980 is for windows 2000. Something is broken somewere i should say. Allso even though it shows as installing 8 times through automatic updates it only shows ones in add remove programs. KB923980 is the only update i have received since november 15, I wonder if instead of getting regular updates we get this one over and over.

    I sure hope they fix this before too long, have a feeling i am missing updates I should have.

    Erna

    Friday, December 8, 2006 7:26 AM
  • Cliff N's solution didn't work for me.  Running XP Home on a HP Pavilion 533w.  Still battling the yellow shield, so I turned off auto updates for now to eliminate the annoyance.  Funny thing is that I have a Pentium 4 system that updated normally, with no problems, whilst the HP system (Celeron) is the problem child.  Is this condition perhaps a combination of software and machine?
    Wednesday, December 13, 2006 9:05 PM