locked
Error when exporting to excel and config export size in CRM2011 RRS feed

  • Question

  • Hi all,

    I am trying to export to Excel the members of a list.
    If my list has 300 contacts -> the list is exported
    If my list has 80 000 contacts -> the list is not exported.

    Do you have any idea? Is there a limit somewhere? If yes how I can configure it.

    Thanks



    If my question/answer can help you, please give me a points :) ----You may be disappointed if you fail, but you are doomed if you don't try---


    • Edited by AnyMi Wednesday, May 14, 2014 6:44 AM
    Tuesday, May 13, 2014 4:47 AM

All replies

  • Hi LuuHa,

    By default the default value is 10000, however if you need more records to exported to excel there are couple of ways to achieve this.

    Start -> Run -> type regedit and then press enter

    Navigate: HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> MSCRM

    Look for registry entry (DWORD) with the title “maxrecordsforexporttoexcel” and modify the value to 65000.

    If you are unable to find the registry entry then create it as shown below.

    From Edit Menu -> Click New -> DWORD value and select it to be “Decimal” and specify value 65000.

    Once you have modified/created this registry entry, reset IIS by doing the following

    Go to your CRM server, Start -> Run -> type iisreset and press enter

    The below method is not supported by Microsoft but has worked for me every time.

    Unsupported by Microsoft


    • Open SQL Management Studio on your database server
    • Run a new query on <OrganizationName>_MSCRM
    • Select MaxRecordsForExportToExcel From OrganizationBase where Name = ‘OrganizationName’
    • This query will show you the value of MaxRecordsForExportToExcel in the organization database. It will be 10000 (by default) if it has not been updated
    • Run update query to update this value to 65000 (if you want to export 65000 records in an excel spread sheet). 
    •  Update OrganizationBase Set MaxRecordsForExportToExcel=65000 where Name = ‘OrganizationName’

    If you now run the select statement again, you will see the value as 65000. This should now allow you to export 65,000 records out of CRM in excel spread sheet.

    • Proposed as answer by Eranger Tuesday, May 13, 2014 10:59 PM
    Tuesday, May 13, 2014 4:52 AM
  • HI,

    In my DB has set 100000 is maximum.

    But it still fail for export ~ 70000 contacts

    Its works for a list of 55000 contacts => the exported fiel ~ 120mb

    Maybe there is a config to make the limit of 'size to export'?

    Do you have any idea?

    Thanks,


    If my question/answer can help you, please give me a points :) ----You may be disappointed if you fail, but you are doomed if you don't try---

    Wednesday, May 14, 2014 6:43 AM
  • Hi LuuHa,

    May be you can try increasing the OLEDB timeout settings using registry? That's the only thing I can think of. Other than that you can export two lots of spreadsheets as a workaround.

    http://support.microsoft.com/kb/918609

    Wednesday, May 14, 2014 7:19 AM
  • There is another problem you need to concern is about timeout of the export. Please check the following guidance:

    If you increase the value and you receive a time-out error while exporting the records configure the steps below.

    Increase the Maximum Connections of Internet Explorer:

    Outlook inherently uses Internet Explorer to help render web content. Although the 2011 version of the client relies heavily on mapi integration to display data, increasing the maximum number of connections for Internet Explorer can help mitigate performance issues. The KB article listed below contains a “Fix It” to increase the maximum number of connections for Internet Explorer:

    http://support.microsoft.com/kb/282402

    Change timeout on connection:

    Locate the TcpTimedWaitDelay key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters (select Parameters)

    Check if the TcpTimedWaitDelay registry exists or not. If yes set the Decimal value to 300. If no follow the below steps:

    On the Edit menu, point to New, click DWORD Value and then add the following registry value:

    Value Name: TcpTimedWaitDelay

    Value: 300

    Wilson

    Wednesday, May 14, 2014 8:25 AM