SyncToy access denied error on USB drive connected to NAS RRS feed

  • Question

  • Hi,

    I am having the familiar access denied problem when trying to sync files from my XP 64 pc to a USB drive connected to a maxtor shared storage NAS.
    I can sync just fine to the maxtor nas network drive but get the following error when attempting to sync to the USB drive attached to the NAS:

    Error: Unknown error. Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) Copying FILE_TO_BE_SYNCHED to USB_ON_NAS_BOX_FILE

    I can read/write files just fine when connected to the drive on the pc.
    Somehow the permissions are ok for the NAS drive but not the usb drive attached to it. I have tried to modify the security level on the USB drive but just get an access is denied error.

    Hope someone could help as SyncToy looks like just what I need Smile
    Thursday, October 23, 2008 2:26 PM

All replies

  • Can no one help me out with this problem?!

    Tuesday, October 28, 2008 3:40 AM
  • Can you check this ? Map the USB drive to a drive letter on the XP 64 bit machine and see if you can manually copy a file from the 64 bit box to the USB?




    Tuesday, October 28, 2008 9:57 PM
  • Sorry I didnt make this clear in the original post but when mapped to the usb drive (via the NAS) on the XP64 pc I can read/write files no problem.
    Wednesday, October 29, 2008 3:22 AM
  • Anyone help me out here?
    Tuesday, November 4, 2008 4:24 AM
  • I guess there is no fix for this issue, I hope that MS will consider looking into this and fixing it for the next version of SyncToy.
    Thursday, November 20, 2008 7:49 AM
  • It looks like your user does not have full controll of the USB drive.  Can you check the USB drive Security properties to verify that your user has full control?


    Maria del Mar Alvarez - MSFT

    Thursday, November 20, 2008 6:12 PM
  • As I mentioned the usb should have full control rights as I can both read/write and delete files/folders from explorer. I cant access the drive directly as its connected through the NAS, however there should be full admin rights.
    Sunday, November 23, 2008 7:27 AM
  • I am having the same problem as Kreeture.


    I have an external USB hardrive pluged into the USB port on the back of my BT Home HUB.

    This allows me to share music, video etc over my wireless network, this all worls very well with no problems.

    I maintane the original files on my WIndows XP SP3 32 bit pc. Whenever I add additional files, I currently manually copy and paste from my PC onto the USB drive. This works ok, I can, from the main PC, copy read write & delete any files from the usb drive.

    When I tried using SyncToys I get an error, Access denied. It does however creat any folder structure required on the USB drive, and creates a lot of .tmp files, but failes to copy the actual files over.???


    I tested the process copy files from one folder to another on my pc's hardrive and it worled ok.


    Anyone help with this??


    Thanks in advance


    Monday, January 26, 2009 10:34 PM
  • Can you check under which account the sync is working?

    Under which user's permissions is the process running.

    Trying giving full rights to the user.


    Ensure USB drive reg key has following properties:



    Tuesday, January 27, 2009 7:52 AM
  • Hi Soshan, thanks for taking an interest in this.


    I have only the one user account, ne and I an full administrator.


    I checked the registry key you sugested, I have no "StorageDevicePolicies" in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control"


    Is this the problem?


    Can I just create this key and reeboot?




    Thursday, January 29, 2009 12:05 AM
  • Did this ever figured out?  Is there any workaround?  I'm having the same problem with a USB drive connected to my router (a Buffalo WZR-HP-G300NH).  I can copy and delete files on this NAS drive, but SynToy 2.1 gives me the same "Access is denied" error when it tries to write to the NAS drive.  I even get this when I try to sync to a folder that I created from the same PC I try to do the sync (well actually Contribute).  One twist, I am only getting this error with my Notebook PC -- but not my Desktop PC (which SyncToy seems to work fine with the NAS).
    Monday, June 21, 2010 4:20 AM
  • BTW, my desktop is running XP while my notebook is running 7.  I connected my notebook to the router via a wired connection, and I still get the "access is denied" error.  So the problem I am seeing with SyncToy 2.1 (and NAS drives) seem to only be with Windows 7 -- and not XP.  Or perhaps it is an issue with the 64-bit version of SyncToy (which I am running with 7) and the 32-bit version (that I am running with XP).  Either way, I'm hoping version 2.2 is released soon AND that it corrects this problem!



    Monday, June 21, 2010 3:03 PM
  • Same problem here. I have a Hammer N1200 NAS configured as RAID 0. I use (or hope to use) a USB SATA drive as a backup. SyncToy 2.1 fails to synchronize most new files.

    The Hammer drive seems to be running Linux.

    I run SyncToy from a WinXP workstation. I have tried full path names as well as mapped drives, both modes result in the same failures.

    Operation: Overwrite

    Error: Unknown error. Access is denied (Exception from HResult:0x80070005(E_ACCESSDENIED))


    Operation: New

    Error: Unknown error. Access is denied (Exception from HResult:0x80070005(E_ACCESSDENIED))


    I've tried both Synchronize and Contribute modes. Both fail in the same manner.

    Friday, September 24, 2010 4:05 PM
  • Long time no answers?

    I have the same problem under Win7 32bit, trying to Echo from a Public Share on my NAS to a USB 1TB disk drive attached to it (Both WD).  Like Bugss the folder structure was created, but no files were copied.  Ie was logged in as an account with admn prives, but the permissions on the folders did not include me specifically.

    I have copied a lot from C: to the same drive using SyncToy.

    If I find an answer I will post it here.

    Monday, September 27, 2010 8:24 PM
  • I have been having the same issue as well. It happened around the time I upgraded SyncToy about 6 months ago. I was using an older version, v1.4 I think, but was sick of that bug where it leaves empty folders on the right even after you delete everything on the left. So I upgraded to v2.1 because I heard it was supposed to resolve this problem. Also around the same time I had to blow away my USB drive connected to my LinkSys Cisco router and recreate the shares on it. All the security seems fine as I can manually copy files and folders over to the drive with no issues. However, now SyncToy only creates the folders on my USB (NAS) drive but fails to copy any files due to the same Access Denied HR Result error. I don't get it. Is it my upgrade to the newer SyncToy or my recreation of the shares that broke it, and if it truely was a security issue, which I don't believe it is, then why can I manually copy files and folders over with no issues????

    I've seen many different posts on this problem going back to 2007 or later and no concrete solutions from Microsoft!!!!

    Lucky for me I have a RAID mirror on my new PC so at least I have data redundancy there, but right now my USB drive connected to the router is useless unless I wan't to do a manual copy or robocopy or something. SyncToy used to be a pretty good solution for me and now it's just a piece of......

    Okay my rant is over now!

    Saturday, May 7, 2011 12:43 PM