none
browsing WelcomeToOCS application gives "Page Cannot be displayed" error RRS feed

  • Question

  • We are facing an issue in Speech application in deployment environment. We have installed Speech Server 2007 on a Windows 2003 SP1 box (without development tools). Now, the problem is, when we browse the WelcomeToOCS application (.speax) from browser, it gives DNS error (Page cannot be displayed). We have verified following:

     

    1. Virtual directory mapping to valid folder exists in IIS.
    2. in IIS, .speax extension is mapped to “C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll".

     It would be a great help if anyone can just throw some light on if we are missing something.

    Monday, July 7, 2008 10:27 AM

All replies

  • Could you post the actual error from the event log?

    -Marc
    Monday, July 7, 2008 2:49 PM
  • me too,

     

    My http://localhost/WelcomeToOcs/WelcomeToOcs.speax can't display correctly,

    The page just show source code :

    ------------------------------------------------

    <!--
        WelcomeToMss.speax 
    
        Copyright (c) Microsoft Corporation.  All rights reserved.
    -->
    <%@ SpeechAppHandler Assembly="Microsoft.SpeechServer.WelcomeToOcs" Class="Microsoft.SpeechServer.WelcomeToOcs" %> 
    
    Who can help us?
    Thank You!
    Tuesday, July 8, 2008 4:17 AM
  • The IIS error message is not enough to determine what is going on.

     

    If you can post the error message as it is shown in the event log (just copy and paste it right from the event log) then I might be able to point you in the right direction.

    Wednesday, July 9, 2008 3:19 PM
  •  

    Make sure the Virtual Directory is an Application in IIS and also make sure Network Server account has read access to the source folder.

     

    Keith Kabza MVP

    http://www.ocsmvp.com

     

    Thursday, July 24, 2008 10:06 PM
  • Hi

    I am evaluating OCS at the moment as I need to develop a voice solution and I think that it can help me.

    I just installed windows server 2003 in a virtual machine, sp2 and the others required. I installed all roles (I think I am using developer edition) apart from the development one as the VM has no visual studio installed.

    I tried going to the default application but had similar problems. I have tried everything, but I always get page can not be displayed when browsing any of the sample .speax files

    As this is a VM with no NIC enabled, I do not really mind security, I have even tried changing everything in IIS to log on to administrator and it has done nothing.

    I dont know what to do!
    Wednesday, August 13, 2008 5:14 PM
  •  

    You are not going to browse speax fles in browser?

     

    You need to open the solution in Visual Studio 2005 and configure the application using Speech Server Admin Console.

     

    Send me your contact info from my blog site and i can help you offline.

    http://www.ocsmvp.com/contact.aspx

     

     

    Keith Kabza, MVP

     

    Wednesday, August 13, 2008 5:24 PM
  • Ok,

    I will install VS and try again later.

    I did not think there would be anything fancy, however I assumed there may just be a hello world or equivilant sample application to let me know it had worked!

    Thanks
    Wednesday, August 13, 2008 5:44 PM