none
vstest.console.exe gets stuck after first test when executed from TFS Build RRS feed

  • Question

  • I have my build definition for my project set up on TFS. I intend to add Task to Run C++ Unit Tests and run them after each build.

    I tried and added the task. When the Tests ran on TFSBuild the first test crashed with unhandled c++ exception and did not moved to next test. It hung there itself.

    So I tried to run the test manually using command line(cmd). I ran the vstest.console.exe command and executed all tests and they ran fine when ran from cmd on the Build Agent. I also tried running them on Visual Studio and they ran fine on the Build Agent.

    I am not sure what is going wrong with the TFS.

     
    Wednesday, February 27, 2019 10:56 AM

Answers

All replies

  • Hello,

    I'm sorry I don't know Team Foundation Server. Maybe you should better ask here:

    https://stackoverflow.com/questions/tagged/tfs

    Regards, Guido

    Wednesday, February 27, 2019 2:00 PM
    Moderator
  • Hello,

    Thanks for post here.

    >> vstest.console.exe gets stuck after first test when executed from TFS Build

    This forum is about c++ development. I guess maybe your case is more related to MSBuild or Visual Studio Unit Testing, or you could refer to the link which Guido Franzke provided, I will move this thread to Where is the Forum for...? forum to redirect it. Then you could post your issue on the right  for better support.

    Your understanding and cooperation will be grateful.

    Best Regards,

    Jack Zhang


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, February 28, 2019 8:06 AM