locked
Remote Desktop Login Problem RRS feed

  • Question

  • When I try to log in to WHS via remote desktop, I get an error message box displayed: 

    "The system cannot find the file specified. This initial program cannot be started: taskmanager"

    When I 'OK' this message box, there is a brief flash of the 'Saving your settings' banner, then a blank screen, and eventually Remote Desktop pops up an error to say it couldn't connect. 

    I can log in to WHS Console with the same admin id and password, and I can find and run taskmanager (in windows/system32) from within the console, but I'm at a loss to know how to fix the remote desktop log in.

    Any ideas?
    Sunday, February 15, 2009 3:46 PM

Answers

  • Hi,
    did you at any time try to change settings for the program to start at remote desktop logon (which is unsupported use of WHS btw.)?
    • If you are logged on to the console, open Terminal Services Configuration in Control Panel/Administrative Tools.
    • Under Connections right click RDP-Tcp and select Properties.
    • Click the Environment tab and check, if here is some entry made. Usually the second point should be selected.

    Best greetings from Germany
    Olaf
    Sunday, February 15, 2009 5:09 PM
    Moderator
  • Thanks Olaf, it turns out that the Remote Desktop Connection entry for WHS had been set to try to run TaskManager on connection (this was likely set by mistake, as there are a couple of other RDC entries it was probably intended for).

    All fixed. I removed the RDC start program setting for the WHS and I can remote login again :-)   
    I can't help thinking I should have thought of that - but I didn't...

    Thanks again for your help. 

    • Marked as answer by dlorde Sunday, February 15, 2009 6:38 PM
    Sunday, February 15, 2009 5:36 PM

All replies

  • Hi,
    did you at any time try to change settings for the program to start at remote desktop logon (which is unsupported use of WHS btw.)?
    • If you are logged on to the console, open Terminal Services Configuration in Control Panel/Administrative Tools.
    • Under Connections right click RDP-Tcp and select Properties.
    • Click the Environment tab and check, if here is some entry made. Usually the second point should be selected.

    Best greetings from Germany
    Olaf
    Sunday, February 15, 2009 5:09 PM
    Moderator
  • Thanks Olaf, it turns out that the Remote Desktop Connection entry for WHS had been set to try to run TaskManager on connection (this was likely set by mistake, as there are a couple of other RDC entries it was probably intended for).

    All fixed. I removed the RDC start program setting for the WHS and I can remote login again :-)   
    I can't help thinking I should have thought of that - but I didn't...

    Thanks again for your help. 

    • Marked as answer by dlorde Sunday, February 15, 2009 6:38 PM
    Sunday, February 15, 2009 5:36 PM