none
uninstalling software on remote computers RRS feed

  • Question

  • Hi all

    I am having difficulties trying to uninstall software from targeted PCs. For my initial research, i was testing uninstalling a software on my machine via WMIC. WMIC works great on a standalone device however when i tried to uninstall a software on another machine remotely i get an error

    i tried using the txt document method as well and same error

    Any ideas how i can connect to a pc remotely with wmic? i tried connecting with test device's IP address as well but that didn't change anything

    If wmic does not work, can you advise what i need to do in powershell to achieve this?

    Thanks in advance

    • Moved by Bill_Stewart Thursday, December 20, 2018 10:00 PM This is not "teach me how to use command-line tools" forum
    Sunday, October 28, 2018 11:00 PM

All replies

  • Is you account a member of the local Administrators group on the remote computer? Usually, if you are a member of the "Domain Admins" group that makes you a member, since that group is added to the local Administrators group when the computer is joined to the domain.

    Richard Mueller - MVP Enterprise Mobility (Identity and Access)

    Sunday, October 28, 2018 11:07 PM
  • WMIC is a system utility.  This is a scripting forum.  You need to post I n the Windows General forum for help with how to use utilities.

    I will note that you need to read the help for WMIC carefully to learn how to use it.  "/node" takes a simple computer name. 


    \_(ツ)_/

    Sunday, October 28, 2018 11:07 PM
  • sorry about that, i will ask this question under windows general. how do i close or delete this thread?
    Sunday, October 28, 2018 11:14 PM
  • Hi Richard, thanks for your reply. I am running cmd via domain admin credentials. I will be re-asking this question under windows general
    Sunday, October 28, 2018 11:16 PM
  • sorry about that, i will ask this question under windows general. how do i close or delete this thread?

    First read the help carefully to see how to use "Node" parameter.

    If you need further help then the Windows General forum will find more users with  experience with command line utilities.

    You can also look in the gallery for scripts that add and remove products via WMI using PowerShell or you can search and find a number of blogs that will describe how to do this.

    WMIC uninstall products remotely

    Results of search


    \_(ツ)_/

    Sunday, October 28, 2018 11:38 PM
  • Note also that the error seems to indicate that you have network or system problems or the names you are using are not in your domain.


    \_(ツ)_/

    Sunday, October 28, 2018 11:42 PM
  • thanks JRV,

    the WMIC site that you suggested is what i used as reference. it works great on my local machine but not on another machine

    i am able to ping my test machine which is why i tried using /node:"com-1707", /node:"192.168.xxx.xxx" and /node:@"c:\pc.txt"

    the test machine is domain joined as well


    • Edited by Tommy0824 Sunday, October 28, 2018 11:48 PM
    Sunday, October 28, 2018 11:47 PM
  • Firewall?  WMI corrupt on remote systems? 

    One command tells you that the system is unreachable remotely.  We can't fix that. 


    \_(ツ)_/

    Sunday, October 28, 2018 11:50 PM
  • disabling the firewall seems to have resolved my issue. i was not aware that wmi is disabled by default on Windows, thanks for your input

    its always the small simple things that you miss, sometimes you just need an extra pair of eyes

    thanks again. now to research what port to open for wmic to work on remote pcs




    • Edited by Tommy0824 Monday, October 29, 2018 1:35 AM
    Monday, October 29, 2018 12:03 AM
  • In Group Policy enable the management ports exception.  This should always be set on a domain and for the domain only scope.

    \_(ツ)_/

    Monday, October 29, 2018 1:07 AM