locked
WHS 2011 Server Backup SLOW and fails often RRS feed

  • Question

  • I have about 700gig of data on my WHS 2011.  All works well except all of my server backups fail.  The failures bother me but my main problem is they are so slow like I let it run all night only to find the next morning its sitting at 60% or so and appears to be stopped.  I will watch it for an hour and the percentage does not increase.  If I back up only small amounts of data like 1 gig it takes an unreasonable amount of time but by adding small amounts of data at a time I have about 80% of the 700gig backed up but my 45gig file of pictures will not complete.

    First queston:  Is WHS 2011 server backup this slow?  I estimate well over 20 hours for my 700gig if I ever get it to finish.  An internet search reveals many that have this problem but I find no mention of it on this forum.

    Second question: What might be causing my problem if this is not typical (and I hope to H it is not typical but from what I have read on other forums I fear that it is another MS screw up).

    ASUS P7H55M MB  -  Core i5  - 8 gig RAM  - Hitachi 1T (OS) &2t WD Green hard dives  -  Backup drive in hot swap bay(SATA) used WD 2T Green and tried Seagate 2T.  Also tried USB External with WD Green 2T

     

    Sunday, September 11, 2011 3:07 AM

All replies

  • No, it's not typical. Your initial backup of that volume of data may well take several hours, but after that it should be pretty quick (as there will typically not be large volumes of changed data from one backup to the next). As for what the issue actually might be, I'd guess hardware or driver issues related to the drives you're using in server storage.

    Forums are a very bad place to go to get a picture of the relative frequency of any issue, with any product. They'are always skewed heavily in favor of people having some problem or other; nobody drops by to say "Hey, I'm not having any issues at all!". :)


    I'm not on the WHS team, I just post a lot. :)
    Sunday, September 11, 2011 12:21 PM
  • Thanks for the reply,  I downloaded the latest ASUS drivers for the Intel storage and Intel chipset.  ASUS install refused to install them no doubt because they don't provide drivers for WHS specifically but they are for Win 7 64 bit.  I bypassed the ASUS Setup and used Setup.exe to install them and they installed fine but the backup is still the same.  (Previously I just let WHS 2011 install the chipset and drive drivers from the install disk and windows update). Can you help  - should I just let WHS install the drivers or should I use the ASUS WIN 7 64 bit drivers?

    I tried to just copy my big picture folder (228 gig) to the backup drive.  Took an unreasonable amount of time also so I removed my pretty yellow SATA data cable and took the drive out of the hot swappable bay.  Copy was much better but found 3 .tif files that take almost 20 minutes each to copy.  Still working on that one, they copy fine on another computer.  It seems like the cable or bay was causing most of the problem.  I am trying a backup of all but the picture files right now and am hoping for the best.

    Appreciate your suggestion of hardware issues, I think it got me on the right track.

    Thanks

    Roy

    Sunday, September 11, 2011 5:23 PM
  • Roy

    The best way to install drivers is to log in locally or RDP to your Server and  use Device Manager. Select "Update Driver Software", "Browse my computer .." and then go to the actual folder where the drivers are located. Having said that, if the Setup worked then I would not expect that method to make any difference. W7 64-bit are normally the best option if there are no specific ones for Windows Server 2008 R2 available. Try connecting the drive internally.


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Sunday, September 11, 2011 5:50 PM
  • ... but found 3 .tif files that take almost 20 minutes each to copy. ...

    How big are they? 20 minutes, even at USB 2.0 speeds, is in the gigabytes per file range...

    Have you checked all the drives involved for errors, using chkdsk /r?


    I'm not on the WHS team, I just post a lot. :)
    Sunday, September 11, 2011 11:27 PM
  • Sorry I haven't been back for a while but I have been busy troubleshooting things.  The .tif files are about 12MB. Yes I have run the disk check in WHS 2011 on all the drives and it reports no errors. I assume that is just chkdsk.  I have changed SATA cables, hot swap drive bay and SATA ports on the MB etc. with no cure, however:

    The disk the troublesome files are on is a 1T Hitachi.  If I copy the folder to another hard drive, which took overnight, then copy them from this disk to a third drive all is well. (228gig folder in just over 1.5 hrs.)  If I copy them from the Hitachi to that same destination drive I had to stop it after 3 plus hours.  Found a Hitachi utility to test their drives - it doesn't work. Called Hitachi they couldnt help with the utility or the drive. It is still under warranty so I can RMA it if further testing shows its bad. The Hitachi drive is also my system drive so I am restoring my system right now to another drive and will check file copy and then server backup.  Pretty sure the drive is the problem.

    Boy that restor seems quite limited!  I used the install disk method and told it to repair.  I first had a 500gig WD drive in place of the 1T Hitachi.  I tried all combinations of the check box options and it would not let me restore just the operating system or the entire drive (there is only 300 gig of data on the Hitachi).  Kept saying there is no disk that can be used for the restore (or something like that)  I told it to restore the operating system only which is on a 60gig partition and it just would not do it. Just a pain in the ---.  I just want to restore 300 gig and the operating system on a 500gig drive it should do it!!! Acronis does a proportional image this should also.  I had to put a 2T drive in to get it to work. I don't want to do that but no choice. Possibly I am missing something?

    Had the same problem changing a client drive from 150gig SSD to 120gig SSD. (90 gig of data) WHS restore just would not do it.  I had to go back to Windows 7 and shrink the partition to less than 120gig (I could also do it right in restore but I just felt more comfortable doing it in Win 7) Hopefully I will be able to expand it to use the full SSD after I test it out.  Its easier to just use Acronis and not fool with WHS restore.

    Roy

    Wednesday, September 14, 2011 2:41 AM
  • Restoring to a smaller drive is not supported, no. There are circumstances where it's possible, but the way backups work, combined with the way NTFS uses disk space for it's metafiles, results in the general requirement to use a drive of the same size or larger.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 14, 2011 3:42 AM
  • Hi to all, I´m experiencing the very same problem......  I installed WHS 2011 on my HP data vault X310   - was a huge makover ... but ok its now up and running... in the last days I´m experiencing the following...    (from the 4 physical drivers - system SSD + 3x 1 TB drives) - sometimes D:\   sometimes E:\   sometimes both are giving and error...   - checked the cables connections - restarted server - removed server backup and set it back again    but  I´m experiencing the very same issue  (server backup goes to 50% rather quickly ... than sometimes stops there for over 40 minutes ... and than gets sometimes to 60% but than stops... ;-()    (I checked with Scandisk for errors)  NO errors...   backup is taking very very long or fails (drivers or other hardware is also out of game as everything is fine.   Do you have some suggestions??

    Monday, February 6, 2012 8:11 PM
  • Hi,

    I'm having this problem too. It's now been 24 hours to back 1Tb of data from a single drive to an external USB hard drive. Even after the initial server backup, subsequent backups are still very slow, taking hours and hours and failing often. The hardware running on the server is pretty good (Pentium G530 Sandy Bridge + 4Gb RAM) so it's not a question of lacking resources. After investigating the subject, this seems to be a problem shared by a lot of people so it would be really good for Microsoft support to have a look at this.

    Tuesday, March 27, 2012 12:35 PM
  • Hi - I am getting a similar problem to the OP after installing WHS 2011 last week, transitioned from WHS v1.  Occasionally (about 1 in 3) backups fail to include the f: driver and then when I rerun, it gets to 75% and then takes a while to run.  Sometimes it also restarts saying back up for server is not configured at all!  From reading the posts, I can't believe we all have hardware issues.  Anyone seen a good way of investigating to get to the real error for those of us who are home users and not Server 2008 aware?

    • Proposed as answer by JHardesty Saturday, June 2, 2012 7:39 PM
    • Unproposed as answer by JHardesty Saturday, June 2, 2012 7:39 PM
    Wednesday, March 28, 2012 4:11 PM
  • FOUND ON MICROSOFT CONNECT !

    Posted by Microsoft on 5/30/2012 at 7:30 PM

    “The device is not ready” issue reported here is caused by less space to create Shadow Copy on volume.
    It is solved by increasing the shadow copy maximum size in the impacted volumes. After trying it, there is no such issue reported from customer.

    Best wishes,
    Windows Home and Small Business Server Team
    Saturday, June 2, 2012 7:40 PM
  • Can you provide more details or a link to the solution?

    • Proposed as answer by AntiphonII Monday, September 24, 2012 11:13 PM
    • Unproposed as answer by AntiphonII Monday, September 24, 2012 11:14 PM
    Wednesday, June 6, 2012 9:25 PM
  • Have a simple workaround to this problem, finally!

    1) You must configure the storage drive(s) to use an unlimited amount of space for shadow volumes; this will allow it to go a much longer interval before it chokes.  Procedure: my_computer->right-click the drive->properties->shadow_copies tab->settings; choose the no-limit radio button

    2) when it does choke you blow away all the shadow volume copies and it will work just fine again for a long while.  Procedure: my_computer->right-click the drive->properties->shadow_copies tab->disable; when it finished click enable then ok. Shadow copies are now re-enabled with none hanging around.

    3) I don't know if this third step helps or not, but I also configured my drive to take only one volume snapshot a day instead of two, configured my server backups to run at 4am only instead of twice a day.  I configured the one volume snapshot to occur 12 hours away from the backup.  In my case it was always the 4am backup that failed and the volume was configured to take a snapshot at 6am.  I figure they bumped into one another.

    Procedure: my_computer->right-click the drive->properties->shadow_copies tab->settings->schedule->check "show multiple schedules" box-> edit the schedule to be far far away in time from the scheduled backups.

    You're done!



    • Proposed as answer by AntiphonII Monday, September 24, 2012 11:26 PM
    • Edited by AntiphonII Monday, September 24, 2012 11:29 PM
    Monday, September 24, 2012 11:26 PM
  • Ken may be correct -- forums may not be the best place to gauge the frequency of an issue... however, not for the reason he states.  Often times, one person complaining about a problem underlies many other people having the same issue (who aren't on that forum, don't post to forums, don't know to post there, are trying to figure the problem out for themselves, don't understand they have a problem, give up in frustration, etc).  If you do see many instances of a particular problem being listed on a forum, it is a sign of a problem; you don't need to get everyone's vote to draw useful conclusions.

    That all being said... I'm having this problem as well.  Here is the story:

    My WHS2011 computer has a pair of mirrored (within Windows) hard drives.  One of them had a fatal problem.  Fortunately, I had the other half of the mirror, plus a complete backup of that data on a recently-acquired external drive.  WHS had done several successful backups to that drive, so I know the external drive was happy.  Moreover, I purchased two new internal drives for the computer, installed them, and did a restore of the backup data from the external drive to the new mirrored set in the server.  The restore happened with no problem (about 1TB over USB3).  

    Afterwards, I let the server try to do its regular backup, which meant it (the server) would be backing up to that same external drive previously used.  (This was within an hour of the restore being done, with all the components still in exactly the same location as they had been during the restore... no chance to damage any of the equipment in the interim).  The backup percentage started very quickly, running up to the 66% point in less than half an hour.  However, after that, the progress was very choked.  A couple more hours, and had made it to 77%.  Mind you, no data had changed on the mirror set inside the server... it should be exactly the same as the backup data on the external drive.  The whole backup should really be backing up zero additional data.  That backup drive had worked perfectly for backups prior to the restore, and worked perfectly during the restore.  It has only used about half of the available space on that external drive, and since no additional data really needs to be added to the external backup drive, space shouldn't even be an issue.

    I've had need to restart the server during the new backup process (impending lightning storms, etc).  Upon restart of the backup process, it runs up to 66% and again slows to a crawl, not even moving quickly to the point where it had previously been.

    There is no window into what Windows is doing at this stage -- is it comparing files, moving files, resetting file dates, doing checksums, fixing some damaged file?  Dunno.  Hopefully none of those -- that is the point of the back-and-restore process after all, right?  The files are returned with full integrity, right?  I'm an optimist, and going to figure that the backup system has sufficient error checking to make corrupt data statistically a non-issue.

    So... driver issues are out, hardware issues are out.  Let's look at other systemic causes.

    Tuesday, October 2, 2012 2:07 AM
  • Pfurrie, have you tried doing anything I wrote in the post before yours?  Those things solved my problem.
    Wednesday, October 3, 2012 1:31 AM
  • Do you have any "large" files on the volume that is being backed-up?    I'm getting the same issue where the initial backup is taking foreeeeever... but if I exclude a folder that has several > 3GB files... then the rest of the volume backups quickly....    IE, it backups the 400GB volume quick.. but if I add in 5 3GB .iso files.. the next backup will take several hours (if it finished before the server kills the task).  

    Tuesday, June 25, 2013 11:57 AM
  • A potential solution:

    Do not exclude any files or folders from the backup!

    It looks like the backup switches from a block backup (faster) to a file backup (slower) when anything is excluded. 

    Perhaps, if you want to exclude something, keep it on a separate drive. 

    Some details here: http://social.technet.microsoft.com/Forums/windowsserver/en-US/fb2b8b33-cea7-42e8-b264-09d8c5eab30f/failed-server-backup-dextendrmmetadatatxflogtxflogblf?forum=winserveressentials

    S.


    • Proposed as answer by Stan2016 Saturday, July 19, 2014 12:22 PM
    • Edited by Stan2016 Saturday, July 19, 2014 12:26 PM
    Saturday, July 19, 2014 12:22 PM
  • We found the solution to this issue in our case. Turns out WHS 2011 creates the volume shadow max size settings on new volumes way way too small. In our case our data drives VSS max size was set to 5GB and that's why the backups dragged on and on when we had large files in the mix.   We simply disabled VSS on all volumes and turned it back on using Windows explorer and let it reset the max size to a more reasonable 10% off the disk.     Once we did that, sure enough after a few days all server backups started to work again and we could see the total VSS size on each volume both in the disk properties as well as from the command line ended up being slightly over the overly restrictive and artificial 5 GB limit set by WHS.

    • Proposed as answer by ArtieMcD Saturday, March 21, 2015 2:33 PM
    Saturday, March 21, 2015 2:33 PM