none
Add link problem RRS feed

  • Question

  • Before the recent forum update when I inserted a link, highlighted it and clicked the link button, it was automatically saved as a link and I just needed to confirm. Now I have to save it first into a clipboard and paste into the Web Address. Can you please fix it so we don't need to do extra work?

    Thanks in advance.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Tuesday, April 3, 2012 2:08 PM
    Moderator

Answers

  • I think we can have both:

    1. Pressing Enter will turn link into a link

    2. If we highlighted a text and pressed a link button and that text is a web address, then put it into a web address.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 13, 2012 9:12 PM
    Moderator
  • I think we can have both:

    1. Pressing Enter will turn link into a link

    2. If we highlighted a text and pressed a link button and that text is a web address, then put it into a web address.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    I doubt we'll get #2 because you can argue that it helps prevent trojan spam links, because the feature would create inconsistent behavior, and because the solution is to just paste the link into the top field. Plus it might be weird. For example, in Word, I click the hyperlink option and it autofills a hyperlink for me. Well, whenever it does that, I end up pasting in the URL anyway, thus doubling the URL and making me have to do even more work to fix the thing. Sometimes simple and consistent is better (or at least the argument can be made, whether or not we agree with it).

     

    But I think scenario #1 is something that's expected and hard to argue against. I'm not 100% sure if it will solve the problem, but it might help. It's obvious that most people don't automatically press the spacebar to make a link active (like I do), so maybe they press Enter instead. I'll make sure it's on the bug list.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 9:22 PM
    Owner

All replies

  • Before the recent forum update when I inserted a link, highlighted it and clicked the link button, it was automatically saved as a link and I just needed to confirm. Now I have to save it first into a clipboard and paste into the Web Address. Can you please fix it so we don't need to do extra work?


    What you are describing has never been necessary.   If you have link which you want to insert and have itself as its label, just insert it on its own line.   The only bug resulting from a "recent forum update" that I am aware of is that you can't just press Enter after pasting it without either a new line or new paragraph being inserted before the link.   I hope that gets fixed soon.   It is really "getting old."   Ah.  Maybe this is a "feechur"?   E.g. notice that when you do that that the "Unlink" button then becomes active, proving that the link you just inserted is in fact a link, without even needing to use the "link button", same as ever.

    ---

    Tuesday, April 3, 2012 4:14 PM
  • Robert,

    I've been fixing a few links problems in Transact-SQL forum. I highlight the link, press link button. At this point the link is at the second line, but the first line (Web address) is blank. I am using Google Chrome. I found I had to copy that link first in order to insert it into Web Address.

    This is a new incorrect behavior and I'd like it fixed.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Tuesday, April 3, 2012 4:37 PM
    Moderator
  • I highlight the link, press link button.

    I am using Google Chrome.

    There's the problem then.   If you were using IE you wouldn't even see that popup unless you requested it with Ctrl-k but I'm not sure if it would then be assumed that just because the thing you had highlighted was a URL than you would want that same URL used as its link...

    Do you not get the same Link and Unlink toolbar buttons in Chrome?   They are working (though I am often oblivious of them) and I would say the Ctrl-k option is WAD (the way that you are complaining about.)


    ---

    Wednesday, April 4, 2012 4:14 PM
  • I think you're missing my point. Is it hard for you to try in Google Chrome? Assuming that original link lost its link (it didn't for me when I copy the link from another site, but I was fixing other people's threads). For demonstration purpose I went to HTML view and removed the link.

    http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/dealing-with-the-the-text  

    Ok, now I highlight this link with a mouse and press the Link button. At this point that link is inserted into the second textbox, not the first!

    In the forum's version before the latest update, the insert link menu was smaller, it only had one textbox and it was filled when I highlighted the link.

    That's the main difference and I need it fixed.

    ---------

    UPDATE. I tried it now in IE9 and I got the exact same problem as I am getting with Google Chrome.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog




    Wednesday, April 4, 2012 4:47 PM
    Moderator
  • This is what I was talking about

    http://social.msdn.microsoft.com/Forums/en-US/transactsql/thread/7b33db16-f28c-4933-8d0a-76cfb9b185a7

    Please check how links are shown in this message.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Wednesday, April 4, 2012 7:46 PM
    Moderator
  • This is what I was talking about

    http://social.msdn.microsoft.com/Forums/en-US/transactsql/thread/7b33db16-f28c-4933-8d0a-76cfb9b185a7

    Apparently you would have to append a space.   Then you can see that the Unlink button would become active and checking the HTML see that it would have become a link.   As I said, don't use Ctrl-k.

    Robert
    ---

    Thursday, April 5, 2012 11:49 AM
  • I don't understand you and once again, this is not my thread. I always take care to insert clickable links.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Thursday, April 5, 2012 12:44 PM
    Moderator
  • Test

    This worked perfectly for me. Can't repro.


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)


    Friday, April 13, 2012 4:49 PM
    Owner
  • Create a message with the link but make it not link (in HTML). Then highlight it and press Link button. The address will be in the Text, not in the web-address. I am using Google Chrome.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 13, 2012 5:29 PM
    Moderator
  • Create a message with the link but make it not link (in HTML). Then highlight it and press Link button. The address will be in the Text, not in the web-address. I am using Google Chrome.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Let's go back a little. So how do you make it with a link but not a link? Do you paste it in (Ctrl+V), use the link button, or add it in the HTML window?

    Then how do you make it not link? What do you remove in the HTML?

    Then highlight and press the Link button. I got that.

    Then what does that one sentence mean where the address is in the text?

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 6:49 PM
    Owner
  • Oh and why would you do all that to make a link? I just paste it in and am good to go. Don't use the Link button or the HTML window.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 6:50 PM
    Owner
  • When I paste a link, in 99% it is pasted as a link (it sometimes doesn't work when I take it from IE in one site). Anyway, for my own threads I always make sure the link is clickable. However, I often see cases when link is not showing as clickable link. (I don't know how the person who created that message did it). If I see such cases in T-SQL forum, often I need to correct such link. And this is the case I am talking about. For me in order to make that link to become a link I had to copy it first.

    ------------------

    For your own tests I suggested to first create a link which is not a link (you can do by pasting that link in HTML view or going back to HTML view and removing the <a attribute). After that you can experiment and you'll see the same behavior I do.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 13, 2012 6:56 PM
    Moderator
  • I observe the same behavior as Naomi.

    Repro steps:

    1. Create a new reply.
    2. Paste a URL into the message, e.g. http://www.microsoft.com
    3. Highlight the URL and click the Link button. The link window appears. The web address is "http://" and the link text is the URL I pasted:

    Weird Insert Link behavior

    I believe the assumption is because this text is a URL, that it should be in the web address field.

    EDIT: You'll also notice that the http://www.microsoft.com  URL did not automatically become a hyperlink which creates an annoying UX issue for users of the forum ("why do I have to select this darn URL to use it? Hasn't anyone elver heard of a link?")


    Jason Warren
    Infrastructure Specialist
    Habañero Consulting Group
    www.habaneros.com/blog




    Friday, April 13, 2012 8:39 PM
  • Unfortunately, this is By Design. I guess the expectation is that you wouldn't highlight a URL to add a link to it. Why would you, when it's already a link?

    Plus you could argue that this way it's harder (but still possible via the HTML) to make a linked URL actually go to a different page than the URL you see and click on (you know, like those spam emails from ebay and facebook that I keep getting).

    So here's how you make a link active that you paste in...

    1. If it's from an address bar, no problem: http://social.microsoft.com/Forums/en-US/reportabug/thread/66d169ca-3b67-4970-8630-ab1e1141732c

    It automatically becomes an active link.

    2. If it's from text and not yet an active link, such as... http://www.microsoft.com

    ...Then you need to press the space bar after you paste it in: http://www.microsoft.com

    3. If it's from text and is already an active link... Test

    No problem. It becomes an active link.

     

    So we could request scenario 2 as a bug (I believe this is the one mentioned as a bug) so that you don't have to press the spacebar...

    But when do you actually do this? When do you have a URL that's not an active link?

    Note that I've also seen this a lot, especially in the Where Is forum. But honestly I think the main problem isn't pasting. I think the main problem is that people are just typing out the URL and forget or don't know to press the spacebar at the end, like this... www.microsoft.com

    They press Enter or click Submit without making the link active by pressing the spacebar, like this... www.microsoft.com  

    So maybe the best bug here is the request to have the Enter button also turn the URL into an active link (as expected), and not just pressing the spacebar.

    Thoughts?

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)


    Friday, April 13, 2012 9:05 PM
    Owner
  • When I paste a link, in 99% it is pasted as a link (it sometimes doesn't work when I take it from IE in one site). Anyway, for my own threads I always make sure the link is clickable. However, I often see cases when link is not showing as clickable link. (I don't know how the person who created that message did it). If I see such cases in T-SQL forum, often I need to correct such link. And this is the case I am talking about. For me in order to make that link to become a link I had to copy it first.

    ------------------

    For your own tests I suggested to first create a link which is not a link (you can do by pasting that link in HTML view or going back to HTML view and removing the <a attribute). After that you can experiment and you'll see the same behavior I do.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    For the short term (until a code update is made), to fix those links that you edit (I sometimes do this too), just press the spacebar after the URL. The URL must start with either "http://" or "www." in order for this trick to work.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)


    Friday, April 13, 2012 9:10 PM
    Owner
  • I think we can have both:

    1. Pressing Enter will turn link into a link

    2. If we highlighted a text and pressed a link button and that text is a web address, then put it into a web address.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 13, 2012 9:12 PM
    Moderator
  • I think we can have both:

    1. Pressing Enter will turn link into a link

    2. If we highlighted a text and pressed a link button and that text is a web address, then put it into a web address.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    I doubt we'll get #2 because you can argue that it helps prevent trojan spam links, because the feature would create inconsistent behavior, and because the solution is to just paste the link into the top field. Plus it might be weird. For example, in Word, I click the hyperlink option and it autofills a hyperlink for me. Well, whenever it does that, I end up pasting in the URL anyway, thus doubling the URL and making me have to do even more work to fix the thing. Sometimes simple and consistent is better (or at least the argument can be made, whether or not we agree with it).

     

    But I think scenario #1 is something that's expected and hard to argue against. I'm not 100% sure if it will solve the problem, but it might help. It's obvious that most people don't automatically press the spacebar to make a link active (like I do), so maybe they press Enter instead. I'll make sure it's on the bug list.

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 9:22 PM
    Owner
  • I've tried it in this thread http://social.msdn.microsoft.com/Forums/en-US/transactsql/thread/7b33db16-f28c-4933-8d0a-76cfb9b185a7 (last message) and it didn't work. 

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 13, 2012 9:47 PM
    Moderator
  • I've tried it in this thread http://social.msdn.microsoft.com/Forums/en-US/transactsql/thread/7b33db16-f28c-4933-8d0a-76cfb9b185a7 (last message) and it didn't work. 

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    I'm not an admin there. I've been doing it fine in the Where Is forum. I'll try it on yours above...

    Okay. I did it successfully and easily on two replies above (made your URL a link by pressing the spacebar).


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)


    Friday, April 13, 2012 9:53 PM
    Owner
  • I observe the same behavior as Naomi.

    Repro steps:

    1. Create a new reply.
    2. Paste a URL into the message, e.g. http://www.microsoft.com
    3. Highlight the URL and click the Link button. The link window appears. The web address is "http://" and the link text is the URL I pasted:

    Weird Insert Link behavior

    I believe the assumption is because this text is a URL, that it should be in the web address field.

    EDIT: You'll also notice that the http://www.microsoft.com  URL did not automatically become a hyperlink which creates an annoying UX issue for users of the forum ("why do I have to select this darn URL to use it? Hasn't anyone elver heard of a link?")


    Jason Warren
    Infrastructure Specialist
    Habañero Consulting Group
    www.habaneros.com/blog





    Test - made your URL a link by pressing the spacebar

    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 9:54 PM
    Owner
  • I think you're missing my point. Is it hard for you to try in Google Chrome? Assuming that original link lost its link (it didn't for me when I copy the link from another site, but I was fixing other people's threads). For demonstration purpose I went to HTML view and removed the link.

    http://blogs.lessthandot.com/index.php/DataMgmt/DataDesign/dealing-with-the-the-text

    Ok, now I highlight this link with a mouse and press the Link button. At this point that link is inserted into the second textbox, not the first!

    In the forum's version before the latest update, the insert link menu was smaller, it only had one textbox and it was filled when I highlighted the link.

    That's the main difference and I need it fixed.

    ---------

    UPDATE. I tried it now in IE9 and I got the exact same problem as I am getting with Google Chrome.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog




    Test - made your URL a link by pressing the spacebar

    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 9:55 PM
    Owner
  • I've tried it again with my message - it doesn't work for me. Are you using Google Chrome? I put the cursor at the end of the link text and tried pressing the spacebar on my laptop - no effect

    www.microsoft.com

    Pressing space bar doesn't make a text a link for me. 


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 13, 2012 10:24 PM
    Moderator
  • Ah, yes. It works in IE. So that's another bug then. It should be compatible with all browsers... unless other browsers disallow it.

    Can someone also test Firefox and Safari?

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 13, 2012 11:10 PM
    Owner
  • Also, can we verify that this isn't just the way Chrome works?

    Thanks!


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 20, 2012 7:32 PM
    Owner
  • Well, I just posted a comment in my husband's Lifejournal with a link (pressed an Enter or space bar) after typing a link and nothing happened, the link didn't became a link.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 20, 2012 8:08 PM
    Moderator
  • Well, I just posted a comment in my husband's Lifejournal with a link (pressed an Enter or space bar) after typing a link and nothing happened, the link didn't became a link.

    The suggested procedure was given for the original example cited, e.g. these forums.   It's possible that other web apps would not support just pasting a URL string and automatically making it into an HTML anchor tag without taking some more explicit action.



    ---

    Friday, April 20, 2012 9:31 PM
  • Well, I just posted a comment in my husband's Lifejournal with a link (pressed an Enter or space bar) after typing a link and nothing happened, the link didn't became a link.

    The suggested procedure was given for the original example cited, e.g. these forums.   It's possible that other web apps would not support just pasting a URL string and automatically making it into an HTML anchor tag without taking some more explicit action.



    ---


    Well Chrome isn't but IE is.

    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 20, 2012 9:37 PM
    Owner
  • Well, I just posted a comment in my husband's Lifejournal with a link (pressed an Enter or space bar) after typing a link and nothing happened, the link didn't became a link.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    So it sounds like this is out of the forums hands and this is a Google Chrome issue where they don't support the "feature" of making a link active with the spacebar. Is that right?

    However, pressing Enter to make a link active (in Chrome browsers) does sound like a reasonable feature request.


    Ed Price (a.k.a User Ed), SQL Server Experience Program Manager (Blog, Twitter, Wiki)

    Friday, April 20, 2012 9:39 PM
    Owner
  • Robert,

    I was testing in Google Chrome adding a link by just typing it. It doesn't seem to work in Google Chrome. Also, when I copy link from IE into Chrome, it doesn't become a link.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Friday, April 20, 2012 9:52 PM
    Moderator
  • So it sounds like this is out of the forums hands and this is a Google Chrome issue where they don't support the "feature" of making a link active with the spacebar. Is that right?

    Ed,  I don't think that the workaround we are touting for these forums is a feature of IE.   I think it is a feature of these forums (e.g. in its scripts).   Think about it.   Why should pasting or modifying a string which looks like a URL become an HTML anchor?  Something that I might agree with in support of Naomi's requirement would be if the Link Insertion procedure (e.g. Ctrl-k or the Edit frame's Toolbar button) was used there could be a checkbox (which could persist) which requested that if someone had highlighted a string which looked like a URL (e.g. to be the anchor's label) then it could be used as the anchor's href= value too.   E.g. in order to avoid them having to do a Copy and Paste to achieve that same result.


    Robert
    ---

    Saturday, April 21, 2012 12:08 AM