locked
Auto update reboot RRS feed

  • Question

  • I had a rather long overdue e-mail synchoronization running on 2 computers in my OneCare (tm) circle. It had run for 8 hours when I went to bed. When I woke up the morning, I found one of the computers had been rebooted automatically by a OneCare Windows update. All my work had been lost.

     

    If the only thing I run is the Windows operating system, this might be a good thing. However, I do run other important applications to run a home based business. While Windows is a wonderful and necessary thing for my computing environment, I am held hostage by anything that would decide to restart itself without any prior notice. If I turn automatic updates off, I am constantly reminded that I am not safe because of my non-standard settings.

     

    Could you please point me to someone in Microsoft that understands that the Windows environment is used to support the operation of my computer, and it is not important enough at any time to take over control of my computing environment to the point that it is detrimental to my business? As an IT professional with over 30 years experience, I find it unconscionable that any operating system would reboot as a default behavior.

    Wednesday, August 13, 2008 11:43 AM

Answers

  • I have moved your post to the Tune-up topic, since Windows Automatic Updates are monitored  by this function in OneCare.

     

    First of all, the updates that rebooted your PC were not OneCare updates. Yesterday, 8/12, was "patch Tuesday" when Microsoft deploys critical and important security updates via Automatic Updates.

     

    OneCare requires that AU be configured to download and install updates automatically. You can select either immediate or at a scheduled time. In both cases, a reboot will happen if needed as part of the patch installs.

     

    I have regularly replied to posts like yours with my opinion on OneCare's requirement for AU settings, so I'll spare the details, but simply state that I think OneCare's approach is too simplistic and it isn't a good thing for those of us who want some control over when the PC will update and reboot.

     

    I'll offer you a possible workaround (unsupported) to prevent the automatic reboot in XP:

    Start/Run type regedit. and press Enter Navigate to HKEY_LOCAL_MACHINE \Software\Policies \Microsoft\Windows \WindowsUpdate\AU

    Change the “NoAutoRebootWithLoggedOnUsers” DWord value to 1 to Disallow auto reboot.

    Press OK

    See here for details or a Reg file to do the above for you:

    http://portal.itauth.com/2007/11/13/disable-annoying-auto-reboot-after-windows-update

     

    -steve

     

    Wednesday, August 13, 2008 2:30 PM
    Moderator

All replies

  • I have moved your post to the Tune-up topic, since Windows Automatic Updates are monitored  by this function in OneCare.

     

    First of all, the updates that rebooted your PC were not OneCare updates. Yesterday, 8/12, was "patch Tuesday" when Microsoft deploys critical and important security updates via Automatic Updates.

     

    OneCare requires that AU be configured to download and install updates automatically. You can select either immediate or at a scheduled time. In both cases, a reboot will happen if needed as part of the patch installs.

     

    I have regularly replied to posts like yours with my opinion on OneCare's requirement for AU settings, so I'll spare the details, but simply state that I think OneCare's approach is too simplistic and it isn't a good thing for those of us who want some control over when the PC will update and reboot.

     

    I'll offer you a possible workaround (unsupported) to prevent the automatic reboot in XP:

    Start/Run type regedit. and press Enter Navigate to HKEY_LOCAL_MACHINE \Software\Policies \Microsoft\Windows \WindowsUpdate\AU

    Change the “NoAutoRebootWithLoggedOnUsers” DWord value to 1 to Disallow auto reboot.

    Press OK

    See here for details or a Reg file to do the above for you:

    http://portal.itauth.com/2007/11/13/disable-annoying-auto-reboot-after-windows-update

     

    -steve

     

    Wednesday, August 13, 2008 2:30 PM
    Moderator
  • If anyone can help --

     

    I had a similar "auto-reboot" loss of work because I did not realize that OneCare changed my Windows Update settings from "download updates and ask me" to "download and reboot automatically" -- so I have changed my Windows Update settings to again ask me.

     

    However, now OneCare has a big RED icon, telling me I am in tremendous jeopardy because I am not automatically applying updates -- and there does not seem to be a way to tell OneCare to calm down and that it's ok.  Ideally OneCare would allow me to tell it to ignore this problem, or it would get smart and only go "red" when there actually is an update waiting to be applied (I have no updates needed right now so why is it red)?

     

    Anyway does anyone have any suggestions?

     

    Thank you.


    Ron

    Thursday, December 11, 2008 4:54 PM
  • OneCare requires AU to be set to download and install automatically. Your only choices are - immediate or at a specified time. If you select a time when you are not likely to have work interrupted by the reboot, you should be fine. If you review this forum topic folder you'll see lots of discussions about this issue. I don't agree with OneCare's simplistic approach, but it does go a very long way to stop people from ignoring the little icon that informs them of updates ready for installation. Not applying updates is a major reason for some people's PCs being compromised, unfortunately.

    -steve

    Thursday, December 11, 2008 7:41 PM
    Moderator