locked
how to using URL in CRM on premise deployment without port numbers? RRS feed

  • Question

  • Hi, all..

    I want to know how to using URL in CRM on premise deployment without port numbers?,

    example: now i have http://crmserver:5555/testorganization, and then i want to use http://crmserver/testorganization

    can i do that for on premise deployment?

     

    thanks,

    Glo.

    Monday, May 3, 2010 4:24 AM

Answers

  • Hi Edwin,

    Thank you very much for the answer, your link and reference its very helpfully. i will test it in my test environment.

    Glo.

    • Marked as answer by pntr Tuesday, May 4, 2010 2:12 AM
    Monday, May 3, 2010 9:07 AM
  • You can also update manually the configuration:

    • Update IIS site to change the port from 5555 to 80 (be sure there is no existing site using port 80)
    • Update Registry (HKLM\Software\Microsoft\MSCRM) to change all references to URL using port 5555 to port 80
    • Update DeploymentProperties table in MSCRM_CONFIG database to change all references to port 5555 to port 80
    As said by Edwin, try this in test environment first.


    My blog : http://mscrmtools.blogspot.com

    All my tools on my new dedicated site: MSCRMTools Repository
    • Marked as answer by pntr Tuesday, May 4, 2010 2:12 AM
    Monday, May 3, 2010 11:23 AM
    Moderator

All replies

  • Glo,

    Few Thoughts to share according to my understanding,

    Any web application(Including MS CRM 4) deployed in a system will contain a port number - so the default port number will be 80 , this is determined during installation - if you select a Create a New website for CRM - it will be port 5555 , alternatively - For Use an existing Website the default port number is 80 (which is pre-determined).

    Likewise, if your CRM Application is on port 80 , there is no need to mention the port number in the URL.

    I.E, you can simply access it using http://crmserver/orgname.

    The Other case is exactly what you are having in your test deployment.

    However, I suggest you to try using the CRM Deployment Configuration tool which can be found here to update the port number of your CRM Application.

    Refer this thread as well.

    Note : Strongly recommend you to experiment this in your test environment .

     

    Thanks...

     

     


    Cheers, Edwin
    Monday, May 3, 2010 7:57 AM
  • Hi Edwin,

    Thank you very much for the answer, your link and reference its very helpfully. i will test it in my test environment.

    Glo.

    • Marked as answer by pntr Tuesday, May 4, 2010 2:12 AM
    Monday, May 3, 2010 9:07 AM
  • You can also update manually the configuration:

    • Update IIS site to change the port from 5555 to 80 (be sure there is no existing site using port 80)
    • Update Registry (HKLM\Software\Microsoft\MSCRM) to change all references to URL using port 5555 to port 80
    • Update DeploymentProperties table in MSCRM_CONFIG database to change all references to port 5555 to port 80
    As said by Edwin, try this in test environment first.


    My blog : http://mscrmtools.blogspot.com

    All my tools on my new dedicated site: MSCRMTools Repository
    • Marked as answer by pntr Tuesday, May 4, 2010 2:12 AM
    Monday, May 3, 2010 11:23 AM
    Moderator