locked
Error configuring Gmail as the outgoing smtp email server in CRM 4.0 RRS feed

  • Question

  • Hi,
       I followed the steps to configure smtp.gmail.com as the outgoing email server, changed the port to 465, but outgoing email still doesn't seem to be working ...
    Anybody who might have configured this? (I tried with netcat and I can open smtp.gmail.com port 465 from the CRM server). I have installed Update Rollup 7.

    #61042 - An error occurred while processing the outgoing e-mail message with subject "test3 CRM:0001003" for SMTP: <hidden for privacy> for delivery through smtp.gmail.com. System.Net.Mail.SmtpException: The operation has timed out.
       at System.Net.Mail.SmtpClient.Send(MailMessage message)
       at Microsoft.Crm.Tools.Email.Providers.SmtpPollingSendEmailProvider.ProcessMessageInternal(email emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()

    Thanks,
    Vivek
    Thursday, November 19, 2009 1:34 AM

Answers

  • Have you tried using port 587? I haven't configure email router to send mail out from Google. If you figure it out, please share with all of us.
    Darren Liu | 刘嘉鸿 | MS CRM MVP | English Blog: http://msdynamicscrm-e.blogspot.com | Chinese Blog: http://liudarren.spaces.live.com
    Thursday, November 19, 2009 2:46 AM
    Moderator
  • Port 587 worked in my case , make sure u have use ssl true check and port number 587.
    • Proposed as answer by Scott.B Wednesday, August 4, 2010 2:32 AM
    • Marked as answer by Donna EdwardsMVP Thursday, August 12, 2010 1:41 PM
    Wednesday, February 3, 2010 4:24 AM
  • I got it working with 587.

    In my case the "Test Access" button was working with 465. I had to switch it to 587 before sending emails would work through the CRM web interface.

    Wednesday, August 4, 2010 2:33 AM

All replies

  • Have you tried using port 587? I haven't configure email router to send mail out from Google. If you figure it out, please share with all of us.
    Darren Liu | 刘嘉鸿 | MS CRM MVP | English Blog: http://msdynamicscrm-e.blogspot.com | Chinese Blog: http://liudarren.spaces.live.com
    Thursday, November 19, 2009 2:46 AM
    Moderator
  • I switched the port to 587 and it still wouldn't work. In fact I sniffed the packets and see the TCP SYN retrasmitting and then timing out.
    Then I wrote a little sample .NET console app that sends email using the same smtp server/port and that doesn't work either.
    However I just tried running the same app on the neighboring Windows 7 PC and it worked fine!
    Not sure if there is something blocking my connection to port 587 on the Windows Server 2008 box that runs MSCRM 4.0.
    I also checked that my Windows Firewall is turned off. Anything else wrong here?

    Thanks,
    Vivek
    Thursday, November 19, 2009 7:04 PM
  • Port 587 worked in my case , make sure u have use ssl true check and port number 587.
    • Proposed as answer by Scott.B Wednesday, August 4, 2010 2:32 AM
    • Marked as answer by Donna EdwardsMVP Thursday, August 12, 2010 1:41 PM
    Wednesday, February 3, 2010 4:24 AM
  • Hi,

    It did not work for me either. Is anyone solved this?
    Best Regards,
    Gagandeep Singh
    http://mscrmnovice.blogspot.com
    Tuesday, February 9, 2010 8:40 AM
  • I got it working with 587.

    In my case the "Test Access" button was working with 465. I had to switch it to 587 before sending emails would work through the CRM web interface.

    Wednesday, August 4, 2010 2:33 AM