locked
Unable to expand out volume on partition "Access is denied" RRS feed

  • Question

  • I am trying to resize a partition that contains the OS files. When I try to use the Disk Management interface, I am able to see the partition, right click and select Extend Drive. Walks me through the screens but returns "Virtual Disk Manager, Access is Denied" error when I hit Finish.

    I have tried taking ownership of the C drive and all the sub folders, tried diskpart, tried Powershell but everything returns an error that Access is denied. 

    I have tried booting in to Safe Mode, moving the pagefile over to another disk but nothing seems to work. 

    This is an OS drive for our Exchanage server so formatting or blowing it away in any fashion is out of the question. I am able to drill in to every folder and create files, delete files, basically do everything except expand the drive out. 

    These are the only errors related to the issue that I can find in the logs under, Application and Service Logs > Microsoft > Windows > StorageManagement

    Is there something obvious that I am missing as to why Disk Manager is denying my access?


    • Edited by Chipperchoi Tuesday, December 15, 2020 5:30 PM
    Tuesday, December 15, 2020 5:23 PM

Answers