locked
ICE doesn't launch. RRS feed

  • Question

  • Windows 7 Pro. SP1. 64 bit OS. ICE 2.0.3 for 64 bit Windows.

    Worked ok before.  Haven't used it for a while.

    Can't launch it anymore.

    Repair, reinstall neither work.

    Please help.


    George

    Monday, March 28, 2016 5:18 PM

All replies

  • Hi, George, 

    I'm only your fellow ICE user, but I'd like to help if I'm able.

    If you use Windows Explorer/My Computer to navigate to C:\Program Files\ and navigate to your Image Composite Editor folder (possibly inside a Microsoft Research folder) are you able to launch ICE if you double click the actual .exe file instead of a shortcut to it on your start menu or desktop?

    Tuesday, March 29, 2016 6:37 AM
  • No.

    I can see ICE on the Task Manager => Processes list briefly.

    The ICE window never show up.

    Thanks for reply.


    George

    Tuesday, March 29, 2016 2:48 PM
  • If you create another desktop profile on your computer (one which has permissions to install programs) and try running the ICE installer there, does it work?

    During ICE's install process you should be able to choose to install ICE 'for this user only' (as opposed to 'for everyone').
    Tuesday, March 29, 2016 5:16 PM
  • I uninstall the ICE 2.0.3

    Switch to another admin account; install ICE for everyone;

    and launch ICE.

    Same problem: it only show up briefly on the process list, the user interface never show up.

    Thanks for reply.


    George

    Tuesday, March 29, 2016 5:39 PM
  • Just another fellow ICE user as well - have you installed all recent Microsoft Windows updates? - I assume ICE depend on some .NET compunents.

    And right-clicking the exe file, and running it as administrator doesn't help either?


    • Edited by KjeldOlesen Tuesday, March 29, 2016 8:12 PM
    Tuesday, March 29, 2016 8:12 PM
  • I've .Net Framework 4.6 installed.  ICE requires 4.5 in the ICE.exe.config file.

    Run as admin doesn't help.

    Thanks for reply.


    George

    Tuesday, March 29, 2016 9:17 PM
  • Rolled back to version 1.4.4

    This version works fine.


    George

    Thursday, March 31, 2016 4:36 PM
  • George, I now have the same problem, too: ICE 2.0.3 won't launch, whether I try using the Desktop icon, or "ICE.exe" in C:\Program Files\Microsoft Research\Image Composite Editor. Like you, I tried un-installing and re-installing, but that didn't help. Restarting the computer didn't help.

    Re-installing (or attempting to Repair) the program now returns a new and unexpected error message, saying that "the module  C:\Program Files\Microsoft Research\Image Composite Editor\ShellExtension.dll failed to register". Additionally, the message displays an error code: "HRESULT  -2147024703" (Gee, THAT tells me a lot!) I tried re-installing with my virus program disabled: no luck. I tried re-installing with my User Account Control set to minimum: no luck, either. I thought that, maybe, I should try installing the 32-bit version of ICE to see how that would go, but the 32-bit installer said, "You can't use this 32-bit installer! You need to use the 64-bit installer, FOOL!" So I gave up trying to install ICE 32-bit.

    Like you, I hadn't used the program for a while. Apparently, since the last time we used ICE successfully, something inside both our computers was changed which causes the ShellExtension.dll registration problem. It seems that without ICE's ShellExtension.dll being properly installed and registered, the program simply won't launch. I suspect that a Microsoft Windows Update (related to security enhancements) might be the unintentional culprit, or the problem might be caused by any number of other things.

    A web search revealed some possible fixes in getting .dll's to register via Windows' "elevated" command line prompt or the "Run" command, but none of those worked for me. So that's why I'm HERE in the hopes that the knowledgeable authors of ICE 3.0.2, or it's knowledgeable users, can offer a definitive solution in solving ICE's "ShellExtension won't register" mystery.

    Thank you! And have a great day!


    PS: The installer urges users to have the latest version of Microsoft .NET Framework installed, which I do: Version 4.6.2, downloaded and installed earlier today, but that didn't help, either. 
    • Edited by DB Kettrey Wednesday, July 6, 2016 1:30 PM
    Wednesday, July 6, 2016 1:23 PM