locked
Unable to remove a Ribbon button and group with Ribbon Workbench 2013/2015 RRS feed

  • Question

  • I used the Ribbon Workbench and created a group with a 'Test' button and now try to delete it.

    However, when I right-click on it, I was only allowed to hide or uncustomize it with the 'Delete'

    option grayed out. Why is it? Is there a way to completely delete the button and group?

    Thanks in advance for any help.

    _____
    Danny

    Friday, July 17, 2015 11:19 PM

All replies

  • Suresh,

    Thanks for the reply.

    I tried both but still could not remove the button/group.

    Once, the Ribbon Workbench enabled the 'Delete' option after I right clicked on the group and selected 'Customize Group'.

    But nothing really changed after I published and re-open the solution, do it did not seem to work with Workbench.

    Second approach, I tried customizing the group (with Workbench and published it) and exported the solution (as unmanaged). Opened the

    exported customizations.xml and I was able to see the custom actions for that button/group; I deleted them and imported

    the modified solution back to server with no error. When I opened the solution again with Workbench the button was still on the form.

    Any idea why Dynamics did not delete the button/group?

    Thanks,

    _____
    Danny




    Saturday, July 18, 2015 6:16 PM
  • Hi Danny,

    Old post i know, but i'm currently suffering from almost the same thing. Did you ever find a solution?

    Cheers


    Chris

    Tuesday, April 18, 2017 10:11 AM