locked
Need CRM 4.0 help really bad...please help. RRS feed

  • Question

  • Hi all,

    Thank you in advance, but I am driving nuts due to the weird symptoms of our CRM server.

    First of all, I am totally CRM newbie. I am just trying to install CRM 4.0 server for our sales department, but it never went smoothly. And the most weird thing is, some functionality work, some do not. I have no clue why...

    For now, the main problem is for workflow sending mass emails. I tried on demand or automatic, but all stucked in waiting status in the system jobs. When I search with the error code and messages, it lists:

    Error code: -2,147,204,346

    Message: "System.Net.WebException: The request failed with HTTP status 401: Unauthorized. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Microsoft.Crm.SdkTypeProxy.CrmService.Retrieve(String entityName, Guid id, ColumnSetBase ColumnSet) at Microsoft.Crm.Asynchronous.SdkTypeProxyCrmServiceWrapper.Retrie."

    I have tried every method I could google or from here, no luck.So please help, I really appreciate it.

     

    Most other functionality of our CRM server work just fine, such as logging with the domain user, sending mass email with mail merge, customize UI of records, track emails, importing data from csv files. I really dont see why this one got stucked. Also, we tried a workflow that can create contacts on demand (NOT automatically, my mistake!), and it worked (we just dont know how to stop it properly...so we delete it eventually). That is, the workflow itself is OK under SOME conditions...Argh, I am getting more frustrated. orz

    Thanks!

     

    PS: the configuration of both the server and clients go as simple as possible.

    The CRM server: installed on win  2003 R2 standard, on a hyper-v virtual machine of win 2008 R2 enterprise base server. I only installed the CRM server and the srss data connector.

    The client: only installed offline outlook of the crm client, working with IE and outlook.

    The network: The server has two virtual nics, one for ad one for internet. However, I did NOT use IFD tool, and we only use the internet address. I tried IFDtool, and ended up not working and reinstalling (run time error from IE).

     

    Still no help? please... orz

    I have double checked the error code, it is actually an AsyncNetworkError according to MS (0x80044306=-2,147,204,346). However, restarting the service did not help. And according to the link in the reference, this error means "network error", which does not make sense...

    REF:

    http://blogs.msdn.com/b/crm/archive/2009/03/25/when-do-asynchronous-jobs-fail-suspend-or-retry.aspx


    Friday, July 15, 2011 1:28 AM

Answers

All replies

  • Can you send any emails from workflow?
    Wednesday, July 27, 2011 8:08 AM
  • Can you send emails by methods other than workflow?  If now, then it might be an email router problem.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Sunday, July 31, 2011 4:48 PM
    Moderator
  • Hi,

    Thanks for replying. I almost gave up, but not my bosses nor the sales department...

    Yes I can send direct emails, or using MS word to do the email merge and then send out emails with attachments. Also, I never installed the email router just to keep things as simple as possible.

    Another questions is, could we create email templates with attachments? I noticed that I can either send email with templates only, or compose the email manually with attachments. There is no way to use both?

    -self answer: No. According to the CRM help--"You cannot add an attachment to a template. You can either attach files to individual messages after they are created with the template, or save the file to a public Web site and include a Web address in the template."

    Thanks,

    PS: After restoring CRM, it seems like the workflow can work now (sending mass email either by templates or manually but with attachments). However, using MS Word to merge email fail. Sending direct emails (with templates) seems to work but slow (5 minutes lag). I can also double click a contact and then send a email to him or her with attachments or not. And this time no error code or message in the system jobs...

    Argh, so confused! It seems OK now, but I cannot never know when it is NOT OK again...and I guess I cannot restore again after we formally start to use the CRM server.




    Wednesday, August 10, 2011 11:19 PM
  • You can create a email with attachment using workflows: add step "send email" and there you can add attachment(s) to email.

    Thursday, August 11, 2011 5:37 AM
  • In order to send emails with CRM you first need to install the email router.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Friday, August 12, 2011 3:14 AM
    Moderator
  • actually you don't need email router to be able to send emails, second option is to install crm for office outlook client and use outlook as middleware when sending (and receiving) emails.

     

    Yours, Vonsu

    Friday, August 12, 2011 12:13 PM
  • If your organization uses email queues then you do need to use it.  Otherwise you are correct.  Unless all of your users are using the outlook add-on it is usually best practice to configure it.
    Jamie Miley
    Check out my about.me profile!
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Saturday, August 13, 2011 3:51 PM
    Moderator