locked
increase remote user timeout WHS 2011 RRS feed

  • Question

  • I would like to increase the remote user timeout so that we can down/up load larger files with out it timing out. I have searched for days and only found reference to a Server toolkit add in. I have tried to install this no less then 4 times all with no luck. I get the MSI file which is different then the normal add in file type and it will install a program group. But when i clicked publish add-in the first time it told me files where not there. So i searched some more and found i should put files in a folder named add ins, so i did. now it tells me the files are already copied and to install i need to go to Administrator Console. I do not have one so i guess it means the Dashboard. well once there i look under the "available" add-ins and i do not see this at all. to me it looks like it is not for WHS 2011 but i can not be sure. I have searched all over as i dais and can only find these type of instructions, never anything that says it is for WHS 2011 or has steps to follow that coincide with the way WHS 2011 looks. I have also tried a few 3rd party but none of them offer a way to increase time outs like this tool kit is said to. I have also looked over my polices a good many times with no luck ether. Thanks in advance for any help, and sorry if this is a repeat question but i can not find anything that fits my issue on a WHS2011 setup.
    Tuesday, June 7, 2011 2:12 AM

Answers

  • From the original WHS Remote Access documentation:

    "Large File Uploads May Time Out Before Finishing
    If you upload a large file or group of files by using Remote Access, the session may time out before the
    upload finishes. To resolve this problem, you can increase the time-out parameter in the Windows Home
    Server web.config file.

    To increase the Remote Access time

    1. Use mstsc.exe to start a Remote Desktop Connection session to your

    Caution

    Be careful when using a Remote Desktop Connection to your home server. You can

    damage Windows Home Server functionality if you use Remote Desktop incorrectly.

    2. Use a text editor, such as notepad.exe, to open C:\Inetpub\remote\web.config

    3. Locate the following line:

    <sessionState mode="InProc" cookieless="false" timeout="20"/>

    4. Replace "20" (which represents 20 minutes) with a larger number, to allow your uploads to finish.

    Note

    If you change the timeout value to more than 200 minutes, you must also change the

    executionTimeout value. Search for the following line

    <httpRuntime maxRequestLength="2097151" executionTimeout="12000"/>

    and increase the executionTimeout value (Measured in seconds) to the same or greater value than the timeout value (measured in minutes)

    5. Save your change, close the file, and then log off from your Remote Desktop Connection

    session.

    6. Use Remote Access to upload your file or files, to ensure that the new time-out parameter is sufficient to finish the upload.

     

    Important

    If you increase the time-out parameter, you increase your security risk. Do not leave a computer

    that has an active session unattended in a public place.

    ------------------------------------------------------

    This was for WHS1, however WHS 2011 has a file with this content located at C:\Program Files\Windows Server\Bin\WebApps\RemoteAccess\web.config. It is set to timeout at 30 minutes - is that what you are seeing? I have not tried it but it looks like a good starting point. Look at this thread:

     

    Similar Thread
     
    Phil

     


    Friday, June 10, 2011 5:56 PM

All replies

  • From the original WHS Remote Access documentation:

    "Large File Uploads May Time Out Before Finishing
    If you upload a large file or group of files by using Remote Access, the session may time out before the
    upload finishes. To resolve this problem, you can increase the time-out parameter in the Windows Home
    Server web.config file.

    To increase the Remote Access time

    1. Use mstsc.exe to start a Remote Desktop Connection session to your

    Caution

    Be careful when using a Remote Desktop Connection to your home server. You can

    damage Windows Home Server functionality if you use Remote Desktop incorrectly.

    2. Use a text editor, such as notepad.exe, to open C:\Inetpub\remote\web.config

    3. Locate the following line:

    <sessionState mode="InProc" cookieless="false" timeout="20"/>

    4. Replace "20" (which represents 20 minutes) with a larger number, to allow your uploads to finish.

    Note

    If you change the timeout value to more than 200 minutes, you must also change the

    executionTimeout value. Search for the following line

    <httpRuntime maxRequestLength="2097151" executionTimeout="12000"/>

    and increase the executionTimeout value (Measured in seconds) to the same or greater value than the timeout value (measured in minutes)

    5. Save your change, close the file, and then log off from your Remote Desktop Connection

    session.

    6. Use Remote Access to upload your file or files, to ensure that the new time-out parameter is sufficient to finish the upload.

     

    Important

    If you increase the time-out parameter, you increase your security risk. Do not leave a computer

    that has an active session unattended in a public place.

    ------------------------------------------------------

    This was for WHS1, however WHS 2011 has a file with this content located at C:\Program Files\Windows Server\Bin\WebApps\RemoteAccess\web.config. It is set to timeout at 30 minutes - is that what you are seeing? I have not tried it but it looks like a good starting point. Look at this thread:

     

    Similar Thread
     
    Phil

     


    Friday, June 10, 2011 5:56 PM
  • This worked (solved the problem for me thanks to Phil:

    C:\Program Files\Windows Server\Bin\WebApps\RemoteAccess\web.config

    I upped (changed) the time out value in web.config above and it solved the problem for me.

    Thanks again Phil.

    George


    Tuesday, August 16, 2011 3:39 PM