locked
Trouble sending emails using Direct Email RRS feed

  • Question

    • MS CRM 4.0/SQL 2005/Exchange 2007
    • Email router service seems fine
    • Async service seems fine

    We have had our direct email function stop 'working.' It was sending emails, etc. Sometime in the last few weeks, it stopped sending emails. This is not a function used regularly so I don't know exactly when it stopped working. 

    The other email functionality works (campaigns, mail merges, new email from contact or adv find, etc.). However, whenever we send a Direct Email, they do not arrive. I have checked the Exchange Msg Tracking log. The Direct Emails have not gone through, other emails do appear in the tracking log.

    Any idea what is going on? where to start looking?
     

    Monday, March 1, 2010 7:03 PM

Answers

  • Our solution was that we had 'Bulk Email' system jobs that were blocking all successive Bulk Email jobs. Identified and cancelled all in Waiting status. Direct Email works fine now.
    • Marked as answer by Marcus Mattson Wednesday, August 11, 2010 6:58 PM
    Wednesday, August 11, 2010 6:58 PM

All replies

  • Marcus,

    Have you applied any Update Rollups lately? I have seen situations where the users' CRM options have been undone and need to be reset, especially the email setting and in particular after applying UR 7.

    So is this for one, several or all users? I would go into Outlook/IE and check their email settings.

    Also, I would go into the router and run through the settings again.
    Jerry http://www.crminnovation.com
    Monday, March 1, 2010 8:07 PM
  • No rollups recently.
    Monday, March 1, 2010 8:09 PM
  • Also, this is for all users tested (various roles, etc.). Checked email settings. They are all the same. Have tried resetting and modifying . Same results. All other email functionality works. Just Direct Email. I checked Exchange to make sure they were not being blocked there. From what I can tell, they are not even getting to Exchange. 

    Email Router Config on the server seems fine. Tests succeed.
    Tuesday, March 2, 2010 1:30 PM
  • After further testing it seems related to the templates. When I send direct email to a user or contact not using templates, it works. However, when a template is used, it fails without error. Activities are NOT logged against contact as expected.
    • Edited by Marcus Mattson Tuesday, March 2, 2010 4:06 PM changed activities from logged to not logged
    Tuesday, March 2, 2010 3:18 PM
  • I have run tracelog and cannot find any exceptions or errors that relate to this issue. This makes me think that it is get thrown out at the desktop browser and not returning an error to CRM. I receive no errors in the desktop eventlog, either. I have tried running this from the server as well - still no luck.
    Tuesday, March 2, 2010 5:03 PM
  • Is this an issue with all templates including the default templates installed with CRM?  Try creating a simple template with just the word Hi or something like that.   Make it a Global template and see if that works.
    Best Regards | Twitter: edwardsdna
    Thursday, March 4, 2010 2:45 PM
  • I did that, too. It seems only to be templates with Direct Email. If I am on a contact or use a mail merge the email gets delivered fine. I have tried Global and Personal templates.
    Friday, March 5, 2010 3:27 AM
  • Our solution was that we had 'Bulk Email' system jobs that were blocking all successive Bulk Email jobs. Identified and cancelled all in Waiting status. Direct Email works fine now.
    • Marked as answer by Marcus Mattson Wednesday, August 11, 2010 6:58 PM
    Wednesday, August 11, 2010 6:58 PM
  • this say "pop" email.  Why do I suddenly need a password and one occasion I needed to give them a different e-mail.  I do not have any other e-mail address, I do not have a smart phone.  I was trying to get my husband another e-mail address because one of the sites that we order medicine from will not accept him in because of the same e-mail address as mine.... then this trouble started

    Monday, December 28, 2015 3:04 PM
  • Also I don't have outlook.  Why can't I get into my e-mail

    Monday, December 28, 2015 3:07 PM
  • You are replying to a thread that is over 5 years old.  If you are having an issue that you need some help with, please create a new post.  i'm certain someone will assist.

    Regards, Donna

    Monday, December 28, 2015 3:07 PM