locked
send mail when task is assigned in crm 2013 RRS feed

  • Question

  • Hi,

      I am using crm 2013. when i am assigning a task another user the mail should go to that assignee. for that i have created a workflow but the mail is not going( i.e. it is not created). how can i do this.

    Please help me if you have any information.

    Thanks in advance,


    Nagaraj

    Wednesday, February 12, 2014 9:46 AM

All replies

  • Hi,

    When you say that the email is not created - do you mean it is not sent? The key is to define who your email will be sent from. If you are not using the Email Router and you make you alert email sent from a particular user (e.g. you) then you will have to have outlook running so that the email can be downloaded and sent. The most common way to sent alert emails is to create a special user that you send these emails from and then configure the Email Router to send these emails - https://community.dynamics.com/crm/b/magnetismsolutionscrmblog/archive/2013/09/17/installing-the-crm-2013-email-router.aspx

    If you look in the Draft Emails view - you should see your email waiting to be sent if your workflow is using the Send Email Activity?

    Hope this helps,

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Wednesday, February 12, 2014 11:40 AM
    Answerer
  • Hi Scott,

       No, the email activity in crm is not creating.

       I am assigning the tasks by using my user account in CRM.

       And i have configured the CRM Outlook client in my outlook. 

      do i need to check anything. how can i know whether the work flow ran or not. 

       


    Nagaraj

    Wednesday, February 12, 2014 12:27 PM
  • Hi Scott,

      When i create and assign a task to another user ,  the workflow is running and staying in the Waiting state. i have opened the system jobs and opened the workflow job it is showing the error as

    "The email must have at least one recipient  before it can be sent" 

    Please help me if you know about this error.

    awaiting for your response. Thanks in advance. 




    Nagaraj

    Monday, February 17, 2014 12:22 PM
  • Hi

    Does you send email step under workflow has a recipient ? In your case, it should be the assignee of the task.

    Next check, if assignee is a systemuser. Does the user, has email address field filled on the user record under systemuser entity.

    Also check, if the workflow owner user has, send email on behalf other users, checked under security roles

    Monday, February 17, 2014 12:47 PM
  • Hi CRMDevlpr,

    Thanks for the reply. please find my answers below.

      1. Please see the below image: 

    2. Yes assignee is the system administrator. both the sender and receiver  of the task have email id's.

    3. where can i check the "send email on behalf other users" property ?



    Nagaraj

    Monday, February 17, 2014 1:23 PM
  • Hi

    1. Is assign to a custom lookup field ?

    2. If yes, what is the type of this lookup field.

    3. Are you sure, when you create a task, you are filling this assign to field on task.

    4. Is workflow registered on create of task ? 

    Monday, February 17, 2014 1:54 PM
  • Hi, 

     1. yes, it is a lookup field.

     2. It is pointing to users. but we are not using it in the form.

     3. After creating the task we are clicking on the assign button and assigning the task to a user.

     4. No, work flow is registered with "record assigning" and "record field is changed"(Assign to field).



    Nagaraj

    Monday, February 17, 2014 2:05 PM
  • Hi, 

     Now the email is sent.what i did is: 

    i have added "Assign To" field to the form and filled the the field with user which i would like to assign the task.

    but i want to send the mail when i click on the Assign button in the command bar.

    Thanks,


    Nagaraj

    Monday, February 17, 2014 2:09 PM
  • Hi Again

    For first question, I meant to ask if its a system field or a CUSTOM field.

    I think its a custom field, because I do not see any field named as assigned to in my vanilla setup.

    So you need to do following changes :

    Approach 1 : 1. Before send email step, add another step where you update assign to field with owner field of Task.

    Approach 2 : 1. Set to field to owner of task.

    Reason behind this is, when you assign a task to another user, its the owner field of CRM record which is updated

    Monday, February 17, 2014 2:12 PM
  • Hi Nagaraj, Rather than use this custom field, use the 'Owner' field. This will be set to the user you select when using the Assign button. Hope this helps, Scott

    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Tuesday, February 18, 2014 7:57 AM
    Answerer
  • Hi Scott,

      when i am using the owner field , for first time assigning the mail going, when assign the task second time to the same user the mail is not going.

      I want the mail to be send every time when i assign to user(if the user is already assigned with the same task, i want reassign the task).

    Thanks,


    Nagaraj

    Tuesday, February 18, 2014 8:12 AM
  • Set the workflow trigger as On change of Owner field, instead of Assign to field.

    It should work in that case everytime when you assign task to anyone.

    Tuesday, February 18, 2014 8:21 AM
  • Hi Nagaraj,

    I suspect that when you assign it to the same person, because the owner is not changing, the workflow will not fire. You may need to create a custom button that changes some other field to trigger the workflow - or you could use a dialog and start it via a custom button - http://ribbonworkbench.uservoice.com/knowledgebase/articles/140652-create-a-dialog-short-cut-ribbon-button

    Hope this helps,

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Tuesday, February 18, 2014 8:41 AM
    Answerer
  • Hi Scott,

      I have deactivated the workflow and set the workflow to trigger on change of the owner field, after activating of the workflow it is not enabling.

    Thanks,


    Nagaraj

    Tuesday, February 18, 2014 9:04 AM
  • Does it gives any error why it could not be enabled ?

    Do you see any error on any of the steps ?

    Tuesday, February 18, 2014 9:05 AM