locked
Off Topic: Help with re-installing Windows System file "CSRSS.EXE File" RRS feed

  • General discussion

  • Mcafee found a virus on the file CSRSS.EXE from Windows system, but couldn't clean it so it done it's job and deleted the file :-( .  When my pc boots up n comes on to desktop, it opens an alert window which says "windows cannot find c:\windows\config\csrss.exe", I have searched Microsoft & Google sites,but not coming up with any info of how to put the file back or repair the system, Tried Regcure but nothing.... Can some1 Plz HELP (DESPERATE).....!!!  Only hoping I don't have to do a complete re-install of the system. Any help will be much appreciated.
    Thursday, July 5, 2007 9:05 PM

All replies

  • You can try running the system file checker (Start>run>sfc /scannow) which might recover your missing or damaged system file but your best option would be to contact McAfee support - http://us.mcafee.com/root/support.asp
    Thursday, July 5, 2007 10:19 PM
    Moderator
  • dont work, already try'd it, thanx for try'n to help
    Monday, July 9, 2007 4:30 PM
  •  

    Hi Leroy;

     

    Just had the same problem. In my case Norton picked up a virus and deleted it, then I started to get the same error you did every time I rebooted the computer. Tried just about everything...Microsoft was no help. I didn't reinstall the OS... just did a repair. That worked fine until I tried to get updates from Microsoft. The updates would download but would not install. Here is the solution to your problem.

     

    ....Using your installation disk, do a windows repair.

    ....After completing the repair get Dial-A-Fix program from http://wiki.djlizard.net/Dial-a-fix#Mirrors.2Fdownload_locations.2C_and_articles

    ....Download the program (it is a WAR file....extract and run the Dial-A-Fix executable. Make sure that you select all the boxes shown in the GUI and hit

    GO.

    ....After the program has finished running go get updates and install. That's it!

     

    I'm not exactly sure why everything got f**ked up but I think some files related to registry got corrupted. Anyway, this definitely worked for me. Hope this helps. Any problems, let me know and I'll try to help.

     

    Lew

     

    Thursday, July 12, 2007 2:34 PM
  • Hi Lew

     

         I try'd 2do a repair bt it asks for adimistrater password, i dont knw what it is & put da sys on m sel n neva put 1 in so i dont knw why its aksing for 1...???? cos dats 1 of 1st things i try'd 2do
    Thursday, July 12, 2007 6:36 PM
  •  

    Hey Leroy;

     

    It seems there must be one on there if it's asking for it. Anyway, try this...

     

    Start

    Run

    Type in cmd and click ok

     

    When the command prompt opens type in: control userpasswords2

     

    A User Accounts window will pop up. Highlight Administrator under UserName then click the Reset Password button at the bottom. Put in an easy password then reboot.

     

    When you now logon to Windows, go to the control panel and open up User Accounts. Go the Administrator account and remove the password so this doesn't happen again. It will ask you to confirm your id by typing in your password (the one you just created..) and then simply click Remove.

     

    If this works, you can then just follow the directions I sent earlier to correct your previous problem.

     

    I'll keep checking back here a little more often to see if everything is ok.

     

    Good Luck!

     

    Lew 

     

     

     

     

     

    Friday, July 13, 2007 6:52 PM
  • Leroy & Lew this thread is Off topic for this forum and I will be locking it.

     

    chuck

    Friday, July 13, 2007 8:00 PM