locked
CRM Reporting Services - Not showing Current User - Only the Admin RRS feed

  • Question

  • Hi All,

     

    I have a technical CRM Reporting issue that I’m struggling to resolve.

    When I generate any report from CRM at the bottom of the report it gives the “Prepared by: <user>” message.

    Our issue is that when any user generates a report, it always displays the Admin user name and not the user’s details that actually generate the report.

    I have checked several SQL user and security settings but can’t seem to get it right.

     

    My only guess is that the cerdentials of the reports must be set to the user under the ReportGroup

     

    We need the users details to restrict certain results to specific users

     

    Any andvice will be greatly Appreciated

     

    Thanks

    Tuesday, September 30, 2008 6:35 PM

Answers

  • Open up IIS  (cmd > inetmgr)

    Right click on the virtual directory is IIS Manager. Click Directory Security > Authentication and Access Control - Edit.

    Ensure anonymous is disabled and integrated security checked.

    To find the related application pool, right click on the virtual directory > Properties. Click on the Virtual Directory tab and see which application pool is selected.

    Application pools are at the top, above the web site lists. Right click> Properties> Identity.

    Could you try the following.

    Create a user that has access only to create and view leads. Create a report which displays lead detail. Use the following sql:

    Select leadid from FilteredLead as CRMAF_FilteredLead

    Publish to MSCRM and run as the restricted user.

    If you can only see a single lead then the problem lies with your report. If however you can see leads for which you do not have permission, the problem lies in the configuration above.

    Cheers,

    Karlo
    Wednesday, October 1, 2008 6:00 PM

All replies

  • For the "Prepared by: <user>", what code did you put for generating the <user>?  Also, when you run the report as different users, do they see different results (based on their security level) or they see the same results?  I am wondering maybe the reports is run based on the admin.

    Tuesday, September 30, 2008 7:38 PM
  • Hi,

    Check to ensure that the reports and reportServer virtual directory are running integrated authentication and that the related application pool is not running as a dedicated user (the admin). Also check the respective web.config for your reportServer contains the following settings :

        <authentication mode="Windows" />
        <identity impersonate="true" />

    Cheers,

    Karlo
    Tuesday, September 30, 2008 8:46 PM
  •  

    Thanks for the reply, I would like clarify the steps I will take:

     

    To ensure that the reports run integrated security:- I nav to the http://myserver/reports/Pages/Folder.aspx reports manager > datasource > properties > general > and select 'Windows integrated security'

     

    To ensure that the Report Server Vitual Directory run integrated authentication:- I nav to the Reporting Services Configuration tool > Connect to my report server instance > Click on Report Server Vitual Directory >

     

    This is where I get stuck

     

     

    How do i set integrated authentication for Report Server Vitual Directory?

    How will i access the related application pool?

    Where will i find the web.config file for my Report Server to complete the suggested steps?

     

    Thanks so much

    Wednesday, October 1, 2008 8:40 AM
  • Open up IIS  (cmd > inetmgr)

    Right click on the virtual directory is IIS Manager. Click Directory Security > Authentication and Access Control - Edit.

    Ensure anonymous is disabled and integrated security checked.

    To find the related application pool, right click on the virtual directory > Properties. Click on the Virtual Directory tab and see which application pool is selected.

    Application pools are at the top, above the web site lists. Right click> Properties> Identity.

    Could you try the following.

    Create a user that has access only to create and view leads. Create a report which displays lead detail. Use the following sql:

    Select leadid from FilteredLead as CRMAF_FilteredLead

    Publish to MSCRM and run as the restricted user.

    If you can only see a single lead then the problem lies with your report. If however you can see leads for which you do not have permission, the problem lies in the configuration above.

    Cheers,

    Karlo
    Wednesday, October 1, 2008 6:00 PM
  • Hi,


    Could you tell me what you did to get it to work in the end?

    Cheers,

    Karlo
    Thursday, October 2, 2008 9:47 PM