Configuring the email router with CRM Online and Exchange Online RRS feed

All replies

  • ok, I have further information on this.

    When I actually log onto the Exchange Online Account I see that a draft email message has been created but not sent.  When I manually open the draft email and click send I see the following error

    You don't have the permissions required to send messages from this mailbox.

    Thursday, February 9, 2012 2:26 AM
  • I am having the exact same issue. If you switch the outgoing to SMTP, and setup the server to be your owa server, then try to send the email out, be sure to check the TLS box, and change the outbound port to 567 in the advanced setting.s LEt me know if it is succesful. I am still trying to get the 401 issue fixed. My email router was working great for about a month, and then just started doing this out of the blue. I did check the permissions on the mailbox, and everythign seems to be correct.

    I think it was from an update to exchange or somethign and the documentation hasnt caiught up with it. I think it is realted to remote-powwershell commands in Office 365.  I have enabled my user that we are ucing for the CRM router to have full access to the mailboxes, and can open every other user's mailbox from OWA.

    Someone has to know how to fix this...

    Friday, February 10, 2012 1:36 AM
  • I connected to outlook and gave delegate access rights also, but still I am unable to get this done.  Does anyone have any idea on how to fix this?
    • Proposed as answer by Rick Neubauer Thursday, February 23, 2012 12:46 AM
    • Unproposed as answer by Rick Neubauer Thursday, February 23, 2012 12:46 AM
    Friday, February 10, 2012 10:54 AM
  • I spent about 3 hours on the phone with CRM support and they couldnt get it working either. I went on holiday for a week, and he sent me an email saying he thought he had figured it out. He did. It is all about the URL. The autodiscover did not work. But, if you go to OWA and get the POD server that your mailbox is located on , and insert it into the following URL, you should be able to start sending and receiving via the CRM email router. Sorry this took so long to figure out....


    Mine ended up being:


    Please let me know if this resolves your issue. Again, this is for exchange online, and CRM online.


    Thursday, February 23, 2012 12:50 AM
  • Hi there,

    We've also been fighting with this error. We do have the URL to be https://pod51011.outlook.com/ews/exchange.asmx, and it still gives that 401 error.  If we change things to be POP3/SMTP, it works fine (but then we have to create a profile for each email address, which is a pain).

    This was working for about a week and then it broke this past weekend out of the blue....

    Any thoughts?


    Thursday, April 12, 2012 12:43 AM
  • Are you on the same Exchange Pod?  If you go into OWA, and then settings. Take a look at your pop server settings. Is it pod51011.outlook.com?
    Saturday, April 14, 2012 10:27 PM
  • I'm having the same problem - we migrated to Office 365 yesterday and the CRM router worked fine until 7PM last night then suddenly stopped (with HTTP 401 errors) and I haven't been able to get it working since. I recreated the incoming and outgoing profiles and rebooted the CRM server but this hasn't helped. I tried accessing the exchange.asmx service using IE and strangely this works fine.  A few hours before everything stopped this error was logged in the Application log (which may or may not be relevant):

    System.Web.Services.Protocols.SoapException: Exchange Web Services are not currently available for this request because none of the Client Access Servers in the destination site could process the request.

    I've checked our pod number and this hasn't changed so think we can rule this out.

    In the meantime I'll have to switch to using SMTP / POP3 but would prefer to use the EWS if at all possible so any assistance in getting this fixed would be much appreciated.

    Tuesday, May 1, 2012 5:25 PM
  • I was running into the same issue here and went down the path of configuring the power shell and updating the permissions on the mailbox along with everything else. I eventually got it working after installing and configured RU 8 for the email router.. hope this helps!
    • Proposed as answer by Mark XRE Thursday, June 28, 2012 1:30 PM
    Thursday, June 28, 2012 1:05 PM
  • Hi,

    You need to have Updated Rollup of 8 and above which would resolve ur issue and please follow belo forum to knw much abt it


    Thursday, December 20, 2012 10:21 AM