none
Change Product Key button does nothing RRS feed

  • Question

  • Please tell me how to change the product key when the Change Product Key button does nothing and does not respond.

    My Windows 7 was shown as Genuine before a Windows 7 update on 3-4-2017, but after I did the required update computer restart there is now the bottom right desktop message THIS COPY OF WINDOWS IS NOT GENUINE.

    Please advise me as to how to enter my valid product key, and make my Windows 7 valid.

    I can get to C:\Windows\system32\cmd.exe , but please tell me exactly what do I enter after the C:\Users\user> message.

    Sunday, March 5, 2017 11:07 PM

Answers

All replies

  • 1. Click on start and type command (cmd) with run as administrator option or check how to open elevated command prompt

    2. Now type following command

    “slmgr.vbs -ipk <insert your new product key here>”

    3. To activate windows after changing the key, run “slmgr.vbs -ato”


    Carey Frisch

    Monday, March 6, 2017 6:24 AM
    Moderator
  • I went to the administration mode by accessories - command prompt - then run as administrator

    Then when I entered the command in 2 above of slmgr.vbs -ipk < I received the following error message

    The syntax of the command in incorrect.

    Are there any required spaces such as between the s and -, and are there required spaces between each five characters of the product code ?

    Please advise me what the syntax problem is.

    Monday, March 6, 2017 8:12 PM
  • I was able to g et the Windows Script Host to display and it states under a list of Global Options the following:

    /ipk<Product Key>

    I tried it, and I got the same error syntax message again as before:

    The syntax of the command in incorrect.

    I did not enter any spaces between each five characters of the product code.

    Please advise me what this syntax problem is.

    Monday, March 6, 2017 8:24 PM
  • I am able to confirm that I am in the administrator, mode by Control Panel - User accounts

    But the change product key ( Control Panel Home - view basic information about your computer ) still does not work and does not respond

    I watched a month ago a computer technician change the product key, to fix this same problem before.

    He changed one setting before pressing the change product key button.  I don't know what setting he changed.

    I have to pay the technician again if I want his help again.

    Monday, March 6, 2017 8:48 PM
  • I got it to work.

    The < > characters that I typed in before was the problem, also spaces in the product are OK.

    Thank You

    Monday, March 6, 2017 10:01 PM
  • It is amazing to me that Windows Server 2016 also has this issue. Clicking on "Change Product Key" does nothing from the Settings screen. There isn't even an event log.  Nothing.

    It seems that a lot of the newer "Windows 10/2016" interfaces via CTRL-I still have a lot of bugs after three years now. Being a SPLA partner, I feel that if you won't even let me easily activate a system, that someone there is not doing their job.


    But thank you Carey, I upvoted your answer. slmgr.vbs -ipk is the only thing that worked.
    • Edited by Brain2000 Thursday, January 10, 2019 4:54 PM
    Thursday, January 10, 2019 4:52 PM
  • I completely agree. It is a bit unnerving to see how "un-clean" these new versions of Windows Server OS are - lots of weird glitches in its GUI here and there.

    I have had others respond on issues like this with "just use the command line like a 'real' admin", whatever that is supposed to mean.

    If Microsoft actually wants to get rid of the GUI, it would seem that a better approach would be to take these options out of the GUI instead of making mistakes, then leaving them broken, which creates what seems to be a bit of a mess and a poorly designed system.

    Frustrating. Maybe someday MS will start listening and cleaning up.

    Tuesday, June 4, 2019 5:12 PM