none
The "Unable to Service Request" is getting annoying on MSDN Library!! RRS feed

  • Question

  • Okay this all started two weeks ago.  I am looking up development docs in MSDN Library online like I do everyday, and then after using it fine for hours I get a "Unable to Service Request" error page on everything under MSDN Library tab.  Logging in or out doesn't fix it.  I tried clearing my cache, and nothing. Next I cleared out my cooks for just the last hour (shortest period I can do in Chrome) and that fixes it.  It seems MSDN is relying on a cookie as to determin if it can allow me to view a page or something.

    So I just figured maybe just a one time issue and moved on. Then after a few more days of using MSDN library in Chrome it does it again.  So this time I left it alone and switch to Firefox 6 and its working fine and then after a couple days of using it on MSDN Library it has the same issue. 

    So I try to go to the MSDN forums and I get "Sorry, we were unable to service your request. Please try again later." So I try in the still not working on MSDN Library Chrome and it gets the same thing. So the issue iss Library and Forums now.

    There seems to be an issue with MSDN Library and Forums Firefox 6 and latest Chrome, I am currently using IE9 and I would supect after a couple days it would develop the same issue.

    This is getting crazy, there should be no COOKIE that MSDN requires be on my system to allow me to simply view the MSDN Library documentation. I shouldn't have to delete my cookies for the last hour when this occurs.

    Now I only remove all Microsoft cookies and the problem goes away for a few days. Please Fix!

    Wednesday, September 14, 2011 4:57 PM

Answers

  • That link is for FORUM bugs which applies I guess since it impacts the forums, but it was bigger than that and impacts MSDN Library as well so it didn't seem like the right place to report it there, since you have maybe we can just link back to this thread from yours.

    To delete only Microsoft cookies:

    Latest Chrome (14?):

    1. Click Options Icon (Wrench)
    2. Select Under the Hood on the left Options pane
    3. Click Content settings button under Privacy
    4. Click All cookies and site data  button under Cookies
    5. In the search box type "microosft"
    6. After results return click the Remove All button

    Firefox 6:

    1. Click Firefox -> Options -> Options
    2. Select Privacy Tab
    3. Click the "remove individual cookies" link in middle of History group
    4. In the search box type "microosft"
    5. Select all the results
    6. Click Remove Cookies button

    IE9:

    This is a little more complex and not as fool proof. There may be an addon to make this easier.

    1. Open IE9 and go to microsoft.com
    2. Hit the F12 key to open the developer tools
    3. Select Cache -> Clear cookies for domain
    4. Leaving the developer tool window open and go to msdn.microsoft.com and repeat steps 3
    5. You may need to repeat for social.msdn.microsoft.com as well for forums

    You can test the level you need to do this on IE9 as I don't use IE9 unless I am forced into it.  I am sure there is an addon to make this easy. 

     

    • Marked as answer by Rodney Foley Wednesday, September 14, 2011 9:40 PM
    Wednesday, September 14, 2011 6:30 PM

All replies

  • I was getting a similar problem recently (in the forums). The problem cured itself for me for now, hopefully for good. I did clear all cache in IE and GC and also tried using FireFox.
    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Wednesday, September 14, 2011 5:02 PM
    Moderator
  • While that is a workaround, and I did do a full history purge once. It still comes back and I have narrowed it down to one or more of the microsoft cookies they plop down.  Since it has come back 3 times after each work around, and now I just delete only Microsoft cookies each time.  

    I really wish there was a way to officially report bugs about their websites to Microsoft so that it would hopefully be more visible than a forum post.

    Wednesday, September 14, 2011 5:53 PM
  • This is the forum to report bugs

    http://social.msdn.microsoft.com/Forums/en-US/reportabug/threads

    I hope your thread will be moved there. You can also find my recent thread on that same topic there.

    BTW, since I always forget the steps - can you explain how to delete only MS cookies?

    Thanks.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog

    Wednesday, September 14, 2011 6:03 PM
    Moderator
  • That link is for FORUM bugs which applies I guess since it impacts the forums, but it was bigger than that and impacts MSDN Library as well so it didn't seem like the right place to report it there, since you have maybe we can just link back to this thread from yours.

    To delete only Microsoft cookies:

    Latest Chrome (14?):

    1. Click Options Icon (Wrench)
    2. Select Under the Hood on the left Options pane
    3. Click Content settings button under Privacy
    4. Click All cookies and site data  button under Cookies
    5. In the search box type "microosft"
    6. After results return click the Remove All button

    Firefox 6:

    1. Click Firefox -> Options -> Options
    2. Select Privacy Tab
    3. Click the "remove individual cookies" link in middle of History group
    4. In the search box type "microosft"
    5. Select all the results
    6. Click Remove Cookies button

    IE9:

    This is a little more complex and not as fool proof. There may be an addon to make this easier.

    1. Open IE9 and go to microsoft.com
    2. Hit the F12 key to open the developer tools
    3. Select Cache -> Clear cookies for domain
    4. Leaving the developer tool window open and go to msdn.microsoft.com and repeat steps 3
    5. You may need to repeat for social.msdn.microsoft.com as well for forums

    You can test the level you need to do this on IE9 as I don't use IE9 unless I am forced into it.  I am sure there is an addon to make this easy. 

     

    • Marked as answer by Rodney Foley Wednesday, September 14, 2011 9:40 PM
    Wednesday, September 14, 2011 6:30 PM
  • I got the same error using tech net subscriptions. I went to internet options in the control panel, went o browsing history on the general tab, clicked delete, checked all the boxes. Then clicked the advanced tab, clicked the restore and reset buttons. Now i'm back in


    • Edited by LA1 Sunday, October 21, 2012 2:27 PM
    Sunday, October 21, 2012 2:27 PM
  • I use Opera and I encountered this problem today for the first time.  

    I was just trying to access msdn documents.

    I look forward to more annoyance.

    Tuesday, May 5, 2015 4:58 PM