when c states enable in bios,com port detected the receiver buffer overrun at high baudrate in windows 10 RRS feed

  • Question

  • Hi all,

    When i disable the c states in bios , com port were working for high baudrate in windows 10( serial port device has been drived by invox driver)

    When i enable the c states in bios, com port were not working for high baudrate , that time it showing the receive buffer overrun in passmark tool.

    What is the impact when enable the c states which affect the driver were not working in high baudrate for inbox driver?

    how i can fix to resolve the driver to run in high baudrate when we enable the c states in windows 20 by taking the windows sample driver and fix it in driver ?

    Could anyone help on resolving this issue in windows sample driver for serial port ?

    Whether the cpu not able to enter into ACPI c states and how to resolve in driver side?



    Prabhakar Vinayagam

    • Moved by Baron Bi Monday, July 17, 2017 6:09 AM not about development
    Saturday, July 15, 2017 5:26 PM

All replies

  • When i disable the c states in bios

    I have no idea what that is.

    This question is not a C++ language question. As best as I understand, there is no MSDN forum where this this question would be appropriate.

    Sam Hobbs

    Sunday, July 16, 2017 7:19 PM
  • Hi Prabhakar Vinayagam,

    thanks for posting here.

    This forum is about c++ development with Microsoft products. For your case which , I suggest you post on  Driver Development forum to see if there could be help of you. And this case will be moved into off-topic forum.

    Your understanding and cooperation will be grateful.

    Best Regards,

    Sera Yu

    MSDN Community Support<br/> Please remember to click &quot;Mark as Answer&quot; the responses that resolved your issue, and to click &quot;Unmark as Answer&quot; if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact <a href=""></a>.

    Monday, July 17, 2017 2:57 AM