locked
Email Router not Deleting Emails after Processing

    Question

  • Hello,

    We are on CRM 2013 on-premise. We are using the CRM email router to automatically create email activities for every email that arrives in a shared group mailbox. 

    In the Mailbox setting, we set the option to 'Delete Emails after Processing' so that to avoid build-up of emails in Exchange.

    However the emails are never deleted from Exchange, even after I restarted the Email Router service a few times.

    Any idea why the emails are not being deleted?

    Thanks,

    -tri

    Thursday, November 12, 2015 8:20 PM

Answers

  • Hi,

    Yes we have to run a powershell script such as below to send to a forward mailbox with -DeleteMessage function:

    New-InboxRule -name 'ForwardAsAttach' -Mailbox mailbox@test.com -ForwardAsAttachmentTo ForwardMailbox -DeleteMessage $true

    -tri

    • Marked as answer by triangular Monday, January 29, 2018 7:29 PM
    Monday, January 29, 2018 7:29 PM

All replies

  • could be the shardmailboxtype, try it first with a users mailbox and see if this is happening there also

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, November 13, 2015 9:27 AM
  • Thanks Daniel for the reply. Are you saying it's not working on a shared mailbox? 

    -tri

    Friday, November 13, 2015 3:08 PM
  • Actually I just tried on a user-owned mailbox and the emails are still not being deleted from Exchange even though the emails are created in CRM... I'm not seeing any error messages on the CRM Email router server that could be related to this.

    Any suggestions?

    Thanks much.

    -tri


    • Edited by triangular Monday, November 16, 2015 8:09 PM
    Monday, November 16, 2015 8:06 PM
  • really hard to know without any logs

    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Tuesday, November 17, 2015 8:50 AM
  • Hello,

    Thanks all for the reply. We opened a case with MS support. Turned out this feature is not supported for the regular email router. It's only supported if using the server side synchronization, or if using the forward mailbox within the email router queue...

    Now we might still be able to use this feature but will have to modify the email router xml config file, and it's actually unsupported... I'm scratching my head to this answer... 

    Thanks, 

    -tri

    Thursday, November 19, 2015 3:52 AM
  • Hello,

    Thanks all for the reply. We opened a case with MS support. Turned out this feature is not supported for the regular email router. It's only supported if using the server side synchronization, or if using the forward mailbox within the email router queue...

    Now we might still be able to use this feature but will have to modify the email router xml config file, and it's actually unsupported... I'm scratching my head to this answer... 

    Thanks, 

    -tri

    Hi, Can you find a solution for this problem?

    Monday, January 29, 2018 10:45 AM
  • Hi,

    Yes we have to run a powershell script such as below to send to a forward mailbox with -DeleteMessage function:

    New-InboxRule -name 'ForwardAsAttach' -Mailbox mailbox@test.com -ForwardAsAttachmentTo ForwardMailbox -DeleteMessage $true

    -tri

    • Marked as answer by triangular Monday, January 29, 2018 7:29 PM
    Monday, January 29, 2018 7:29 PM