locked
Unable to create users as a System Administrator RRS feed

  • Question

  • Hello,

    I am unable to create a user in CRM 2011 (On premise) I am a System Administrator. I have been able to create users in different organizations but for some reason this one is failing. This is an out of the box environment (no customizations). I tried to create another role from scratch and assigned the same permissions that a system admin will have and no dice.

    The log file indicates that the following privilege is missing “prvCreateUser privilege”. I have verified and I do have access to create user.

    I have switch the System Admin role to other users and I am still unable to create users. I have also tried changing the Access Mode from Full to Administrative under the user that has System Admin but still does not work.

    Is there a table in SQL where I can verify this access?

    BTW, the CRM Server currently has Ru16 installed.

    Cheers,

    Thursday, April 24, 2014 6:48 PM

All replies

  • Sometimes the Antivirus software is said to cause such issues.. http://social.microsoft.com/Forums/en-US/1cc5a738-7088-4055-9417-9cbcc82910bd/unable-to-apply-user-settings-as-administrator?forum=windowssteadystate

    I don't have a database to check the exact object but you would check that in RolePrivileges, UserSettings, SystemUserRoles, UserSettings


    If my response helps you in finding your answer then please click 'Mark as Answer' and 'Vote as Helpful'

    Thursday, April 24, 2014 7:46 PM
  • Hi,

    Many thanks for your reply. I tried that but still experiencing issues. I also checked the database tables and confirmed the username I am using to try to create the accounts does have the privilege "prvCreateUser"

    Cheers,

    Friday, April 25, 2014 12:55 PM
  • This does sound odd, and the message may be misleading. Can you create users in other organisations in the same deployment ?

    If not, the issue could be either with SQL permissions in the MSCRM_Config database, or with permissions in AD, though I would expect either would show a more useful message

    Otherwsie, if it is specific to one organisation in the deployment, you might want to check the permissions on the business units


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Monday, April 28, 2014 9:10 AM
    Moderator