none
Windows Home Server: "Updating port forwarding failed" warning. Told to ignore, but keeps popping up! RRS feed

  • Question

  • Using WHS w/PP3. Periodically, it pops up with a message that the network health is bad, because "Updating port forwarding for your router failed". I got into the WHS console and check the box to "Ignore this issue". A few minutes later, it pops up again to tell me that updating the port forwarding has failed. I check the box again to ignore the issue. The cycle repeats.

    Two questions:

    1. Why is it not ignoring the issue when I tell it to? PP2 used to work fine in this regard, but it seems that since upgrading to PP3, it doesn't ignore the problem when I tell it to. (This is driving me nuts!)

    2. Why am I getting the error to begin with? I can go into the WHS console, Settings, Remote Access screen, and it checks everything and says that remote access is available. (I can access the WHS remotely as well, so I know the ports are all forwarded correctly.) So, there is apparently a bug in the logic that checks to see if the WHS is available - in the Admin console it says it is (which is correct), but the periodic check says it isn't (which is incorrect).

    Thanks,
    Karl Cepull
    President
    K-Squared Computing, LLC
    Thursday, January 14, 2010 11:27 PM

All replies

  • If you're using UPnP to configure port forwarding, it's possible that your server isn't getting the response it expects from your router during the port forwarding test.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by Jonas Svensson -FST- Tuesday, February 9, 2010 12:54 AM
    • Unmarked as answer by Karl C_ Tuesday, February 9, 2010 3:13 AM
    Friday, January 15, 2010 1:38 AM
    Moderator
  • Thanks, Ken. I have manually configured my router to allow the ports through. There used to be a way to tell WHS that I had "manually configured" my router, and it wouldn't keep trying to test it. With PP3, it appears this has all changed. So, I can't tell it to not try to test it, and when it does, it isn't sensing that it actually works, AND I can't tell it to ignore the "problem"! 

    Thanks anyway, though!  :-)
    Friday, January 15, 2010 2:48 AM
  • Thanks, Ken. I have manually configured my router to allow the ports through. There used to be a way to tell WHS that I had "manually configured" my router, and it wouldn't keep trying to test it. With PP3, it appears this has all changed. So, I can't tell it to not try to test it, and when it does, it isn't sensing that it actually works, AND I can't tell it to ignore the "problem"! 

    Thanks anyway, though!  :-)
    You could try temporarily disabling Remote Access in the Console (reboot the server for good measure), then login to your router and disable uPnP on it and manually configure the ports, then re-enable Remote Access in the Console again.  (My router is manually configured, has been since RTM, and I've never once had that pop-up.)
    • Marked as answer by Jonas Svensson -FST- Tuesday, February 9, 2010 12:54 AM
    • Unmarked as answer by Karl C_ Tuesday, February 9, 2010 3:13 AM
    Saturday, January 16, 2010 1:56 AM
    Moderator
  • Thanks, kariya21. I've tried disabling Remote Access, then re-enabling it. Remote Access works, but I still get the "warnings". My router does not support UPnP, so I have no way to turn it off (or on).

    I really am not concerned that it can't sense that things are OK - since things work, I don't care what WHS thinks. My real issue is why it won't "ignore the issue" when I tell it to! This ends up being a "cry wolf" problem, as the only way to get the popups to go away is to turn off "Display Network Health Warnings", but then I won't get warnings that truly are important. How can I get it to stop warning me?

    Thanks,
    Karl
    Saturday, January 16, 2010 5:37 PM
  • I had the same problem for several weeks.  My Linksys router does not support upnp, so I also manually configured the ports.  Then I set up my IP addresses as static, rebooted the server and I haven't seen the problem since.
    Tuesday, January 26, 2010 10:40 PM
  • Still looking for an answer. I am an MS Partner, and have WHS via the MAPS program. My understanding was support (via this forum) was included with the MAPS software, but I am not seeing any real answers here. Am I asking in the wrong place? This is how I understood we were supposed to get support....?!
    Tuesday, February 9, 2010 3:15 AM
  • What settings have you made on your router?  Who is your ISP and what Router do you have? This is a public forum so if it was touted as some premium paid support service I would get your money back.
    --
    Tuesday, February 9, 2010 10:32 AM
  • Allow Ping test on WAN in your Router. Solved my Port Forwarding problem.
    Sunday, December 30, 2012 5:13 PM