locked
Disable the Communicator Autostart feature RRS feed

  • Question

  • We are running the most current version of Office Communicator 2.0.6362.76.  My problem is that not all of our users are enabled for OCS.  Office Communicator is part of our enterprise load so every workstation has it installed.  I would like to prevent Communicator from auto starting when the user logs in.  Otherwise Communicator tries to connect even without an enabled account.

     

    Thanks for your help

     

    Jeff

    Monday, September 8, 2008 3:10 PM

All replies

  • In the OC client go to Tools > Options > Personal.  The top section has a setting for "Automatically start Communicator when I log on to Windows" that should be disabled for those users.

     

    The registry setting that controls this client behavior is:

     

    Code Snippet

    HKCU\Software\Microsoft\Communicator\AutoRunWhenLogonToWindows

    Disabled = 0

    Enabled = 1

     

     

    Monday, September 8, 2008 4:58 PM
    Moderator
  • The solution that Jeff Schertz works on a per user basis. Does anyone know of a solution that can be done that will apply to all users that will login to the machine. We need to deploy Communicator within our company with the latest patch and MUI pack but when the install is done Communicator Auto Starts in every profile that logs on. We want to suppress this and let the users decide if they want Communicator to AutoStart. Any help would be appreciated.
    Thursday, April 9, 2009 6:58 PM
  • You can use the registry key I included to configure this in bulk for users, either via a custom GPO setting (this is not a policy setting but would be a 'tattoed' registry setting) or a thrid-party deployment tool, like Altiris.  In the simplest form you could include a .reg file to be run on each workstation you plan to deploy the client with in the first place.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Thursday, April 9, 2009 7:50 PM
    Moderator
  • I know this is an old thread, but I was needing to accomplish roughly the same thing and figured out the missing piece so I wanted to add it for future readers who find this through a search engine :-)

    In my case the situation was an app mode terminal server that we didn't want Communicator autostarting on. As stated, Jeff's proposed solution of creating a custom GPO to stamp HKCU works for existing users but not users signing in for the first time (new profile creation). What I did to handle the latter is to load the Default User registry hive and add the Communicator\AutoRunWhenLogonToWindows key and value (I had to create the Communicator key, then create the DWORD value in it). The result of that change is that all new user profiles that get created on first login inherit this setting from the Default User profile and Communicator does not autostart. The procedure to do this for XP/2003 is below, I have not tested on Vista/2008/Win7. Keep in mind that despite the name, HKEY_USERS\.DEFAULT is *not* the Default User profile, it's actually the LocalSystem profile. That's why you have to do the following.

    1. Open regedit
    2. Highlight HKEY_USERS
    3. Click File > load hive
    4. Navigate to your '\documents and settings\default user' and select the ntuser.dat file
    5. The key name you are prompted for is just descriptive, it'll be what the hive loads under HKEY_USERS as for display purposes and has no bearing on what you're actually doing. I just put in 'mydefault' but it really doesn't matter, just give it a name so you'll recognize the hive once it is mounted.
    6. Expand your mounted hive under HKEY_USERS, then expand Software\Microsoft.  Create a new key named 'Communicator'
    7. In your new Communicator key, create a DWORD value named 'AutoRunWhenLogonToWindows' and leave it with the default value of 0.
    8. Highlight the root key of your mounted hive ('mydefault' or whatever you called it), then click File > unmount hive and confirm.

    I tested by deleting my own user profile off the system while logged in as the admin account (System Properties > Advanced tab > User Profiles settings), then logging back in as myself and letting the new profile get created and confirming that Communicator did not start (and also that it could still be started manually).
    Friday, October 2, 2009 3:56 PM
  • Nice explanartion, Will!

    1) Of course it would be nice to correct the underlying problem, that communicator should not start anything at all, and not look for registry entries, until the user clicks on it.  The correct way to autostart is to add a shortcut to the Start folder, which the user can easily delete.  The slight-of-hand infestation with an unrequested startup is problematic at best, and a violation of my computer security at worst.

    2) I tried to script the fix, so I can easily clean all my family's computers.  The script must be run as administrator. I just CANNOT get it to work on Windows 7.

    PS admin> set-executionpolicy remotesigned

    PS admin> notepad $home\ps1\fixcommunicator.ps1

    # fixcommunicator.ps1
    # &"$home\ps1\fixcommunicator"
    "Fixing communicator autostart"
    "This program must run as admin"
    $l = ls 'registry::hkey_users'
    foreach ($u in $l)
    {
         $p = "registry::$u\software\microsoft\communicator"
         if (!(test-path $p))
         {
              "creating communicator folder $p"
              $null = md $p
         }
         if ((gp $p).autorunwhenlogontowindows -ne 0)
         {
              "setting communicator option $p"
              sp $p autorunwhenlogontowindows 0
         }
    }
    "Done"

    PS admin> $home\ps1\fixcommunicator"
    Fixing communicator autostart
    This program must run as admin
    ...
    Done


    Thanks

    /Uffe

    Saturday, October 31, 2009 7:24 AM