locked
CRM 2011 Email router - the token provider can not get tokens for target RRS feed

  • Question

  • Hi all,

    I am trying to configure CRM Email router in my CRM 2011 beta virtual machine (onpremise). When I click Load Data to get CRM users and queues, I get an unexpected error: Email router is not able to retrieve users and queues from CRM. Verify that the url http://127.0.0.1/companysample  is correct. This problem can occurs if specified acccess credentials are issuficient (the token provider can not get tokens for target).

    This is the configuration I am using for Deployments tab:

    My company:

    Address: http://127.0.0.1/companysample

    Access Credential: Other specified

    User name/Password: administrator ones.

    Thanks in advance  

    Friday, April 8, 2011 4:44 PM

Answers

  • Thanks for the help!

    The problem was finally solved. The problem came with the administrator account provider. It was not properly specified on Deployments tab (the active directory part was not properly written). Changing that, the problem was solved.

    Sunday, May 15, 2011 4:28 PM

All replies

  • Does providing the machine name instead of the IP help? Are both router and CRM on the same machine?

    Could you verify that you can navigate to the following URLS from the browser on the email router machine?
     - http://127.0.0.1/companysample
     - http://127.0.0.1/XRMServices/2011/Discovery.svc
     - http://127.0.0.1/companysample/XRMServices/2011/Organization.svc


    Do you have both HTTP and HTTPS binding enabled on the CRM Website? If so, you will have to dis able one of them.

    Also, enable logging in email router to get a full stack trace. Publish the email router settings and wait for the log to show up.
    - In the Service folder of Email router installation, locate the file Microsoft.Crm.Tools.EmailAgent.xml.
     - There is a key for Log Level - <LogLevel></LogLevel> This is by default set to 1. Please set it to 3.
     - Add a key for Log file below this key. <LogFile>C:\Log.txt</LogFile> Mention the desired log file path and name.
     - Restart the Email router service.

    Sunday, May 15, 2011 2:17 PM
  • Thanks for the help!

    The problem was finally solved. The problem came with the administrator account provider. It was not properly specified on Deployments tab (the active directory part was not properly written). Changing that, the problem was solved.

    Sunday, May 15, 2011 4:28 PM