locked
Cannot install Sync Framework V2.0 CTP1 RRS feed

  • Question

  • Hi, I've downloaded Sync Framework V2.0 CTP1 but get an error when I install.

    Once I've unzipped the package, I see the executable "SyncSetup.exe", and four folders (Sync Framework, Sync Framework SDK, Sync Framework Services, and Sync Services for ADO) each containing a msi file.  I double clicked on "SyncSetup.exe" and accepted all EULA, then the installation seems to start, but then it stops right away with the following error message:

    Component Microsoft Sync Framework Runtime v2.0 has failed to install with the following error message:
    "A fatal error occurred during the installation of Microsoft Sync Framework Runtime v2.0."

    The following components were not installed:
    - Microsoft Sync Services for ADO.NET v3.0
    - Microsoft Sync Framework Services v2.0

    The following components failed to install:
    - Microsoft Sync Framework Runtime v2.0


    When I run individual .msi files (e.g. ProviderServices.msi), I get the error:
     
    This installation package is not supported by this processor type. Contact your product vendor.

    I had Version 1 of SyncFramework installed and I have already uninstalled all the componenets, and restarted my machine, but that doesn't resolve the problem.

    My system info:

    Windows XP Professional Version 2002 Service Pack 3.

    Thank you.

    Wednesday, March 25, 2009 4:25 PM

Answers