locked
Windows update not working: invalid PID? RRS feed

  • Question

  • I have a new Vista Ultimate computer from Gateway which I just received on 3/29/07. I have had trouble with Windows update not working. If I elect to look only for updates for Windows, it works fine, but when I switch it to Microsoft update, no updates show at all. The window says that no updates are available for any product. When I change the setting back to Windows Updates only, once again the available updates (such as Ultimate Extras) appear. Naturally, I am concerned about missing critical updates for Office and Visual Studio. Scanning through the very long WindowsUpdate.log file, I noted the phrase "invalid PID" in a number of places. So I ran the MGA diagnostic tool and got the following results. Can you help, please?

     

    sig

     

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Validation Control not Installed
    Detailed Status: 0x1
    Windows Product Key: *****-*****-X9PJQ-PYF36-G8WGV
    Windows Product Key Hash: 3HCMZpnmIjPGHPPrR3Wncy9wTZ0=
    Windows Product ID: 89580-OEM-7332132-00125
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6000.2.00010100.0.0.001
    ID: 32c28da4-1ce4-4b12-a95d-5c0afbb342ff
    Is Admin: No
    AutoDial: Yes
    Registry: 0x0
    WGA Version: Failed to retrieve file version. - 0x80070006
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Ultimate
    Architecture: 0x00000000
    Build lab: 6000.vista_rtm.061101-2205
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: N/A
    File Exists: No
    Version: N/A
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    OGA Version: Failed to retrieve file version. - 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-3178-80070002_025D1FF3-138-80041010_025D1FF3-324-80040154_025D1FF3-269-80040154_025D1FF3-273-80070002_672A8F41-307-80004005_672A8F41-349-80004005_672A8F41-244-80004005

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>32c28da4-1ce4-4b12-a95d-5c0afbb342ff</UGUID><Version>1.7.0012.0</Version><OS>6.0.6000.2.00010100.0.0.001</OS><PKey>*****-*****-*****-*****-G8WGV</PKey><PID>89580-OEM-7332132-00125</PID><PIDType>2</PIDType><SID>S-1-5-21-3044710105-750406646-3523738665</SID><SYSTEM><Manufacturer>Gateway</Manufacturer><Model>E6610</Model></SYSTEM><BIOS><Manufacturer>Intel Corp.</Manufacturer><Version>LA97510J.15A.0258.2007.0116.1420</Version><SMBIOSVersion major="2" minor="3"/><Date>20070116000000.000000+000</Date></BIOS><HWID>E5313507018400FA</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Central Standard Time(GMT-06:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>GATEWA</OEMID><OEMTableID>SYSTEM  </OEMTableID></OEM></MachineData>   <Software><Office><Result>100</Result><Products><Product GUID="{91120000-0014-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Professional 2007</Name><Ver>12</Ver><Val>2DFB566E26AD70A</Val><Hash>hHxm/f3KRZAUAZK+6bpVO6jGPWE=</Hash><Pid>81605-901-9074332-65625</Pid><PidType>1</PidType></Product></Products></Office></Software></GenuineResults> 

     

    Monday, April 2, 2007 11:50 PM

Answers

  • I don't want to give you bad information, and unfortunately because this forum is dedicated to validation issues we've reached the end of the expertise I have available to me.  Please contact  Product Support Services for further help.  Thank you!
    Tuesday, April 3, 2007 6:42 PM

All replies

  • Hello,

     

    Please click "Validate Windows" here: www.microsoft.com/genuine and follow the steps for activation; then try MS update.  Let me know if that solves your issue.  Thanks!

    Tuesday, April 3, 2007 12:38 AM
  • Thanks for your response. I went to the validation site and apparently have successfully validated Windows. I ran the validation tool again and the report is below. However, Microsoft Update still does not work. When I activate Microsoft Update, the window shows that no updates of any sort are available. When I revert back to plain old Windows Update, the available optional updates are displayed.

    So, no luck so far. What should I try next?

     

    I don't know if this is relevant, because I am not sure how OEM licences work, but the last 15 digits indicated in the Windows Product Key below do not match the Windows Product Key on the certificate on the back of my computer.

     

    sig

     

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: 0x1
    Windows Product Key: *****-*****-X9PJQ-PYF36-G8WGV
    Windows Product Key Hash: 3HCMZpnmIjPGHPPrR3Wncy9wTZ0=
    Windows Product ID: 89580-OEM-7332132-00125
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.0.6000.2.00010100.0.0.001
    ID: 32c28da4-1ce4-4b12-a95d-5c0afbb342ff
    Is Admin: No
    AutoDial: Yes
    Registry: 0x0
    WGA Version: Registered, 1.5.723.1
    Signed By: Microsoft
    Product Name: Windows Vista (TM) Ultimate
    Architecture: 0x00000000
    Build lab: 6000.vista_rtm.061101-2205
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: N/A
    File Exists: No
    Version: N/A
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    OGA Version: Failed to retrieve file version. - 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-3178-80070002_025D1FF3-138-80041010_025D1FF3-324-80040154_025D1FF3-269-80040154_025D1FF3-273-80070002_672A8F41-307-80004005_672A8F41-349-80004005_672A8F41-244-80004005

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>32c28da4-1ce4-4b12-a95d-5c0afbb342ff</UGUID><Version>1.7.0012.0</Version><OS>6.0.6000.2.00010100.0.0.001</OS><PKey>*****-*****-*****-*****-G8WGV</PKey><PID>89580-OEM-7332132-00125</PID><PIDType>2</PIDType><SID>S-1-5-21-3044710105-750406646-3523738665</SID><SYSTEM><Manufacturer>Gateway</Manufacturer><Model>E6610</Model></SYSTEM><BIOS><Manufacturer>Intel Corp.</Manufacturer><Version>LA97510J.15A.0258.2007.0116.1420</Version><SMBIOSVersion major="2" minor="3"/><Date>20070116000000.000000+000</Date></BIOS><HWID>E5313507018400FA</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Central Standard Time(GMT-06:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>GATEWA</OEMID><OEMTableID>SYSTEM  </OEMTableID></OEM></MachineData>   <Software><Office><Result>100</Result><Products><Product GUID="{91120000-0014-0000-0000-0000000FF1CE}"><LegitResult>100</LegitResult><Name>Microsoft Office Professional 2007</Name><Ver>12</Ver><Val>2DFB566E26AD70A</Val><Hash>hHxm/f3KRZAUAZK+6bpVO6jGPWE=</Hash><Pid>81605-901-9074332-65625</Pid><PidType>1</PidType></Product></Products></Office></Software></GenuineResults> 

     

    Tuesday, April 3, 2007 2:31 PM
  • I'd like to follow up on my previous reply to your post, as I have found more information that may help in tracking down the problem. I opened the WindowsUpdate.log file to look for any error messages. When I tried to use Microsoft Update after following the instructions in your post, the following was logged:

     

    2007-04-03  09:19:32:337      1120  1280  Report      REPORT EVENT: {7C567E4D-CFC8-44E0-A32C-9744E4CE9DB7}     2007-04-03 09:19:27:337-0500  1     147   101   {00000000-0000-0000-0000-000000000000}     0     0     AutomaticUpdates  Success     Software Synchronization      Windows Update Client successfully detected 0 updates.

    2007-04-03  09:19:32:337      1120  1280  Report      REPORT EVENT: {39600869-F67A-438E-B8D2-BF8F5DC1A4E3}     2007-04-03 09:19:27:337-0500  1     154   101   {00000000-0000-0000-0000-000000000000}     0     0     AutomaticUpdates  Failure     Software Synchronization      Client has an invalid Pid.

     

    Note the phrase Client has an invalid Pid.

     

    However, when I reverted to Windows Update, there were no error messages, and instead the log file indicated that 19 updates were located.

     

    If it is relevant, I have validated and registered my copy of Office 2007.

     

    sig

    Tuesday, April 3, 2007 2:45 PM
  • I don't want to give you bad information, and unfortunately because this forum is dedicated to validation issues we've reached the end of the expertise I have available to me.  Please contact  Product Support Services for further help.  Thank you!
    Tuesday, April 3, 2007 6:42 PM