locked
Web Component Cannot login-in RRS feed

  • Question

  • Hello,

    I have deployed OCS 2007 in my lab test (internaly IM, video and audio work perfectly).

    I have now deployed the "Web Component" (on the same server as OCS 2007 and IIS).

    With the configuration Wizard i have configured two virtual WC (one for internal on the port 448 and one on the port 449 for external)

    I have configured the correct Certificate (that match with the FQDN of the IIS server...)

    I have run the Validation tool for the web component with 0 error.

    when i open a web browser and I go on (internaly) "https://fqdn.mydomain.com:448" i have a a http error 401 (unautorized...)

    if i go on "https://fqdn.mydomain.com:448/cwa/client/0.0.0000.0000/Mainframe.htm the Office Communicator Web is started and ask me to enter my login (i enter my OC login  xx@mydomain.com... and pwd) but i can't loginIn) there are no error but

    He continuously asked me my login..


    Where is the probleme? WHat I do check ?

    Regards,
    Albert Smoz



    Friday, November 14, 2008 7:44 AM

All replies

  • How is your IIS authentication configured for the internal site

    Did you choose Integrated authentication?

    Friday, November 14, 2008 9:33 PM
  • i have choose intergrated AND with Forms
    Friday, November 14, 2008 9:41 PM
  • You mean :

    Windows Authentication for the internal site

    And Forms based authtentication for the external site

     

     

    Friday, November 14, 2008 9:48 PM
  • for the the internal:
    Windows Authentication (NTLM/Kerberos) And with forms

    for external (but i don't use external now...)
    Only Forms
    Friday, November 14, 2008 9:53 PM
  • Did you add the CWA url in your Local Intranet site in Internet Explorer settings?

    Otherwise it will not do the automatic logon

     

    Friday, November 14, 2008 10:00 PM
  • No I didn't. ( i added now https://fqdn.mydomain.com)

    and now when i go on https://fqdn.mydomain.com:444/cwa/client/0.0.0000.0000/MainFrame.htm
    he do no ask me a login input he load a moment and go on "disconnected" and if i try to click on "login" button et redirect me on https://prod1.exchange.com:444/ (and here i have a http 401 error..)


    Thank's for your help. Smile
    Friday, November 14, 2008 10:07 PM
  •  

    You might need to add https://fqdn.mydomain.com:444

    And you should go to https://fqdn.mydomain.com:444 directly and not to CWA/...

     

     

    Friday, November 14, 2008 10:16 PM
  • Yep, i have added https://fqdn.mydomain.com:444 (but when i click "Add" in the list it appear https://fqdn.mydomain.com)

    And yep in the planning and deploying web Access guide the url is https://fqdn.mydomain.com:444, but it don't work by me .. Tongue Tied

    So the problem is why i have the http 401.2 error ?

    I have fund this MS ticket
    http://support.microsoft.com/kb/871179/en-us

    It can be this ?


    Friday, November 14, 2008 10:26 PM
  • Can you check if you have configured an MTLS Certificate for your CWA Server

    Go to the node that displays your CWA FQDN server and check if there is a certificate present

     

    Friday, November 14, 2008 11:18 PM
  • Yep ther is a certificate
    the certificate i have installed for cwa server is:

    delivred for: fqdn.exchange.com
    delivred by: myCA

    role : Server authentification

    Friday, November 14, 2008 11:37 PM
  • It should have a checkmark (Green) if you look on the right side

    Maybe you have changed Authentication settings on IIS? No authentication should be selected in IIS

     

    Try to use your external website and check wether you can login explicitely from there

    Friday, November 14, 2008 11:47 PM
  • It should have a checkmark (Green) if you look on the right side

    Yes there is

    Maybe you have changed Authentication settings on IIS? No authentication should be selected in IIS
    No auth. is actived in IIS

    Try to use your external website and check wether you can login explicitely from there

    same probleme http eror 401.2

    Saturday, November 15, 2008 12:02 AM
  • Nobody had the same problem ??
    Tuesday, November 18, 2008 8:21 AM