locked
Somebody PLEASE HELP ME. RRS feed

  • Question

  • Hello,

    I have a really weird, frustrating yet intereting problem.

    MY SET UP

    A BT Home Hub 2 in the hall with two ethernet wired connections. First one to a brand new Netgear 5 port switch upstairs. The other to a brand new Netgear 8 port switch downstairs.

    Upstairs, attached to the switch, is a brand new HP X510 WHS, and a laptop, both CAT 6 wired.

    Downstairs, attached to the other swittch is a Panasonic TV (with media receiving capabilities) and a PS3, both CAT 6 wired. I also have a wireless Pure Evoke Internet radio with Media receiving capabilities. I also have another laptop belonging to my wife.

    MY CONFIGURATION

    I have left all equipment as default (to auto detect and use DHCP) but have reserved the IP address for the TV and WHS (within the DHCP range) using the router software. My BT Home Hub is set to use UPNP and I think that virtually everything else is default. I have opened 5 ports on the router and forwarded them to the WHS. The 5 ports are: 80, 443, 4125, 9000 (Twonky) and 9999 (firefly).

    I use iTunes on my main laptop upstairs as the "master music machine" and then use the HP collector tool on the WHS to collect the music from the master laptop and place the music in the shared music folder on the WHS.

    I have enabled Twonky on the WHS and also set the iTunes part up so that my wife can use her laptop with iTunes to find the shared library.

    WHAT WORKS

    Upstairs - the laptop upstairs behaves normally and finds all I have thrown at it. The WHS appears to be working normally other than it shuts down at midnight for no reason!! This is despite me setting it to sleep at 00:30

    Downstairs - the PS3 works absoutely fine, as does the wireless radio. My wife's laptop also works fine in wireless mode and successfully finds the iTunes library.

    THE PROBLEM

    This is the weird part.

    Firstly - My TV simply will NOT find Twonky media player unless I turn on the PS3 which is connected to the same switch!!! Sometimes I have can turn on the PS3 and then the second I turn it off (after a while) the TV decides to find Twonky! Once the TV finds Twonky it will keep it for several minutes before losing it again.

    Secondly - my wife's laptop will NOT pick up the iTunes library share when connected to the downstairs switching off wireless and using ethernet.

    WHAT HAVE I ELIMINATED AS THE PROBLEM

    I have removed BOTH switches such that I only have TV---ROUTER---WHS. Still doesn't work so can't be a switch problem

    I have connected TV to upstairs switch and TV finds Twonky immediately. So problem doesn't appear to be TV.

    I have switched off firewall in WHS and Router tempararilly and TV still can't find Twonky unless I switch on the PS3. So I don't think it's a firewall issue.

    I have turned on and off UPNP and also DMZ'd my TV, WHS etc.

    I have attempted to give my TV and WHS a static IP address. This made no difference except that we lost internet connectivity. I think I used the routers 192.168.1.254 address in the WHS DNS setting when in actual fact I should have used the DNS settings from the router itself. I kind of gave up at this point.

    A RAY OF LIGHT :-)

    Last night I decided to swap the ethernet cables around on the back of the router. Guess what? The TV actually found Twonky. And then lost it again after a few minutes. I swapped them back and it still wouldn't find twonky until I switched the PS3 on.

    So, from what I can tell, this problem is based around either the router OR WHS denying access to anything downstairs which is linked to my switch via ethernet. Unless, of course, I decide to switch the PS3 on.

    Can someone please help me before I chuck the whole bl**dy lot out of the window. THIS IS DRIVING ME NUTS!

    I have come on here to eliminate the WHS as being the problem but any help with the router config would be greatly appreciated.

    Many thanks in advance.

    Friday, December 11, 2009 1:27 PM

All replies

  • Based on this:
    I have connected TV to upstairs switch and TV finds Twonky immediately. So problem doesn't appear to be TV.
    I believe that your issue is either the downstairs switch or the router. My assumption is that your internal network topology is something like this:
    Internet --- router --- Switch A --- upstairs stuff
    |- Switch B --- downstairs stuff
    When you move the TV from Switch B to Switch A, you take both Switch A and the router out of the equation. Personally, I would start with the router, and beat up British Telecom tech support (politely, of course) until they actually help you.
    I'm not on the WHS team, I just post a lot. :)
    Friday, December 11, 2009 3:01 PM
    Moderator
  • Many thanks for your reply, Ken, you are indeed concurring with my thoughts that it is the router software config at fault. I have taken the Switch B (downstairs) out of the equation by virtue of connecting the TV directly to the router in the hall...and the TV still doesn't work. But the PS3 DOES.

    It's as if the PS3 downstairs can "open" something up all on its own, which the router (or WHS) normally blocks.

    Is it common to have two switches attached to a router?

    Do you know of any other ports which I need to forward to the WHS apart from the ones above? Also (not knowing much about port forwarding) i presume that you only need to forward the ports to the WHS and not the receiving device!?!?!

    Also, I have remote desktop'd onto the WHS to try and configure Twonky, just to check that twonky config is ok. I can't even find the twonky software under prog files???

    Cheers
    Friday, December 11, 2009 3:45 PM
  • Yes, it's common to attach a switch to a router.

    The only ports you need to worry about are 80, 443, and 4125, and even then only if you're using the Remote Access web site.

    Twonky is software added by HP; it's not part of the base Microsoft product. But in general you shouldn't have to change anything in a remote desktop session.


    I'm not on the WHS team, I just post a lot. :)
    Friday, December 11, 2009 4:22 PM
    Moderator
  • Morning crispy,

    I would agree with Ken, I bet that the issue lies with your BT home hub. i looked up the device for a general over view and my thought is that for some reason the home hub is segmenting its Ethernet ports. there are many classes of net work devices, router, switch, hubs, ect. so as to try to not us generals here i will try to be specific.

    a network is collection of computer systems linked together.
    the internet is one big series of networks.
    a router allows networks to talk to each other.
    a switch controls the data traffic so that the data will head to a right computer with out going everywhere first.
    a hub will send all the data traffic everywhere.

    so your BT home Hub though named as such is not a hub its a router. it joins the internet to your home network.
    the LAN ports on the back for most routers act like a switch.
    info comes in the WAN port (the internet) and is directed out a spefic LAN port because it knows where to find the devices on your network.
    hooking a switch up to a LAN port is totally fine and it expands the one LAN port into, well however many ports are on the switch.

    here is the thing you need to be aware of. not all switch ports are made equal. if you look on the device or the documentation for the switch, they should mention a uplink port, or describe a uplink capability. it is very important that the cable coming from your router gets plugged into the uplink port on your switches. also it might require a type of cable called a crossover cable. now in modern networking devices this is now rare, as most switches can auto detect and reconfigure if needed. I know its odd and rare but sometimes network cabling just wont work. it may look fine, but it just wont work.

    so down to the WHS part the Mods can correct me if I'm wrong, but WHS, in general wont actually kill, swallow, or destroy network traffic data. you mentioned that the BT hub has UPNP enabled, and you moved ports. i dont know the stability of the device but i would only use one or the other. if you have manually entered forwarding data, and had WHS configure useing UPNP, that could be an issue. BT would need to tell you that.

    in the end you can always get another router and see how that works.

    Friday, December 11, 2009 4:59 PM
  • Ok, thanks for the replies so far - makes me feel better talking to someone :-)

    I've had a look at the switches documentation and it says nothing about uplink ports. It implies that you can stick anything anywhere! Same with the BT Home Hub.

    I am using normal straight wired cable everywhere and I thought that was the right thing to do for my setup.

    I've just done a factory reset on the hub because my wife has complained of not having internet access all day. Basically, I think that me messing with trying to give the WHS a static IP address has screwed something up. She has been getting DNS errors (me too). I have now turned off the WHS and will turn it back on tonight. If I lose internet connectivity again tomorrow then I'll be begging you for help regarding DNS settings on the WHS. I've read conflicting views on what you should enter into the WHS DNS settings when selecting a static ip address. I added the BT Home hub default gateway IP address but I think the hub may act as a proxy, or something, and cause problems - I'm no expert!. So I put the WHS back to Autodetect but may have missed something in the settings. I'll see how it goes tonight.

    Thinking about all of this and to sum it up...it seems that WHS is only providing twonky or iTunes data wirelessly OR to anything directly connected to the switch upstairs. All EXCEPT, that is, for the PS3 which seems to get the data fom the downstairs wired ethernet. So what is the PS3 doing that my TV (or wife's laptop) isn't?

    I've just had another thought...EVERYTHING is gigabit except for the TV and the BT Hub built in switch. Am I barking up the wrong tree here?
    Friday, December 11, 2009 7:18 PM
  • I think your issue may be caused by a problem with port speed and duplex auto negotiation. What you can try is connect the upstairs switch straight to the downstairs switch (or the other way round). Alternatively you can try and set the NIC's on all Gigabit devices to a fixed speed (100 Mbps Full Duplex).

    If the switches are not auto sensing it could also be a connection issue. You may need to check the manual for the correct way (cables / ports) to connect the devices (unlikely though, I expect your switches to be auto sensing since they are brand new)
    Saturday, December 12, 2009 1:27 AM
    Moderator
  • Thanks. What I'll do tonight (after the Christmas shopping) is remove the switch from next to the TV and, instead, place it next to the router so that every piece of equipment has direct access to all others through a gigabit connection. This way, I'm bypassing the router. I didn't really want to downgrade my network to 100 but perhaps I might have to try that also.


              upstairs             |       downstairs
                                       |

    WHS-----GIG SWITCH------GIG SWITCH-----TV
                                                   ¬
                                               ROUTER
                                                   ¬
                                              INTERNET

    The problem with this is that I won't be able to connect the PS3 without unconnecting the TV. So that's another 20 quid to buy yet ANOTHER switch.

    I'll report back later and let you know.
    Saturday, December 12, 2009 1:39 PM
  • Right, done that, and I thought I'd let you know that the TV works perfectly!! So it must be something to do with the router (as you guys suggested), probably because it's not gigabit. I'm glad that's sorted but now I guess I have to buy another switch :-(

    I still can't figure out why the PS3 always worked though (oh, yeah...*thinking out loud* probably because it was gigabit, or maybe because it is listed as a default upnp item within my router) I'll never know!

    thanks again for your help guys :-)

    Saturday, December 12, 2009 9:08 PM
  • Glad you fixed it.
    Sunday, December 13, 2009 9:19 AM
    Moderator