locked
Windows 7 Pro 64 and WHS Connector Problems RRS feed

  • Question

  • I just installed Windows 7 Pro 64 bit and I am having problems running WHS connector.  During installation I get "not responding" messages when it looks for the WHS and every screen after it.  It created the share folder and I can open the folder after I enter the name and password. 

    The console will not run.  I have been able to periodically get it to run but most of the time it hangsup immediatly after I enter the password.  When it hangs I do not get the progress bar.  The WHS icon is green and says the network is healthy. 

    I am running Windows Firewall on the home server and the Windows 7 PC
    I have enabled ingoing and outgoing TCP 55000 and 56000 on both firewalls (the server was already setup)
    I am using a Linksys BEFSR41V3 router. 
    Also, I took by old PC, which was running Windows XP PRO SP3, and converted it to the WHS.

    Please advise.
    Monday, November 16, 2009 3:27 AM

All replies

  • Which version does your home server show in Settings/Ressources on the console?
    Did you try installing the connector software from http://yourservername:55000?

    Best greetings from Germany
    Olaf
    Monday, November 16, 2009 10:42 AM
    Moderator
  • Hello Olaf,

    Thank you!  I appreciate your help.

    I have a shared folder and the Windows Home server Icon is green and says the network is health on my Windows 7 PC.  I always see this even when I cannot connect. 

    I copied the connector software from the software folder on the share.  The connection fails when I use http://yourservername:50000 (when I am able to connect the console, this may work.)

    The connection using the console is intermittent.  Ok, I was finally able to connect.  I am running version 6.0.2030.2.

    I could not connect for 2 days.  I installed the Windows home server Tool Kit and I was able to connect immediately after installing it.  I closed the console and tried again and could not connect. 

    I just ran the Connector Troubleshooter and received 12 errors.  I have looked at every one and could not find a problem.   After I ran the troubleshooter, I was able to connect.   When I run the troubleshooter while the console is connected I get these errors:

    1. Cannot connect to the server internal Web site (password hint page)
    2. Cannot connect to the server secure internal Web site
    3. Cannot connect to the server internal Web site (simple page)
    4. Cannot connect to the server internal Web site (ASPX page) 

    I have done nothing to the server or my router during this time. 

    I disabled the Windows firewall on my Window 7 PC and still was not able to connect. 

    Please let me know what else I can provide

    Greetings from Texas!

    Tuesday, November 17, 2009 1:53 AM
  • The connection fails when I use http://yourservername:50000
    that address is wrong (I assume you replaced yourservername with the name of your server) 55000 is the number, as I wrote).
    Is the server a self built model?
    If so and it has a built in NVidia card, drivers may play a role (see the FAQ How to handle error message “The Password is incorrect” attempting console access).

    The other reason, messed up IIS settings, often caused by applying Windows Updates not via console, but directly from desktop or by installing additional applications on WHS could explain, that the internal website cannot be accessed. In this case often ASP.Net needs to be changed back to version 2.x in the various pages in Internet Information Services on the server.
    To see, if this is the case, login locally to the server and run http://localhost:55000/enrollid/id.aspx  in Internet Explorer. The last line shows the configured version of ASP.NET.

    (A server reinstall is the only supported method to fix such issues, but reconfiguring IIS manually also works, if you know, what you do.)
    Also check the event log of the server for error messages.

    Best greetings from Germany
    Olaf
    Tuesday, November 17, 2009 7:11 AM
    Moderator
  • Hello Olaf,

    Thanks for replying and giving me your input.

    In my reply above I made a typo and it should have been http://yourservername:55000 and I did use my server name.  Sometimes this will work and sometimes not.

    This is a home built server.  The video card is a NVidia, but I do not install any drivers.  I remove the card when it stands alone.  When I put the card in it asks to install the drivers and I don't let it.   It is using the native driver for the video card.

    Tonight I'll check the ASP.NET version.

    I obtained the software by downloading the trial version from Microsoft's website.  I downloaded WHS DVD.ISO version 1.0 and burned an ISO image on a CD.  I loaded the software from the CD with a connection to the internet.  After the installation, I removed the video card and restarted.  I installed the connector software from the CD onto my Windows 7 PC and connected to the server.  Using the console, I configured my PC and backup.  During this time I noticed that the server was downloading some updates.  Later I restarted the console and it said I have to install a new version of the Connector software.  I clicked on the share folder link on my Windows 7 desktop and in the software folder, there was new connector software.  I copied this software and pasted on my Windows 7 HD and installed it.  Since then I have been having problems with the Console. 

    Please advise.  Should I reinstall from the DVD.ISO version 1.0 or should I get the newer version and reinstall?  I'll have an update tonight on the ASP.NET version. 
    Tuesday, November 17, 2009 5:19 PM
  • Here are the results of run http://localhost:55000/enrollide/id.aspx.  I see the following:
    servid
    id followed by information
    admin  followed by information
    oobestatus followed by information
    oobeinprogressstatus followed by information
    path followed by information
    version 6.0.2030.0
    error/
    master followed by begin certificate with a many characters and then end certificate
    /serverid

    Also, the video card is using standard VGA graphics adapter and drivers from Microsoft.

    I opened IIS manager and looked under web service extension and found the following:

    ASP.NET V1.1.4322 allowed
    ASP.NET V2.0.50727 allowed

    Thanks for you help! Please advise.
    Wednesday, November 18, 2009 4:27 AM
  • Hello,
    if you replace the information with your own placeholders, how I am expected to help? Crystal ball?

    In IIS right click the WHS site and select Properties. Open the ASP.NET tab and check the ASP.NET version.
    Do the same on the Default Web Site. In both cases the version should be 2.0.50727.

    Best greetings from Germany
    Olaf

    Wednesday, November 18, 2009 10:33 AM
    Moderator
  • Thanks for you help. 
    Here are the results of run http://localhost:55000/enrollide/id.aspx.
     <?xml version="1.0" encoding="utf-8" ?>
    - <ServerId>
      <Id>{FC21528C-6B5D-4324-92CF-325BF27FFCDA}</Id>
      <Admin>LSGSERVER\Administrator</Admin>
      <OobeStatus>0</OobeStatus>
      <OobeInProgressStatus>0</OobeInProgressStatus>
      <Path>C:\Program Files\Windows Home Server\</Path>
      <Version>6.0.2030.0</Version>
      <Error />
      <Master>-----BEGIN CERTIFICATE-----
    MIICzgIBAzCCAooGCSqGSIb3DQEHAaCCAnsEggJ3MIICczCCAm8GCSqGSIb3DQEH
    BqCCAmAwggJcAgEAMIICVQYJKoZIhvcNAQcBMBwGCiqGSIb3DQEMAQYwDgQIPv38
    nV7gyNQCAgfQgIICKPxTjMi/obS9s81j+R5NsxSi00HGBXJnZ4Ih1H1YTo1XiV1u
    O2vmL5niX8P7X7oJJtWQTiuwagNfo5F0QzKSYOnrrSeQZF4I8stOAK81M96fpJob
    yy9FvjXJUggplNIty5uKjw5I1PCUO59nX2bcXVMlZyZs8iReB5wPX/uFDUCFubKC
    OqVfDMhWnU3qPhB8zB6ah9N941aLZWvqrliD5Kyq1kpkkfsrmQIFsQoufc7cxDch
    FJ+o5XwwY9ukOvWUChJoPbALwm0bQTUcTAQ0GZxmL/V2Xo5dCdSQ5keRQfAncWx0
    CL7ukgiV4pn8wSn8YBZAv4PKDSvU50659Js5u6b9TXLjT/7y6R9Sg8TCdI7dTetp
    WylbccKj1v6lnJibSg44fgGC9Cei/26pRzngXcFrJyx/a/lf7wvhObWVG8rLP5/d
    6Xk0ofz5JI7zeLP2rZVLtZ/aiiy3jA5jtxGlu5U/JosdfOC5tiLP2Z0PAQmKw9lr
    gC2HmkdXZZ5sa3AqQaQtEVAHoUFVD8p+kiJUpq0rcH05dOdfgSDKSsxPCaA3btNV
    1pr1vRESmpx9ClgShU/KJAnGBXjtxVkJDyjv1a7DbMD/vjReXUYeg6VwNfjG0kTp
    Ew/qOBnA9V36vtHReaJoTZOCU4BrtVgD3M+smbXvlRnfQNJwa/MikU4jWxwqSiha
    qR/H34p3swXUiWUXiUyFahioGRlQld8etkAhqjxqVghDWchHajA7MB8wBwYFKw4D
    AhoEFGgPxQF9MLzg7gFKEldEfJCh0g/bBBRlrOSSEL8R0mU3/Qbk3m1XSGRiuQIC
    B9A= -----END CERTIFICATE-----</Master>
      </ServerId>

    In IIS manager, I clicked on Web Sites and then right clicked the WHS site and select Properties and Default Web Site. Open the ASP.NET tab and check the ASP.NET version. The version was 2.0.50727 for both. 

    This may not be important, but I also right clicked on Web Sites and then the ASP.NET tab and the version was 1.1.4322 and it was grayed-out.

    Please advise.

    Greetings from Texas.



    Thursday, November 19, 2009 3:34 AM
  • The funny thing is now, that I cannot perform this command to verify what the message should contain on all three of my managed home servers. Each single one returns a Ressource cannot be found error.
    The version numbers you see in IIS  are correct (as on my systems), so this should not be the problem.
    There are now two serious options remaining (if nobody here has another hint) - perform a server reinstall or wait until 24th November to install Power Pack 3 via Windows Update and hope, that this will fix the behavior.
    Best greetings from Germany
    Olaf
    Thursday, November 19, 2009 10:50 PM
    Moderator